mintmenu application install: apturl crash

Archived topics about LMDE 1
Forum rules
User avatar
mfs
Level 1
Level 1
Posts: 31
Joined: Wed Jul 21, 2010 1:44 pm

mintmenu application install: apturl crash

Postby mfs » Thu Jul 21, 2011 6:10 pm

Hi,

on my LMDE 64bit system (up to date with the latest repo, but without the xserver and gnome3 updates), trying to use the application install feature of mintmenu fails:

Code: Select all

Traceback (most recent call last):
  File "/usr/bin/apturl-gtk", line 48, in <module>
    sys.exit(apturl.main())
  File "/usr/lib/python2.6/dist-packages/AptUrl/AptUrl.py", line 177, in main
    if not self.openCache():
  File "/usr/lib/python2.6/dist-packages/AptUrl/AptUrl.py", line 117, in openCache
    if self.cache._depcache.BrokenCount > 0:
AttributeError: 'apt_pkg.DepCache' object has no attribute 'BrokenCount'


As the same error appears when issuing

Code: Select all

apturl apt://foo
, I concluded that this is a problem with the apturl package I have installed (0.4.1ubuntu4 from latest). So I downloaded and installed 0.4.1ubuntu7.1 from the ubuntu maverick repo, but without success. As 0.4.2 from natty is only working with python >2.7.1 (while mine is 2.6), I did not try it.

Are there any hints on how to fix the issue?

mfs.

User avatar
clem
Level 15
Level 15
Posts: 5661
Joined: Wed Nov 15, 2006 8:34 am
Contact:

Re: mintmenu application install: apturl crash

Postby clem » Sat Jul 30, 2011 4:09 am

Hi,

This is a problem caused by the fact that the APT module was moved to python 2.7 in Debian testing. I can reproduce it here and we'll try to fix it in the coming weeks.
Image

hozomean
Level 1
Level 1
Posts: 33
Joined: Mon Jun 06, 2011 2:06 pm

Re: mintmenu application install: apturl crash

Postby hozomean » Mon Aug 01, 2011 8:18 pm

i've submitted patches to bug 798177 that should fix this issue.


Return to “Archive”

Who is online

Users browsing this forum: No registered users and 0 guests