Suspend display not working

Archived topics about LMDE 1
Forum rules
Level 1
Level 1
Posts: 6
Joined: Tue Jul 19, 2011 12:58 am

Suspend display not working

Postby trenthawkins » Wed Jul 27, 2011 2:40 am

Hi folks,

I'm running a HP dv6 with the follow specs:
Processor : 8x Intel(R) Core(TM) i7 CPU Q 720 @ 1.60GHz
Memory : 6064MB (865MB used)
Operating System : Linux Mint Debian Edition
Resolution : 1366x768 pixels
OpenGL Renderer : AMD Radeon HD 6500M/5600/5700 Series
X11 Vendor : The X.Org Foundation
Audio Adapter : HDA-Intel - HDA Intel
Audio Adapter : HDA-Intel - HD-Audio Generic
* I have a triple booting set-up, W7, LMDE, Mepis 11. I have an 8GB swap partition. I am running the fglrx ATI driver and have Compiz running.

I had my power management set to suspend the display after 30 minutes. Unfortunately every time it suspends the display, my computer locks up and i have to perform a hard reboot.

I know this happens when plugged into AC, but haven't tried it when unplugged and running off battery.

Is there an edit i need to do to my Xorg.conf file?

Any help appreciated.

User avatar
Level 9
Level 9
Posts: 2721
Joined: Mon Oct 05, 2009 12:53 am
Location: Formerly of Kentucky, the land of Mint Juleps

Re: Suspend display not working

Postby dawgdoc » Tue Aug 02, 2011 6:18 pm


There may be a simple solution. Go to > Menu > Preferences > Screensaver and untick Lock screen when screensaver is active. I can not now recall if this is still a persistent error and if it has be fixed. But in LMDE and LM9, this worked for me.

SYSTEM: Compaq Presario CQ62 -- Mint 17 Cinnamon
READING: Little Brother by Cory Doctorow

Return to “Archive”