lmde beeps(SOLVED)

Archived topics about LMDE 1
Locked
User avatar
podagee
Level 5
Level 5
Posts: 791
Joined: Mon Sep 26, 2011 1:45 pm
Location: hawaii

lmde beeps(SOLVED)

Post by podagee »

how do you get rid of the beeps when logging in and out of your system?i really would like to know so i could install it again.thanks in advance
this is a question for LMDE
Say it with me,"podagee,....(poh-duh-gee),"
got it?GOOD!

Toshiba Satellite P755-S5393 Intel i7
octo-core @ 2.20ghz
750gb hdd
8gb ram
Windows 8 PRO w/WMC 64bit

User avatar
podagee
Level 5
Level 5
Posts: 791
Joined: Mon Sep 26, 2011 1:45 pm
Location: hawaii

Re: lmde beeps(SOLVED)

Post by podagee »

heres what i did

restart beep
It is possible that your system gives a loud beep on restart so,
In terminal enter this:
echo "blacklist pcspkr" | sudo tee -a /etc/modprobe.d/blacklist
then,
sudo modprobe -r pcspkr
Say it with me,"podagee,....(poh-duh-gee),"
got it?GOOD!

Toshiba Satellite P755-S5393 Intel i7
octo-core @ 2.20ghz
750gb hdd
8gb ram
Windows 8 PRO w/WMC 64bit

zman58
Level 1
Level 1
Posts: 23
Joined: Sun Feb 12, 2012 6:26 pm

Re: lmde beeps(SOLVED)

Post by zman58 »

I just installed the latest LMDE 64-bit and did all updates. Blacklisting the pcspkr module did not work on my system, a DELL Latidute E6400. I had to do the following to get ALL of the beeps removed:

First remove beeps from gnome desktop including the gnome login screen. To do this i had to open the mixer, add the Beep device, and then mute it. Very easy to do, here are the steps.

Control Center – Hardware (section) – Sound (icon)

…This brings up the mixer which includes volume controls and some other items for audio input and output..

In the Sound mixer “Playback” tab, select “Preferences” and add in the “Beep” device. Then check the little speaker on the bottom of the “Beep” slider to mute the Beep. Now you will no longer have the annoying beep as you use the desktop (Gnome). This also removes the beep from the Gnome Greeter (the login screen).


In addition to this, I occasionally use a full screen terminal session with the Ctrl-Alt-F1 sequence. (Most people may not be using full screen terminal sessions so need not do the steps below.) To stop beeping in the full screen terminal session I had to do the following:

You will have to do this with root access (sudo)
Open up the file: /etc/inputrc
uncomment the following line or just place it in the file
set bell-style none


Now I no longer hear the annoying loud BEEP that my laptop speaker has.

User avatar
podagee
Level 5
Level 5
Posts: 791
Joined: Mon Sep 26, 2011 1:45 pm
Location: hawaii

Re: lmde beeps(SOLVED)

Post by podagee »

sorry my bad...this is for the 32bit version.i dont play with linux on any 64bit versions.
Say it with me,"podagee,....(poh-duh-gee),"
got it?GOOD!

Toshiba Satellite P755-S5393 Intel i7
octo-core @ 2.20ghz
750gb hdd
8gb ram
Windows 8 PRO w/WMC 64bit

Kinslayer
Level 1
Level 1
Posts: 2
Joined: Tue Mar 13, 2012 5:44 pm

Re: lmde beeps(SOLVED)

Post by Kinslayer »

zman58's solution works great, thanks!

Locked

Return to “LMDE 1 Archive”