Device Descriptor Error LMDE 64

Archived topics about LMDE 1
Forum rules
GSXR750L
Level 3
Level 3
Posts: 167
Joined: Fri Nov 27, 2009 9:31 pm

Device Descriptor Error LMDE 64

Postby GSXR750L » Wed Dec 29, 2010 4:32 pm

Everything seems to work fine but when I ran the live disc to install I got the following after post and I also get it everytime I start up having successfully installed LMDE 64

Code: Select all

Loading, please wait...
[    5.632021] usb 2-5: device descriptor read/64, error -62
[    5.916019] usb 2-5: device descriptor read/64, error -62
[    6.380021] usb 2-5: device descriptor read/64, error -62
[    6.664021] usb 2-5: device descriptor read/64, error -62
[    7.352020] usb 2-5: device not accepting address 6, error -62
[    7.936015] usb 2-5: device not accepting address 7, error -62
[    7.936048] hub 2-0:1.0: unable to enumerate USB device on port 5
[    8.424018] usb 2-10: device descriptor read/64, error -62
[    8.708021] usb 2-10: device descriptor read/64, error -62
[    9.168021] usb 2-10: device descriptor read/64, error -62
[    9.452021] usb 2-10: device descriptor read/64, error -62
[   10.140015] usb 2-10: device not accepting address 10, error -62
[   10.724020] usb 2-10: device not accepting address 11, error -62
[   10.724054] hub 2-0:1.0: unable to enumerate USB device on port 10
INIT: version 2.88 booting
Starting the hotplug events dispatcher: udevd.
Synthesizing the initial hotplug events...done.
Waiting for /dev to be fully populated..._


Its no problem but I was just wondering if anyone knows roughly why it happens. :D

User avatar
rivenathos
Level 6
Level 6
Posts: 1073
Joined: Wed May 06, 2009 7:32 am
Location: USA

Re: Device Descriptor Error LMDE 64

Postby rivenathos » Wed Dec 29, 2010 4:47 pm

That error message may be due to a USB device such as a battery backup, a printer, or a hub. I have seen similar messages before, and I heard it had something to do with one module loading before another one. In the end, everything loaded and worked. Unless you have non-functional hardware, I would probably not worry too much. Someone else may have a better explanation. I am only sharing what I have seen on my end. If I am mistaken, I would appreciate being corrected. :)

GSXR750L
Level 3
Level 3
Posts: 167
Joined: Fri Nov 27, 2009 9:31 pm

Re: Device Descriptor Error LMDE 64

Postby GSXR750L » Wed Dec 29, 2010 5:43 pm

Many thanks rivenathos its just I notice I never had it happen before with Julia or LMDE 32 so presume its some bug or something with 64 version maybe.

GSXR750L
Level 3
Level 3
Posts: 167
Joined: Fri Nov 27, 2009 9:31 pm

Re: Device Descriptor Error LMDE 64

Postby GSXR750L » Fri Feb 11, 2011 1:16 pm

I've found this temporary fix patch for:- unable to enumerate USB device on port HERE but I do not know where to place it to see if it solves my problem. Any help in suggesting an appropriate folder and file to look in would be appreciated, Thankyou :D

Code: Select all

---
From: Frans Pop <elendil@xxxxxxxxx>

usb core: lower severity of 'unable to enumerate USB device' message

This message is relatively common and in most cases can be safely
ignored. Lower its severity from 'err' to 'notice' so it is not printed
on the console when systems are booted with the "quiet" boot parameter.

Signed-off-by: Frans Pop <elendil@xxxxxxxxx>

diff --git a/drivers/usb/core/hub.c b/drivers/usb/core/hub.c
index 8eb4da3..ea1ef37 100644
--- a/drivers/usb/core/hub.c
+++ b/drivers/usb/core/hub.c
@@ -2756,7 +2756,7 @@ loop:
if (hub->hdev->parent ||
!hcd->driver->port_handed_over ||
!(hcd->driver->port_handed_over)(hcd, port1))
- dev_err(hub_dev, "unable to enumerate USB device on port %d\n",
+ dev_notice(hub_dev, "unable to enumerate USB device on port %d\n",
port1);

done:
--

CiaW
Level 3
Level 3
Posts: 170
Joined: Fri Sep 10, 2010 11:39 am
Location: Spokane Wash, USA

Re: Device Descriptor Error LMDE 64

Postby CiaW » Fri Feb 11, 2011 2:03 pm

I'm not an expert, but I just had to install a sound driver for my ibm thinkpad in Debian and part of the instructions included applying a patch enclosed in a diff file.

So I believe what you could do is create a file called whatever you want (such as usbcore) dot diff, i.e.: usbcore.diff and then paste all of what you quoted beginning with diff into the file and save it. Then run the command (as your normal user should work):

Code: Select all

patch -i usbcore.diff


And see if that works. If it gives you an error, it might be because part of what I did in earlier steps was install some alsa stuff as well as a package group called build-essential. HTH, if not maybe do a search for applying a diff patch on Debian might yield results, and/or someone who knows better will come along. :D

User avatar
DrHu
Level 17
Level 17
Posts: 7563
Joined: Wed Jun 17, 2009 8:20 pm

Re: Device Descriptor Error LMDE 64

Postby DrHu » Fri Feb 11, 2011 2:55 pm

That type of message is usually caused by the Linux detection sequencing via-a-vis the machine's BIOS, the BIOS detects, then the OS (kernel) takes over and re-enumerates devices detected by the OS on boot.

You could possibly use the kernel option irqpoll to fix the enumeration error of devices..
    That, of course: polling devices slows performance on boot

But since the machine/OS is working it shouldn't be that much of an issue..
--message is essentially informational only.
Last edited by DrHu on Fri Feb 11, 2011 3:02 pm, edited 2 times in total.

GSXR750L
Level 3
Level 3
Posts: 167
Joined: Fri Nov 27, 2009 9:31 pm

Re: Device Descriptor Error LMDE 64

Postby GSXR750L » Fri Feb 11, 2011 4:58 pm

CiaW thankyou :D I will have to do some more re-searching and maybe attempt something.

DrHu thankyou too :D I don't know what irqpoll is so I did a quick search and came up with a clue of putting irqpoll into /etc/default/grub

GRUB_CMDLINE_LINUX_DEFAULT="quiet"
GRUB_CMDLINE_LINUX=""

I tried it here

GRUB_CMDLINE_LINUX_DEFAULT="quiet irqpoll"
GRUB_CMDLINE_LINUX=""

then here

GRUB_CMDLINE_LINUX_DEFAULT="quiet"
GRUB_CMDLINE_LINUX="irqpoll"

then sudo update-grub but neither worked - problem is I haven't a clue what anything means so I will go away and do a lot more Googling :mrgreen:


Return to “Archive”

Who is online

Users browsing this forum: No registered users and 0 guests