smoothing out LMDE64's edges

Archived topics about LMDE 1
Forum rules
User avatar
Level 3
Level 3
Posts: 146
Joined: Tue Dec 07, 2010 12:05 am

smoothing out LMDE64's edges

Postby TheGreatSudoku » Mon Dec 27, 2010 12:26 pm

This will be a running journal of my installation and tweaking of LMDE64 to get it to the "minty-fresh" state I enjoy. Your mileage may vary. I will not be inflammatory in this thread nor will I troll. All criticism is offered as constructive. Feedback is welcomed:

Day 0: First attempt at installing LMDE64. Taken back by lack of ReiserFS support. Downloading Reiserfsprogs using the live DVD gives an option to format to ReiserFS, but in practice it doesn't work. My /home is ReiserFS. While the live DVD handles reading the FS fine, once installed to the HD, LMDE64 complains about a bad superblock on my /home partiton. I tried keeping it and installing Reiserfsprogs AFTER install. Ran a reiserfsck and LMDE64 still kept complaining about a bad superblock. Gave up a decided the best way to proceed is to back up the contents of my /home directory, reformat it as ext4, install LMDE64 and then restore my important files, config and otherwise.

suggestion to devs : for future releases of LMDE64 consider adding support for ReiserFS and XFS... People still use these filesystems; they have been a de-facto standard in linux along-side the ext for years. This would placate more intermediate-advanced linux geeks like me,

Day 1: Backed up my /home files to USB sticks. Installed LMDE64 with separate / and /home partitions, both ext4. From a fresh install...

The Good: my sound card, compiz, cups .. pretty much everything that Ubuntu had broken is working as it should in Debian.
The Bad: Grub boot screen, and no splash-screen during boot-up.
suggestion to devs: I seem to remember Parsix having a really cool looking Grub screen. Perhaps borrow from that?
The Ugly: Emerald, but we'll get to that later.

Making LDME more livable:

A. I first restored my .mozilla, .skype, and .purple folders
B. I re-installed my gtk theme (purpleglossed), my icon set (MaXo Remix), and my pointer (Kubuntaero).
C. I edited /etc/apt/sources.list, choosing a closer debian and debian-multimedia server and upgrading both from testing to sid. I then ran a dist-upgrade (I prefer faster file updates and newer programs. And Debian unstable is a lot more reliable than what Ubuntu considers release-ready)
D. I noticed my system time was WAY off even though I had specified my region during install. I installed ntpdate to correct this.
suggestion to devs: have ntpdate installed in a defualt installation.
E. Quick search in synpatic was greyed out. To enable it I have to install apt-xapian-index and then update it from command line.
suggestion to devs: include apt-xapian-index as a package for default install. Synaptic without the quick search functionality is downright frustrating.
F. Used Synaptic to set fastest Mint mirror for future updates/downloads.

G is for GnoMenu! It installed without incident from the Ubuntu PPA:
1.add deb maverick main to /etc/apt/sources.list
2.sudo gpg --keyserver --recv-keys F45E32D195B47D2A
3.sudo gpg --armor --export 95B47D2A | sudo apt-key add -
4. no more annoying missing GPG messages... install GnoMenu through synaptic.

H. More reliable replacements. I've had Brasero and Transmission fail me horribly in the past, so I replaced them with Vuze and K3B.
I. Remove un-needed programs through synaptic such as xservers for video cards I don't have, firmware blobs for devices I don't have

J.Attempted to install experimental compiz plugins outlined here:
failed to recognize compiz was installed. I worked around this by booting into a a live CD of Mint 9, running the script using the live CD, then copying the .compiz folder to my USB stick and restoring the folder in my LMDE64 install.

K. restored my wallpapers folders. Enabled compiz wallpapers, set 4 of them, set the cube caps, set skydome. gconf-editor to tell nautilus to not show the desktop, and voila, a globe that rotates into multiple desktop wallpapers is working again for the first time since linux Mint 9!

Points I'm still stumbling with...

1. Emerald. The repository is down. I don't WANT to use the repository of shame because I have reservations about using a repo that hasn't been maintained for two years. Will patiently wait to see if comes back up
suggestion to devs: include Emerald in the default install or at the very least put it in the mint repository. It should be treated like Firefox, something users want that Debian doesn't officially provide.

2. Nautilus-Elementary ... the Ubuntu PPA is hazardous for Debian's health for a number of reasons:
a. what it sees as "broken packages" due to dependencies only satisfied in Ubuntu repos
b. upgrading to this PPA version of Nautilus would remove several core and meta Mint packages, which I fear would keep me from receiving future mint updates.

3. Boot and Splash screens, but these are fairly minor.

So far LDME is a breath of fresh air. It is rough around the edges and takes some tinkering, but at least it is free from Ubuntu's "let's break what's working" philosophy.
↯Acer Aspire 7730 17" laptop ↝ Intel Core Duo 2.00Ghz x2  4gig DDR2 RAM ⤗ Intel Mobile 4 Graphics ➫ Kernel: 3.2.0-14-liquorix ZEN SMP PREEMPT x86_64  Linux Mint Debian Edition using Sid Repositories ⇨ KDE 4.7.4 ⟿ Installed: 11/23/2010↯

User avatar
Level 3
Level 3
Posts: 146
Joined: Tue Dec 07, 2010 12:05 am

Re: smoothing out LMDE64's edges

Postby TheGreatSudoku » Fri Jan 07, 2011 9:56 am

Day 13: Hammering out the "fine" points of Splashy.

I got irked that Splashy didn't work out-of-the-repo-box. Kept complaining about "multiuser systems", "runlevels", and my "framebuffer not correctly configured".

1.) I edited /etc/default/grub to contain the following two lines:

Code: Select all


This gave me nice crisp resolution on my grub menu and my console bootup, but splashy was still throwing a hissy-fit saying my framebuffer wasn't configured properly.

2.) After much googling I implemented the following tweaks:

A. commented out my previous addtions to /etc/default/grub, opting to append the following line in the same file

Code: Select all

GRUB_CMDLINE_LINUX=" splash vga=791"

B. added the following (video card specific) lines to /etc/initramfs-tools/modules :

Code: Select all

i915 modeset=1

I am guessing a COLD-BOOT here would have solved things, something with rebooting never cleared the framebuffer properly and I ran into a TON of problems. I ended up restoring back to this point and things just magically worked after turning the computer off last night and rebooting this morning.

I ended up installing hwinfo to try to squeeze the max framebuffer resolution out of grub and the console I possible could. 0x0318 in combination with commenting out my additions to /etc/initramfs-tools/modules worked for about 20 seconds during boot. Splashy would get to about 20% then the screen would go black and I'd never get a GDM screen.

I went into PANIC mode.. booted from the LMDE64 live CD, created a /mnt folder for my installed / partition. chrooted to it. Put /etc/initramfs-tools/modules and /etc/defualt/grub back the way I listed them above. Then I tried update-grub form my chroot. No dice, it was bickering about /dev not being installed properly... I tried dpkg-reconfigure grub-pc .. it failed too... I decided to reboot and take my chances that grub might now be totally trashed. Thankfully it wasn't and I booted into GDM which hung and never gave me a login screen. I cnrtl-alt-F1-ed my was to a terminal, logged in, updated grub, rebooted and...

UGH Splashy was displaying correctly, but not centered! It was in the upper left-hand corner of the screen. By that point of the night I just gave up and shut the thing off and went to bed. This morning when I boot up my laptop splashy is working fine, centered and all.

While Ubuntu needs to take serious notes from Debian on package stability, Debian needs to take serious noted from Ubuntu on user-friendliness!
↯Acer Aspire 7730 17" laptop ↝ Intel Core Duo 2.00Ghz x2  4gig DDR2 RAM ⤗ Intel Mobile 4 Graphics ➫ Kernel: 3.2.0-14-liquorix ZEN SMP PREEMPT x86_64  Linux Mint Debian Edition using Sid Repositories ⇨ KDE 4.7.4 ⟿ Installed: 11/23/2010↯

Return to “Archive”