Linux Mint Debian

Archived topics about LMDE 1
Forum rules
newyorkpaulie
Level 2
Level 2
Posts: 84
Joined: Tue Mar 09, 2010 6:23 pm

Linux Mint Debian

Postby newyorkpaulie » Sun Oct 10, 2010 3:56 pm

In Mint 8 my user password worked when signing on as root. With LMDE it does not. Is there a way to logon as root? Is there a password already in place with an install?
Dual-booting LM17.3Rosa-64bit - Win10-64bit on a T61 ThinkPad.

User avatar
Oscar799
Level 19
Level 19
Posts: 9408
Joined: Tue Aug 11, 2009 9:21 am
Location: United Kingdom

Re: Linux Mint Debian

Postby Oscar799 » Sun Oct 10, 2010 4:17 pm

Moved here from Newbie Questions
Image
"Don't fix it if it ain't broken,don't break it if you can't fix it" Husse
Registered Linux User #511789

indaymadel
Level 2
Level 2
Posts: 87
Joined: Thu Sep 30, 2010 8:57 pm
Contact:

Re: Linux Mint Debian

Postby indaymadel » Sun Oct 10, 2010 5:53 pm

newyorkpaulie wrote:In Mint 8 my user password worked when signing on as root. With LMDE it does not. Is there a way to logon as root? Is there a password already in place with an install?


What do you mean signing on as root? Login as root? I think you login from your user account with password. Then do sudo command to run administrative commands.
Other than that, you can do "sudo -i" to actually change to root.
Get started building backlinks using my free backlinks collection.

newyorkpaulie
Level 2
Level 2
Posts: 84
Joined: Tue Mar 09, 2010 6:23 pm

Re: Linux Mint Debian

Postby newyorkpaulie » Sun Oct 10, 2010 6:22 pm

indaymadel wrote:
newyorkpaulie wrote:In Mint 8 my user password worked when signing on as root. With LMDE it does not. Is there a way to logon as root? Is there a password already in place with an install?


What do you mean signing on as root? Login as root? I think you login from your user account with password. Then do sudo command to run administrative commands.
Other than that, you can do "sudo -i" to actually change to root.
I meant logging in as "root" and then when asked for password, my user password sufficed.
Dual-booting LM17.3Rosa-64bit - Win10-64bit on a T61 ThinkPad.

craigevil
Level 5
Level 5
Posts: 554
Joined: Wed Sep 15, 2010 6:10 am
Location: down the rabbit hole
Contact:

Re: Linux Mint Debian

Postby craigevil » Sun Oct 10, 2010 9:40 pm

Change GDM's settings.

#sudo
[type pass]
#gdmsetup
Configure gdm and allow it to login as root

Although why anyone would ever need to run Gnome or any other DE/wm as root is beyond me.

Not only is it not a bad idea, it is also a good way to trash your system.
Debian Sid KDE4.8.4 Kernel 3.4 Thinkpad R40 CPU Pentium M 1.3MHz RAM 2GB ATI Mobility 7500
Debian - "If you can't apt-get something, it isn't useful or doesn't exist"
Giant Debian sources.list | Debian upgrade script smxi | sysinfo script inxi

User avatar
LarryP
Level 3
Level 3
Posts: 119
Joined: Wed Jul 21, 2010 12:28 pm

Re: Linux Mint Debian

Postby LarryP » Mon Oct 11, 2010 8:49 pm

Have t go with craig's assesment on this reading scorp123 post in a simalar thread about 3 years ago. He told how in his first year working with one of the distro's in the owrkplace accidently wiping the hard driveof a server while doing admin work in a desktop. As he said that day he learned the importance of complete backups :D
TANSTAAFL There ain't no such thing as a free lunch

User avatar
Lolo Uila
Level 5
Level 5
Posts: 576
Joined: Thu Mar 15, 2007 3:40 am
Location: Kapolei, Hawaii

Re: Linux Mint Debian

Postby Lolo Uila » Tue Oct 12, 2010 8:55 am

Mint (Ubuntu) never allowed root login by default (root account has a random password and root login to the GUI is disabled). You must have set the root password yourself and enabled GUI login in Mint-8.

As others have said, it's pointless and generally a bad idea to login to the GUI as root. There is simply no need to do that. Learn to use sudo in the terminal.

msuggs
Level 5
Level 5
Posts: 880
Joined: Thu Jul 10, 2008 8:25 am
Location: non-local
Contact:

Re: Linux Mint Debian

Postby msuggs » Tue Oct 12, 2010 3:30 pm

Lolo Uila wrote:Mint (Ubuntu) never allowed root login by default (root account has a random password and root login to the GUI is disabled).

Ubuntu yes, Mint no. Mint sets the root password to be the same as the user password. You can test this by using 'su' (not sudo su) to start a root terminal or logging in to webmin which needs root as the account to make changes to printers. Graphical login is disabled though.
Lolo Uila wrote: As others have said, it's pointless and generally a bad idea to login to the GUI as root. There is simply no need to do that. Learn to use sudo in the terminal.

+1

User avatar
gotjazz
Level 4
Level 4
Posts: 383
Joined: Fri May 28, 2010 11:38 am
Location: Vienna, Austria

Re: Linux Mint Debian

Postby gotjazz » Wed Oct 13, 2010 6:33 pm

or gksu if you really need something graphical to to have root access
Image

vincent
Level 8
Level 8
Posts: 2218
Joined: Tue Feb 09, 2010 4:10 am

Re: Linux Mint Debian

Postby vincent » Wed Oct 13, 2010 7:32 pm

If you want to give your root account a password: https://help.ubuntu.com/community/RootSudo#Enabling%20the%20root%20account

Code: Select all

sudo passwd root
Debian Testing x64/LM9 Main x64/Windows 7 x64 - LG R580 laptop w/ Intel Core 2 Duo T6500 2.1 GHz, 4 GB DDR2 RAM, Nvidia Geforce G 105M, Ralink rt2860 802.11n, 300 GB WD HD 5400 rpm

alan_newbie
Level 1
Level 1
Posts: 3
Joined: Tue Nov 02, 2010 5:36 pm

Re: Linux Mint Debian

Postby alan_newbie » Tue Nov 02, 2010 5:50 pm

sudo passwd root which you will be familiar with from ubuntu ( & LM 9, LM 10) to set root password
for LMDE open terminal as root
backup these two files first
/etc/pam.d/gdm3
/etc/pam.d/gdm3-autologin

open these files with gedit in root to edit
comment (add #) this line in each file as below
#auth required pam_succeed_if.so user != root quiet_success
save files and login as root

cwsnyder
Level 6
Level 6
Posts: 1242
Joined: Wed Oct 20, 2010 6:49 am
Location: Nappanee, IN, USA

Re: Linux Mint Debian

Postby cwsnyder » Mon Nov 08, 2010 11:56 am

When I need root access for a series of commands, I simply open a terminal and type

Code: Select all

sudo bash
then enter the CLI commands, for example, you might want/need to change file permissions/ownership on files moved from another machine or use apt-get/aptitude for updates. You could also use update-manager followed by

Code: Select all

apt-get autoclean
to clean up your code cache.

You can move things around with CLI commands or type

Code: Select all

sudo nautilus
or

Code: Select all

sudo pcmanfm
or whatever your favorite file manager is to simply right click on the files to change permissions/ownership as an alternative.
LMDE Mate 64-bit, LM17.3 Cinnamon 64-bit
Debian Mate 64-bit, Xubuntu xenial 64-bit, Ubuntu-Mate 14.04 64-bit, Antergos Xfce 64-bit, PCLinuxOS Mate 64-bit

User avatar
Fred
Level 10
Level 10
Posts: 3351
Joined: Fri Jan 04, 2008 11:59 am
Location: NC USA

Re: Linux Mint Debian

Postby Fred » Mon Nov 08, 2010 1:31 pm

cwsnyder,

You should never try to run a GUI program using sudo. Doing so can and will, over time, break your desktop in multiple seemingly random ways. Use gksu or kdesu instead of sudo for GUI programs run as root.

Fred
Insanity: Doing the same thing over and over and each time expecting a different result.

Democracy is 2 wolves and a lamb voting on the menu. Liberty is an armed lamb protesting the electoral outcome. A Republic negates the need for an armed protest.

cwsnyder
Level 6
Level 6
Posts: 1242
Joined: Wed Oct 20, 2010 6:49 am
Location: Nappanee, IN, USA

Re: Linux Mint Debian

Postby cwsnyder » Mon Nov 08, 2010 9:27 pm

Fred wrote:cwsnyder,

You should never try to run a GUI program using sudo. Doing so can and will, over time, break your desktop in multiple seemingly random ways. Use gksu or kdesu instead of sudo for GUI programs run as root.

Fred

:oops: Thanks for the warning. I hadn't run into that information before.
LMDE Mate 64-bit, LM17.3 Cinnamon 64-bit
Debian Mate 64-bit, Xubuntu xenial 64-bit, Ubuntu-Mate 14.04 64-bit, Antergos Xfce 64-bit, PCLinuxOS Mate 64-bit


Return to “Archive”

Who is online

Users browsing this forum: No registered users and 0 guests