I've Lost My Compiz Effects How do I get them back

Archived topics about LMDE 1
Forum rules
nbob
Level 1
Level 1
Posts: 17
Joined: Fri Nov 12, 2010 11:45 pm

I've Lost My Compiz Effects How do I get them back

Postby nbob » Sun Nov 14, 2010 1:50 pm

Hello, I'm running a dual boot with Windows7 and LinuxMint Debian.

I had my compiz 3d effects working fine but upon rebooting this morning, the effects are no longer happening. I checked CCSM and everything is still checked. I tried installing the fusion icon and using it to reload my window manager and still nothing. Any help would be appreciated. Thanks. :(

nbob
Level 1
Level 1
Posts: 17
Joined: Fri Nov 12, 2010 11:45 pm

Re: I've Lost My Compiz Effects How do I get them back

Postby nbob » Mon Nov 15, 2010 2:19 am

Hello. I did do the large first-time update. This may have caused compiz to trip up.

I reinstalled my video driver, then Alt+F2 and "compiz" and things are working again now.

User avatar
blowtorch
Level 3
Level 3
Posts: 100
Joined: Sun Sep 05, 2010 10:03 pm

Re: I've Lost My Compiz Effects How do I get them back

Postby blowtorch » Tue Nov 16, 2010 12:13 am

nbob wrote:Hello. I did do the large first-time update. This may have caused compiz to trip up.

I reinstalled my video driver, then Alt+F2 and "compiz" and things are working again now.


you may need to create a "startup application" entry with the command

Code: Select all

compiz --replace

bensoliman
Level 1
Level 1
Posts: 47
Joined: Thu Oct 21, 2010 9:27 am

Re: I've Lost My Compiz Effects How do I get them back

Postby bensoliman » Wed Nov 17, 2010 7:08 am

just want to know
what's the difference between running compiz with "--replace" at the end?
in addition, once you activate compiz, how do you disable it without restarting?

thanks
Dual Boot LMDE 20110101 / openSUSE 11.4 Gnome
emachines em250 netbook 10.1" N270 1GB 160GB 6 cell

User avatar
richyrich
Level 16
Level 16
Posts: 6798
Joined: Mon May 04, 2009 8:31 pm

Re: I've Lost My Compiz Effects How do I get them back

Postby richyrich » Wed Nov 17, 2010 8:29 am

@bensoliman
1) It is replacing the one currently being used.
2) From a terminal : (for gnome)

Code: Select all

metacity --replace


ps: please do not hijack other member posts . . start your own in the appropriate sub-forum. :)
Image

bensoliman
Level 1
Level 1
Posts: 47
Joined: Thu Oct 21, 2010 9:27 am

Re: I've Lost My Compiz Effects How do I get them back

Postby bensoliman » Wed Nov 17, 2010 7:33 pm

ok :oops:
Dual Boot LMDE 20110101 / openSUSE 11.4 Gnome
emachines em250 netbook 10.1" N270 1GB 160GB 6 cell

User avatar
blowtorch
Level 3
Level 3
Posts: 100
Joined: Sun Sep 05, 2010 10:03 pm

Re: I've Lost My Compiz Effects How do I get them back

Postby blowtorch » Fri Nov 19, 2010 1:42 pm

bensoliman wrote:just want to know
what's the difference between running compiz with "--replace" at the end?
in addition, once you activate compiz, how do you disable it without restarting?

thanks


metacity and compiz are both window compositing (effect) managers. metacity is the default gnome compositing manager. the "--replace" switches the compositing manager ...

when gnome starts it is using the metacity compositing manager by default so to start compiz you need to replace metacity

Code: Select all

compiz --replace


to deactivate compiz you need to replace it with metacity

Code: Select all

metacity --replace


Return to “Archive”

Who is online

Users browsing this forum: No registered users and 6 guests