Sysv-rc update error (workround available)

Archived topics about LMDE 1
Forum rules
User avatar
Fornhamfred
Level 6
Level 6
Posts: 1242
Joined: Wed Oct 31, 2007 3:38 pm
Location: Suffolk UK

Re: Sysv-rc update error (workround available)

Postby Fornhamfred » Sun Nov 28, 2010 2:58 am

Thanks all. Worked for me also.

simplon
Level 1
Level 1
Posts: 5
Joined: Sat Oct 30, 2010 11:29 pm
Location: Singapore

Re: Sysv-rc update error (workround available)

Postby simplon » Sun Nov 28, 2010 4:10 am

Works for me too. Is it recommended to keep Romeo enabled or disabled?
Image

User avatar
viking777
Level 14
Level 14
Posts: 5139
Joined: Mon Dec 01, 2008 11:21 am

Re: Sysv-rc update error (workround available)

Postby viking777 » Sun Nov 28, 2010 5:26 am

It depends on your attitude to risk doesn't it. I disabled it for a couple of reasons, first that was the way it was to begin with and second because LMDE is my main (though not only) distro, so I don't want to upset it with unstable packages, which is what romeo is supposed to contain. If it wasn't my main distro I would probably keep it enabled.

Only you can decide.
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).

bensoliman
Level 1
Level 1
Posts: 47
Joined: Thu Oct 21, 2010 9:27 am

Re: Sysv-rc update error (workround available)

Postby bensoliman » Sun Nov 28, 2010 7:05 pm

hi guys, this workaround just rocks :D

this is the first time I've wandered into the world of romeo
i have now entered... the out limits...

tunununununununu :lol:
Dual Boot LMDE 20110101 / openSUSE 11.4 Gnome
emachines em250 netbook 10.1" N270 1GB 160GB 6 cell

libssd
Level 4
Level 4
Posts: 289
Joined: Tue Jun 22, 2010 11:26 am

Re: Sysv-rc update error (workround available)

Postby libssd » Sat Dec 04, 2010 10:07 pm

I just got bitten by this bug on a netbook. From reading this thread, there seem to be three different "solutions":

1. Do nothing

2. Enable Romeo

3. Delete .depend.boot and .depend.start from init.d

It would be nice to get some more knowledgeable feedback on this.

In my case, LMDE is my "for fun" distro, running off an 8gb SDHC memory card; I have nothing of particular value on it, LMDE is just my sandbox for learning something different from Ubuntu, so I can afford to lose it, although I would prefer not to.

User avatar
mads
Level 6
Level 6
Posts: 1301
Joined: Wed Nov 03, 2010 3:44 pm
Contact:

Re: Sysv-rc update error (workround available)

Postby mads » Sat Dec 04, 2010 10:46 pm

Hi! The correct workaround is here (see last post by "Oz123"): https://bugs.launchpad.net/linuxmint/+bug/681238, but
I am almost sure that the latest updates (December 2nd, 2010) resolve this issue.

Unfortunately, there is a problem in mintdesktop 3.2.1, so you’ll need to run the following commands to ensure a smooth upgrade:
(SOURCE: http://blog.linuxmint.com/?p=1595)

Code: Select all

apt update
sudo rm /var/lib/dpkg/info/mintdesktop.prerm
apt install mintdesktop


Now, upgrade your system:

Code: Select all

sudo apt-get dist-upgrade

libssd
Level 4
Level 4
Posts: 289
Joined: Tue Jun 22, 2010 11:26 am

Re: Sysv-rc update error (workround available)

Postby libssd » Sat Dec 04, 2010 11:48 pm

Thanks, mads -- clear instructions. Everything seems to be clean now.


Return to “Archive”

Who is online

Users browsing this forum: No registered users and 0 guests