Crushing gdm on Nadia

Forum rules
Before you post please read how to get help
Level 1
Level 1
Posts: 2
Joined: Thu Feb 21, 2013 12:21 pm

Crushing gdm on Nadia

Postby renegate » Thu Feb 21, 2013 3:10 pm


I've tried to install Gnome3 on my fresh Mint 14 - Cinnamon system.
I've installed with apt-get and Synaptic too [gnome-shell, gnome-session], but neither worked. They produced the same crush problem.

While the installation prozess it asks for wich to use: gdm or mdm.
If I select mdm, the installation stops or somehow don't suceed.
So as I selected gdm.
  • When I singed out it popped out a window:
    Cannot start the greeter application, you will not able to log in. This display will be disabled.
    Try logging in by other means and editing the configuration file.
  • When I rebooted: It just simple hanged on after the Mint loading screen. Nothing works, no sings, no reactions...
As I've tryed to fix it or just sniffed around I've runned the gdm and it said only the root can run gdm(don't know it is normal or not).
With root permission it writed back: Failed to load session "ubuntu".
Another error message i've produced(don"t know how x)): gdm[4610]: WARNING: GdmLocalDisplayFactory: maximum number of X display failures reached: chek x server log for errors.

So somehow gdm can't get the Xserver display :(

Thanks for any help! :)

User avatar
Level 5
Level 5
Posts: 790
Joined: Fri Feb 26, 2010 10:16 am
Location: Middle of Nowhere

Re: Crushing gdm on Nadia

Postby bigj231 » Thu Feb 21, 2013 4:29 pm

You could try unitygreeter (my current favorite with my modified theme) or reinstall MDM. You need to get into your GRUB menu and select recovery or add something to the boot line (text-login I believe). Once you get in to the command line, use apt-get or aptitude to remove GDM then install whatever you want.
Running on a 4-slot toaster @ 60Hz

Level 1
Level 1
Posts: 2
Joined: Thu Feb 21, 2013 12:21 pm

Re: Crushing gdm on Nadia

Postby renegate » Tue Mar 05, 2013 11:09 am

The problem is that i want to run gnome3, and it needs gdm as i know.

Recently, I booted from a live USB with a persistence and tried to install on that gdm and it works!
So with the live USB it logs in automatically then i log out and ta daaa! The gdm gnome3 welcome screen awaits me.
I can log in and use the gnome3 desktop without any problem, so... don't know how can I fix it.

I use this installation guide for gnome3:
sudo apt-get install gnome-shell gnome-session gnome-tweak-tool gdm
sudo add-apt-repository ppa:webupd8team/gnome3
sudo apt-get remove gnome-control-center
sudo apt-get install gnome-control-center

it asks wich to use mdm or gdm i select gdm and at the next relog/reboot it crashes/hangs up.

Return to “Others”