USB Drive automounts after login

Forum rules
Before you post please read how to get help
Post Reply
gmakka
Level 1
Level 1
Posts: 5
Joined: Thu Jan 31, 2013 6:17 am

USB Drive automounts after login

Post by gmakka »

Hi Guys,

Installed linux mint 14 with mate the other day. Every time that i login, the connected USB drives automatically mount and a file browser pops up.

Whilist this is convient sometimes, 99% of the time, it's REALLY annoying :) Oh, and then when i logout and back in again, it then tells me that it can't mount the drive, because it's previously mounted else where

Is there a way to turn this off?

Thanks
Grant
User avatar
jungle_boy
Level 7
Level 7
Posts: 1739
Joined: Thu Aug 19, 2010 2:51 pm
Location: Amazon Rainforest

Re: USB Drive automounts after login

Post by jungle_boy »

Try:

Menu>Control Center>File Management>Media tab

Uncheck "Browse media when inserted"

Close

Reboot
Dell Inspiron 5480, Quad-core, Core I5 8th Gen, Geforce MX 150,
LM 20 Cinnamon
Trapper
Level 4
Level 4
Posts: 354
Joined: Sat Dec 03, 2011 12:21 pm
Location: North Port, Florida USA

Re: USB Drive automounts after login

Post by Trapper »

jungle_boy wrote:Try:

Menu>Control Center>File Management>Media tab

Uncheck "Browse media when inserted"

Close

Reboot
I think the OP may be more interested in preventing the auto mount of USB connected drives at login rather than the prevention of the file browser opening when the drive's mounted.
User avatar
jungle_boy
Level 7
Level 7
Posts: 1739
Joined: Thu Aug 19, 2010 2:51 pm
Location: Amazon Rainforest

Re: USB Drive automounts after login

Post by jungle_boy »

Trapper wrote: I think the OP may be more interested in preventing the auto mount of USB connected drives at login rather than the prevention of the file browser opening when the drive's mounted.
I tested and it works fine...
Dell Inspiron 5480, Quad-core, Core I5 8th Gen, Geforce MX 150,
LM 20 Cinnamon
mikkelbreiler
Level 1
Level 1
Posts: 3
Joined: Thu Mar 28, 2013 1:30 pm

Re: USB Drive automounts after login

Post by mikkelbreiler »

jungle_boy wrote:Try:

Menu>Control Center>File Management>Media tab

Uncheck "Browse media when inserted"

Close

Reboot
I want to turn this feature off too My USB hard drive tower is reactivated from power off rather often, without anything doe by me and every time this happens a window appears on top of what I am oing so I can click it away.

I have Linux Mint Cinnamon installed and if I select "Menu", at the bottom left I do not see anything labelled "Control Center". Where do I find "Control Center", "File Mangement" and the "Media" tab ?

-Mikkel
User avatar
DrHu
Level 17
Level 17
Posts: 7521
Joined: Wed Jun 17, 2009 8:20 pm

Re: USB Drive automounts after login

Post by DrHu »

Apart that it (a line entry ref: usb device) may be in /etc/fstab, the static mounts for devices: the usual location for inserted media is /media, hence you are allowed to alter its operation per device in that location
The media TAB mentioned, or you can use a file manager, whichever one you have, Cairo, nautilus, thunar (should be in menu(s) or as an ICON on your desktop)), and then a right-click-->properties will get data you can manage/change..
http://www.linuxlinks.com/article/20081 ... agers.html
http://www.maketecheasier.com/linux-fil ... 2010/04/29
Post Reply