Mate 1.6 released - Someone already tried?

Forum rules
Before you post please read how to get help
HardyH
Level 2
Level 2
Posts: 76
Joined: Wed Aug 03, 2011 7:02 pm

Re: Mate 1.6 released - Someone already tried?

Post by HardyH » Thu Apr 04, 2013 9:44 am

So how to upgrade Mint 14?
H.

AJ1000
Level 2
Level 2
Posts: 81
Joined: Mon Dec 12, 2011 5:10 am

Re: Mate 1.6 released - Someone already tried?

Post by AJ1000 » Thu Apr 04, 2013 9:50 am


HardyH
Level 2
Level 2
Posts: 76
Joined: Wed Aug 03, 2011 7:02 pm

Re: Mate 1.6 released - Someone already tried?

Post by HardyH » Thu Apr 04, 2013 9:54 am

Same repos like in the webupd8.org install guide. This does not work under Mint 14 MATE, tried it, the 1.4 packages stay up-to-date on Mint 14 with these sources.
H

AJ1000
Level 2
Level 2
Posts: 81
Joined: Mon Dec 12, 2011 5:10 am

Re: Mate 1.6 released - Someone already tried?

Post by AJ1000 » Thu Apr 04, 2013 9:56 am

My apologies, but then I can not help, as I am using Mint 13. Actually I have an idea, as I did this a long time ago when upgrading from 1.2 to 1.4 and had a similar problem. Try this documentation:

Latest MATE releases
-------------------------

If you want to try the latest MATE packages on LinuxMint, you can use the MATE repository for Ubuntu (or the MATE repository for Debian if you use LMDE). Once set up the repository, you need to edit the /etc/apt/preferences file as follow:

Note: This assumes you are using packages.mate-desktop.org. If you are using a different mirror, then use that instead.

Package: *
Pin: release o=linuxmint
Pin-Priority: 700

Package: *
Pin: origin packages.linuxmint.com
Pin-Priority: 700

Package: *
Pin: release o=Ubuntu
Pin-Priority: 500

Package: *
Pin: origin packages.mate-desktop.org
Pin-Priority: 700

HardyH
Level 2
Level 2
Posts: 76
Joined: Wed Aug 03, 2011 7:02 pm

Re: Mate 1.6 released - Someone already tried?

Post by HardyH » Thu Apr 04, 2013 10:14 am

Well, after reading this: http://mate-desktop.org/2013/04/02/mate-1-6-released/ I am sure, I will not use MATE 1.6.
Maybe a customized xfce 4.10 is my next desktop, MATE 1.6 certainly is not my new DE.
H.

AJ1000
Level 2
Level 2
Posts: 81
Joined: Mon Dec 12, 2011 5:10 am

Re: Mate 1.6 released - Someone already tried?

Post by AJ1000 » Thu Apr 04, 2013 10:21 am

HardyH,

That is a shame to hear, as mate 1.6 is working very well on my computer. I do not like Xfce, so each to their own. Good luck with your Xfce setup.

blackcap
Level 1
Level 1
Posts: 4
Joined: Wed Mar 06, 2013 6:24 pm

Re: Mate 1.6 released - Someone already tried?

Post by blackcap » Thu Apr 04, 2013 3:27 pm

For those who have upgraded to MATE 1.6, you can download mintmenu 5.4.0 from the Olivia repository (http://packages.linuxmint.com/pool/main ... .0_all.deb) and manually install it. Afterward, right click on an empty area of a panel, click on "Add to Panel...", then select "mintMenu" to add it to the panel.

I have done this on Mint Nadia/MATE 1.6, and I haven't had any issues with the Mint menu so far.

User avatar
joshg253
Level 1
Level 1
Posts: 11
Joined: Sat Jul 30, 2011 8:29 pm
Location: Bellevue, WA
Contact:

Re: Mate 1.6 released - Someone already tried?

Post by joshg253 » Fri Apr 05, 2013 2:36 am

blackcap wrote:For those who have upgraded to MATE 1.6, you can download mintmenu 5.4.0 from the Olivia repository (http://packages.linuxmint.com/pool/main ... .0_all.deb) and manually install it.
Thanks!

The horizontal separators in the Favorites Pane look a little funky but it works.

(Mint 14 x64 / kernel 3.8.5 / MATE 1.6)
Image

SPV
Level 1
Level 1
Posts: 13
Joined: Sat Jul 21, 2012 4:05 am
Location: RU

Re: Mate 1.6 released - Someone already tried?

Post by SPV » Fri Apr 05, 2013 3:44 am

blackcap wrote:I have done this on Mint Nadia/MATE 1.6, and I haven't had any issues with the Mint menu so far.
Thanks for this, but it's not working on Mint 13 i686 with MATE 1.6 upgraded from 1.4.2. Error with plugins "/usr/lib/mintmenu/plugins" occurs.

AJ1000
Level 2
Level 2
Posts: 81
Joined: Mon Dec 12, 2011 5:10 am

Re: Mate 1.6 released - Someone already tried?

Post by AJ1000 » Fri Apr 05, 2013 7:02 am

k357k9,

I do not know about being quicker but on my setup 1.6 felt smoother than 1.4. Bootup time etc was the same, so maybe it is the switch to gsettings.

AJ1000

HardyH
Level 2
Level 2
Posts: 76
Joined: Wed Aug 03, 2011 7:02 pm

Re: Mate 1.6 released - Someone already tried?

Post by HardyH » Fri Apr 05, 2013 7:07 am

MATE 1.6 just destroyed my other OS, Manjaro, I strongly recommend to stay away from that broken 1.6 stuff, it can destroy your whole OS!
H.

AJ1000
Level 2
Level 2
Posts: 81
Joined: Mon Dec 12, 2011 5:10 am

Re: Mate 1.6 released - Someone already tried?

Post by AJ1000 » Fri Apr 05, 2013 7:41 am

HardyH has not had much luck with mate 1.6, so best to do a backup with Remastersys or Clonzilla live, before attempting the upgrade. I have not had issues with it, but others have. I will be trying my Manjaro upgrade once I get home from work.

HardyH
Level 2
Level 2
Posts: 76
Joined: Wed Aug 03, 2011 7:02 pm

Re: Mate 1.6 released - Someone already tried?

Post by HardyH » Fri Apr 05, 2013 7:44 am

AJ1000 wrote:HardyH has not had much luck with mate 1.6, so best to do a backup with Remastersys or Clonzilla live, before attempting the upgrade. I have not had issues with it, but others have. I will be trying my Manjaro upgrade once I get home from work.

Good luck, you will need it....
H.

User avatar
riki
Level 4
Level 4
Posts: 448
Joined: Thu Jun 03, 2010 4:57 pm
Location: UK
Contact:

Re: Mate 1.6 released - Someone already tried?

Post by riki » Fri Apr 05, 2013 8:01 am

I am running Maya and I am experiencing problems since upgrading to Mate 1.6 (freezes, sluggishness and apps that don't work). Got better since doing a cleanup with Bleachbit and Janitor but still can't figure out how to restore the language icon on the taskbar. Also, when minimising pages they disappear. Any ideas? Thanks.
Riki

Image

Monsta
Level 10
Level 10
Posts: 3013
Joined: Fri Aug 19, 2011 3:46 am

Re: Mate 1.6 released - Someone already tried?

Post by Monsta » Fri Apr 05, 2013 8:48 am

HardyH wrote:MATE 1.6 just destroyed my other OS, Manjaro, I strongly recommend to stay away from that broken 1.6 stuff, it can destroy your whole OS!
H.
Don't panic, Manjaro in its current state has enough power to "destroy" itself after the update. :) I've experienced that once - another update went fine, but the system simply refused to boot afterwards. Anyway, MATE is just a desktop environment, it doesn't do anything with your kernel, or system libs, or other crucial parts of the OS.

User avatar
riki
Level 4
Level 4
Posts: 448
Joined: Thu Jun 03, 2010 4:57 pm
Location: UK
Contact:

Re: Mate 1.6 released - Someone already tried?

Post by riki » Fri Apr 05, 2013 9:17 am

riki wrote:I am running Maya and I am experiencing problems since upgrading to Mate 1.6 (freezes, sluggishness and apps that don't work). Got better since doing a cleanup with Bleachbit and Janitor but still can't figure out how to restore the language icon on the taskbar. Also, when minimising pages they disappear. Any ideas? Thanks.
This is terrible! Sooooo slow...how can I get back to the previous DE?
Riki

Image

HardyH
Level 2
Level 2
Posts: 76
Joined: Wed Aug 03, 2011 7:02 pm

Re: Mate 1.6 released - Someone already tried?

Post by HardyH » Fri Apr 05, 2013 9:18 am

Monsta wrote:
HardyH wrote:MATE 1.6 just destroyed my other OS, Manjaro, I strongly recommend to stay away from that broken 1.6 stuff, it can destroy your whole OS!
H.
Don't panic, Manjaro in its current state has enough power to "destroy" itself after the update. :) I've experienced that once - another update went fine, but the system simply refused to boot afterwards. Anyway, MATE is just a desktop environment, it doesn't do anything with your kernel, or system libs, or other crucial parts of the OS.
Sure, it's just a DE, but a DE update is not supposed to remove essential parts of the x-server, the mesa stack and the graphics driver.
H.

fromWinToLin
Level 2
Level 2
Posts: 77
Joined: Thu Nov 19, 2009 11:53 am

Re: Mate 1.6 released - Someone already tried?

Post by fromWinToLin » Fri Apr 05, 2013 9:51 am

Upgrading from MATE 1.4 to 1.6 on Linux Mint 13 ruined everything for me. I have to reconfigure all my settings, figure out what wasn't properly migrated, and now I no longer have the Mint Menu! My fonts are also messed up!

What happened? MATE 1.4 to 1.6? It feels like 1.4 to 2.0!

Why would those who maintain the MATE repository for Linux Mint go ahead with 1.6? It wasn't even ready yet, and it doesn't read the user's custom settings from 1.4!

UPDATE: Another problem I noticed with MATE 1.6 is that the "close" button in the upper-right corner no longer registers on maximized windows when you click in the very upper-right corner! You must precisely aim the mousr cursor directly over the button! This was not the case on MATE 1.4 or any other DE for that matter (Xfce, KDE, GNOME). Previously, I could just slam my mouse cursor all the way to the upper-right corner, without any precision, and easily close maximized windows. Not any more...
Last edited by fromWinToLin on Fri Apr 05, 2013 6:58 pm, edited 2 times in total.

User avatar
eanfrid
Level 7
Level 7
Posts: 1859
Joined: Mon Apr 30, 2012 2:49 am
Location: FR

Re: Mate 1.6 released - Someone already tried?

Post by eanfrid » Fri Apr 05, 2013 10:15 am

Replaced Cinnamon wih MATE 1.4 then upgraded to MATE 1.6, here on one of my LM13 three days ago. No problem worth to mention. MATE 1.6 works as well as 1.4 and the new desktop themes are quite good-looking. I also enabled compositing in marco and it works like a charm.
Main desktop: Debian GNU/Linux Jessie 64bit - MATE
(i5 2400@3.7GHz - 16GB DDR3 - HD6770 w/radeon driver - SSD+RAID1)
Safer than Dropbox

User avatar
riki
Level 4
Level 4
Posts: 448
Joined: Thu Jun 03, 2010 4:57 pm
Location: UK
Contact:

Re: Mate 1.6 released - Someone already tried?

Post by riki » Fri Apr 05, 2013 10:36 am

fromWinToLin wrote:Upgrading from MATE 1.4 to 1.6 on Linux Mint 13 ruined everything for me. I have to reconfigure all my settings, figure out what wasn't properly migrated, and now I no longer have the Mint Menu! My fonts are also messed up!

What happened? MATE 1.4 to 1.6? It feels like 1.4 to 2.0!

Why would those who maintain the MATE repository for Linux Mint go ahead with 1.6? It wasn't even ready yet, and it doesn't read the user's custom settings from 1.4!
I agree with you. Mine is a mess, if I'd known I would have stayed put and not upgraded. Big mistake.
Riki

Image

Post Reply

Return to “MATE”