Enable compiz on Mate in Mint 15????

Forum rules
Before you post please read how to get help
thirdrev
Level 1
Level 1
Posts: 5
Joined: Thu Jan 03, 2013 6:56 pm
Location: MN
Contact:

Re: Enable compiz on Mate in Mint 15????

Post by thirdrev »

Try: http://community.linuxmint.com/tutorial/view/1298

Follow the instructions exactly. Windows lose decoration till you click window decoration in CCSM and they won't move until you click Move... so make sure you enable all the basic window management functions. Once I did that It worked great for me.

and BTW Compiz isn't going anywhere, not until there's a comperable desktop cube application. Although it would be cool if it were built into KDE (or Mate) :D
Northern-Link Technology Management and Communications Consulting
www.northern-link.com
User avatar
viking1au
Level 3
Level 3
Posts: 130
Joined: Thu Jun 09, 2011 8:03 am
Location: Warburton, Victoria; AU.
Contact:

Re: Enable compiz on Mate in Mint 15????

Post by viking1au »

ruwan wrote:I don't know CompizConfig is installed successfully, but the functions are not working still.. It is disaster for me.. If it's not working I want to install Ubuntu 13.04. It works perfect on it.
I have just tried Zorin 6.3 and Wobbly Windows works out of the box, without trying to set it up. - I have been after wobbly windows since Mint 11. - Mint seem to have dumped it, so now I will try a few other distros. - Zorin semi-o.k. but a bit clunky.
User avatar
viking1au
Level 3
Level 3
Posts: 130
Joined: Thu Jun 09, 2011 8:03 am
Location: Warburton, Victoria; AU.
Contact:

Re: Enable compiz on Mate in Mint 15????

Post by viking1au »

catweazel wrote:
pgyure wrote:The links above will not work either. I've checked them before I came to the forum.
Certain functions are simply not working. I don't think we can do anything as the Team replaced the mateconf-editor with gsettings. Maybe that's the source of the problem...
The real problem is that compiz is pretty much dead. If you want wobbly windows, gliding dialog boxes, desktop cubes, and goodness knows what else desktop effects, wait for Mint 15 KDE and use that. It's all built-in, so there's no compatibility issues.

What happens for those who do not like KDE but love Mate? Are 'they' really that determined to push us to maybe a totally different distro.?
AnonXmous
Level 1
Level 1
Posts: 2
Joined: Sun Jul 21, 2013 5:57 pm

Re: Enable compiz on Mate in Mint 15????

Post by AnonXmous »

leonmaxx wrote:On my Mint 15 Mate I have installed latest experimental Compiz from Sam Spilsbury ppa, it's pretty simple and working:

Code: Select all

sudo apt-add-repository ppa:smspillaz/compiz-experimental
sudo apt-get update
sudo apt-get install compizconfig-settings-manager compiz
gsettings set org.mate.session.required-components windowmanager compiz
And re-login.
Thank you very much! Worked well. not perfect. Some features do not work, but the ones that do work great!!
:D :) 8) :lol: :P :wink: :mrgreen:
User avatar
viking1au
Level 3
Level 3
Posts: 130
Joined: Thu Jun 09, 2011 8:03 am
Location: Warburton, Victoria; AU.
Contact:

Re: Enable compiz on Mate in Mint 15????

Post by viking1au »

leonmaxx wrote:On my Mint 15 Mate I have installed latest experimental Compiz from Sam Spilsbury ppa, it's pretty simple and working:

Code: Select all

sudo apt-add-repository ppa:smspillaz/compiz-experimental
sudo apt-get update
sudo apt-get install compizconfig-settings-manager compiz
gsettings set org.mate.session.required-components windowmanager compiz
And re-login.
This does not do it.--What I have noticed is that on re-start, Wobbly Windows have gone. - On checking in Control Centre>Compiz Settings, I find that Snapping Windows has enabled itself, thereby cancelling Wobbly Windows. - This happens everytime, so I go to Snapping Windows & de-tick it, then go to Wobbly Windows & re-tick it. No worries, 'til the next re-start so I would like to find a way to permanently disable Snapping Windows.
User avatar
viking1au
Level 3
Level 3
Posts: 130
Joined: Thu Jun 09, 2011 8:03 am
Location: Warburton, Victoria; AU.
Contact:

Re: Enable compiz on Mate in Mint 15????

Post by viking1au »

AnonXmous wrote:
leonmaxx wrote:On my Mint 15 Mate I have installed latest experimental Compiz from Sam Spilsbury ppa, it's pretty simple and working:

Code: Select all

sudo apt-add-repository ppa:smspillaz/compiz-experimental
sudo apt-get update
sudo apt-get install compizconfig-settings-manager compiz
gsettings set org.mate.session.required-components windowmanager compiz
And re-login.
Thank you very much! Worked well. not perfect. Some features do not work, but the ones that do work great!!
:D :) 8) :lol: :P :wink: :mrgreen:
This does NOT do it.--What I have noticed is that on re-start, Wobbly Windows have gone. - On checking in Control Centre>Compiz Settings, I find that Snapping Windows has enabled itself, thereby cancelling Wobbly Windows. - This happens everytime, so I go to Snapping Windows & de-tick it, then go to Wobbly Windows & re-tick it.aok, 'til the next re-start so I would like to find a way to permanently disable Snapping Windows.
AnonXmous
Level 1
Level 1
Posts: 2
Joined: Sun Jul 21, 2013 5:57 pm

Re: Enable compiz on Mate in Mint 15????

Post by AnonXmous »

viking1au wrote:
AnonXmous wrote:
leonmaxx wrote:On my Mint 15 Mate I have installed latest experimental Compiz from Sam Spilsbury ppa, it's pretty simple and working:

Code: Select all

sudo apt-add-repository ppa:smspillaz/compiz-experimental
sudo apt-get update
sudo apt-get install compizconfig-settings-manager compiz
gsettings set org.mate.session.required-components windowmanager compiz
And re-login.
Thank you very much! Worked well. not perfect. Some features do not work, but the ones that do work great!!
:D :) 8) :lol: :P :wink: :mrgreen:
This does NOT do it.--What I have noticed is that on re-start, Wobbly Windows have gone. - On checking in Control Centre>Compiz Settings, I find that Snapping Windows has enabled itself, thereby cancelling Wobbly Windows. - This happens everytime, so I go to Snapping Windows & de-tick it, then go to Wobbly Windows & re-tick it.aok, 'til the next re-start so I would like to find a way to permanently disable Snapping Windows.
I do not have the problem you do. Wobbly windows works just fine, so do windows animations, and opacity, however, desktop cube does not work at all for me. I just set up Mint 15 KDE 32bit on another PC and it seems very stable, and has out-of-the-box customization similar to compiz.
User avatar
viking1au
Level 3
Level 3
Posts: 130
Joined: Thu Jun 09, 2011 8:03 am
Location: Warburton, Victoria; AU.
Contact:

Re: Enable compiz on Mate in Mint 15????

Post by viking1au »

ruwan wrote:I don't know CompizConfig is installed successfully, but the functions are not working still.. It is disaster for me.. If it's not working I want to install Ubuntu 13.04. It works perfect on it.
Disaster for me too, until I switched to Zorin 7 (Gnome). - 2 Mouse click and it works fine; 1: De-tick Snapping Windows & 2: Tick Wobbly Windows, in Compiz settings. -
valent
Level 1
Level 1
Posts: 26
Joined: Wed Dec 13, 2006 11:21 am

Re: Enable compiz on Mate in Mint 15????

Post by valent »

then I try "compiz --replace" I get windows without borders :( So no, compiz is now working, it is broken.
valent
Level 1
Level 1
Posts: 26
Joined: Wed Dec 13, 2006 11:21 am

Re: Enable compiz on Mate in Mint 15????

Post by valent »

Honest Mistake wrote:

Code: Select all

gsettings set org.mate.session.required-components windowmanager compiz
Be warned that this version of compiz has some issues, one of which (unclickable window borders on windows that start maximised) is particularly annoying and without a working work-around that I could find.
This is quite bad advice to give to people, because if compiz doesn't work you are screwed and with a broken desktop. It is much better to first test if compiz works.

You can do that with

Code: Select all

compiz --replace
and if it fails revert back to original window manager:

Code: Select all

marco --replace
if you made a mistake and replaced march with compiz as default manager revert it back:

Code: Select all

gsettings set org.mate.session.required-components windowmanager marco
Honest Mistake
Level 1
Level 1
Posts: 47
Joined: Mon Mar 05, 2012 4:40 am

Re: Enable compiz on Mate in Mint 15????

Post by Honest Mistake »

valent wrote:
Honest Mistake wrote:

Code: Select all

gsettings set org.mate.session.required-components windowmanager compiz
Be warned that this version of compiz has some issues, one of which (unclickable window borders on windows that start maximised) is particularly annoying and without a working work-around that I could find.
This is quite bad advice to give to people, because if compiz doesn't work you are screwed and with a broken desktop. It is much better to first test if compiz works.
Which is exactly what I said in the first part of my post that you quoted.

Anyway, about your problem - did you already check if window decoration plugin is on in ccsm? For some reason sometimes everything is just turned off by default.
Tonipt
Level 1
Level 1
Posts: 5
Joined: Mon Jun 10, 2013 7:50 am

Re: Enable compiz on Mate in Mint 15????

Post by Tonipt »

Here is a video that shows Compiz running on Linux Mint 15.

[url]http://videos.sapo.pt/hB86MtyHzZGAccTVhHPH[/url]
Tonipt
Level 1
Level 1
Posts: 5
Joined: Mon Jun 10, 2013 7:50 am

Re: Enable compiz on Mate in Mint 15????

Post by Tonipt »

Here is a temporary solution to the problem (bug) in Compiz 0.9.9,
which loses focus of the windows start maximized.

[url]http://videos.sapo.pt/ET7fcez9PgPQJtMzDItQ[/url]
Tonipt
Level 1
Level 1
Posts: 5
Joined: Mon Jun 10, 2013 7:50 am

Re: Enable compiz on Mate in Mint 15????

Post by Tonipt »

Tonipt wrote:Here is a temporary solution to the problem (bug) in Compiz 0.9.9,
which loses focus of the windows start maximized.

[url]http://videos.sapo.pt/ET7fcez9PgPQJtMzDItQ[/url]

I ended up found that, while not opting for the temporary solution mentioned above, there are some themes contour windows where the bug does not manifest. The themes are:

- Divinorum-Blue-OriginalSeed-1
- Crux
- AdwaitaWolfV4.

There may be more.
zcacogp
Level 1
Level 1
Posts: 44
Joined: Thu Nov 08, 2012 1:59 pm
Location: London, England

Re: Enable compiz on Mate in Mint 15????

Post by zcacogp »

Tonipt wrote:
Tonipt wrote:Here is a temporary solution to the problem (bug) in Compiz 0.9.9,
which loses focus of the windows start maximized.

[url]http://videos.sapo.pt/ET7fcez9PgPQJtMzDItQ[/url]

I ended up found that, while not opting for the temporary solution mentioned above, there are some themes contour windows where the bug does not manifest. The themes are:

- Divinorum-Blue-OriginalSeed-1
- Crux
- AdwaitaWolfV4.

There may be more.
Tonipt,

Thanks for this - your post has explained the problem I had with Compiz on Mint 15, and which led to me uninstalling it.

Armed with this knowledge I'll re-install it, so thank you (I was missing it!)

How big a bug is it? Or, putting it another way, is it likely to be solved in the near future? Are there to be future releases of Compiz? If so, are they likely to have resolved this bug in them?


Oli.
jlxsolutions
Level 1
Level 1
Posts: 3
Joined: Mon Aug 16, 2010 9:01 am

Re: Enable compiz on Mate in Mint 15????

Post by jlxsolutions »

having same problems actually nothing in compiz is working for me nothing i can see at least lol
pr well the default themes window buttons are now _ (square)X and not colored balls
other then that no difference mainly want cube to work for smooth navigation trough workspaces.
:cry:
leprechaun67
Level 1
Level 1
Posts: 1
Joined: Thu Oct 10, 2013 8:45 pm

Re: Enable compiz on Mate in Mint 15????

Post by leprechaun67 »

I followed this article to a tee http://community.linuxmint.com/tutorial/view/1298 using dconf in mint 15 mate and was STILL having an issue where i could not set compiz settings to be saved the issue is mentioned above by viking1au..... the work around I found was by going to your home folder .config... compiz-1.... compizconfig.... open the config file change unity session to mate_session remove unity after profile= ..... then save... create another file with text editor naming it default.ini place it in that same folder..... copy all the text from unity.ini and paste it in the default.ini save it.... or rename unity.ini to default.ini (i chose to make a seperate default.ini out of precaution) open command prompt type compiz --replace and it should fix compiz permenantly!!.... that is if you already changed the window manager in dconf and have compiz in startup applications!!! I think the problem arises for those who install the unity tweak tool.... Peace!!!
Post Reply

Return to “MATE”