LM 15 Mate screensaver starts at 5 minutes regardless

Forum rules
Before you post please read how to get help
Post Reply
klepto
Level 1
Level 1
Posts: 26
Joined: Mon Jan 26, 2009 8:31 pm
Location: Oceania
Contact:

LM 15 Mate screensaver starts at 5 minutes regardless

Post by klepto » Tue Jul 09, 2013 10:29 pm

I normally have my screensaver set for 30 minutes but for some reason the setting won't change.
So every 5 minutes I have to move the mouse.

Any idea who to fix this annoying prob?

ReplicateThis
Level 1
Level 1
Posts: 10
Joined: Sat Oct 09, 2010 3:45 pm
Location: Montreal, Canada
Contact:

Re: LM 15 Mate screensaver starts at 5 minutes regardless

Post by ReplicateThis » Sat Jul 13, 2013 10:46 pm

This may not be the best answer, but I uninstalled the xscreensaver program and set my monitor to power down after 30 minutes through the power settings. The lack of xscreensaver has not caused any trouble to the system.
"Don't anthropomorphize computers - they hate it." ~Author Unknown

ekot
Level 1
Level 1
Posts: 1
Joined: Mon Aug 05, 2013 2:08 am

Re: LM 15 Mate screensaver starts at 5 minutes regardless

Post by ekot » Sat Aug 10, 2013 1:16 pm

I have the same problem.
How did you uninstall xscreensaver? I try to do sudo apt-get remove xscreensaver, but it says there is no such package

msbln
Level 2
Level 2
Posts: 54
Joined: Mon Jan 10, 2011 2:49 pm

Re: LM 15 Mate screensaver starts at 5 minutes regardless

Post by msbln » Sun Aug 18, 2013 1:26 pm

I uninstalled xscreensaver. But that didn't solve the problem.

I came across only one solution to stop this on-going weird behaviour of lmde:

xset s off

Add this line to your starting programs and you're done.
LMDE MATE

msbln
Level 2
Level 2
Posts: 54
Joined: Mon Jan 10, 2011 2:49 pm

Re: LM 15 Mate screensaver starts at 5 minutes regardless

Post by msbln » Sun Aug 18, 2013 4:00 pm

Well, even

Code: Select all

xset s off
doesn't seem to always help :?

Make sure you also consider

Code: Select all

mate-screensaver-preferences
and

Code: Select all

xscreensaver-demo
(the latter if xscreensaver is installed)

Hope, I could help a little.
LMDE MATE

Detonate
Level 2
Level 2
Posts: 86
Joined: Fri Oct 14, 2011 7:40 pm
Location: Ault, Colorado
Contact:

Re: LM 15 Mate screensaver starts at 5 minutes regardless

Post by Detonate » Mon Aug 26, 2013 10:41 am

Another culprit in having an unwanted screensaver blank your screen is the built in screensaver of your monitor in you have an "Energy Star" monitor, and most modern monitors are. You can kill this with:

Code: Select all

xset -dpms
I have that command and:

Code: Select all

xset s off
both in my Startup Applications.

This is using the Mate Desktop in Olivia.

User avatar
LinWinux
Level 4
Level 4
Posts: 296
Joined: Fri Aug 30, 2013 9:04 pm
Location: East Coast

Re: LM 15 Mate screensaver starts at 5 minutes regardless

Post by LinWinux » Sat Aug 31, 2013 12:57 pm

I had the same problem, puzzled me for a few days. I ended up disabling the screensaver altogether in the power manager and using the blank screen option for screensaver with 30 minutes. Now everything is fine. The strange behavior appeared to come from the default Power Manager settings ...
PLEASE ... Don't respond to questions with meaningless or thoughtless comments!
PLEASE ... Help others, don't be lazy! Take a moment to mark your post SOLVED if you received a solution.

Post Reply

Return to “MATE”