How to disable screen blanking?

Forum rules
Before you post please read how to get help
tarverator
Level 2
Level 2
Posts: 72
Joined: Fri Aug 17, 2012 2:43 pm

How to disable screen blanking?

Post by tarverator » Mon Feb 10, 2014 6:28 pm

Can someone help walk me through this?

I am sick of the screen blanking when watching videos. I want to be able to tell the computer "Just Stay On." I don't care if there's no screen saver. Break it, uninstall it, get rid of it. Good riddance! I am just that sick of fiddling with settings that ignore what I am trying to tell them. Why is that hard?

Trouble is, the Mate package for the screensaver is also the screen locker. I do want to keep the screen locker.

So... how do I disable screen blanking, without uninstalling and disabling screen locking? Can that be done?

Thanks.

Thinkpad x230 i5-3360M running Linux Mint Mate Maya 32-bit

User avatar
TheDynamicHamza21
Level 5
Level 5
Posts: 794
Joined: Thu Oct 04, 2012 7:24 pm
Location: California
Contact:

Re: How to disable screen blanking?

Post by TheDynamicHamza21 » Mon Feb 10, 2014 11:39 pm

Menu>Screensaver>Power management>Display change to Never
Linux Registered User: # 573034

Hamza21.com

tarverator
Level 2
Level 2
Posts: 72
Joined: Fri Aug 17, 2012 2:43 pm

Re: How to disable screen blanking?

Post by tarverator » Tue Feb 11, 2014 10:20 am

Thanks for your reply, but that doesn't work. The screen still blanks when playing videos in Chrome on battery power, and other scenarios as well, such as VLC with A/C power, but not as quickly.

I am looking for help either (a) repairing the broken functionality of the screensaver so that when I say "Never" it really never blanks, or (b) yanking the screensaver entirely, but without breaking screen locking.

tarverator
Level 2
Level 2
Posts: 72
Joined: Fri Aug 17, 2012 2:43 pm

Re: How to disable screen blanking?

Post by tarverator » Tue Feb 11, 2014 1:52 pm

Thanks, got that one too, sort of.

Mine, for Mate, is Power Manager Inhibit Applet 1.6.2, whereas the one you linked, apparently for Cinnamon, is Screensaver Inhibit 1.8.1.

I got mine (which doesn't work) via right-click on Panel --> Add to panel --> Inhibit Applet.

That's different than the path you describe: right-click on Panel > Add Applets > Get More Online > Screensaver Inhibit

I don't have any "Get More Online" option. Is there a way to get the upgraded version, or is that just for Cinnamon, or a different program altogether?

User avatar
austin.texas
Level 20
Level 20
Posts: 12054
Joined: Tue Nov 17, 2009 3:57 pm
Location: at /home

Re: How to disable screen blanking?

Post by austin.texas » Tue Feb 11, 2014 2:29 pm

You are right, Screensaver Inhibit is just for Cinnamon, so it won't do you any good in Mate.
Mint 18.2 Cinnamon, Quad core AMD A8-3870 with Radeon HD Graphics 6550D, 8GB DDR3, Ralink RT2561/RT61 802.11g PCI
Linux Linx 2018

User avatar
Flemur
Level 16
Level 16
Posts: 6928
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: How to disable screen blanking?

Post by Flemur » Tue Feb 11, 2014 3:58 pm

I had screen blanking with no screensavers installed.

This fixed it:
$ xset s off
$ xset -dpms

Try it in a terminal; if it works, add it to your login/startup/whatever.
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?
Mint 19.1 Xfce/fluxbox
Manjaro openbox/fluxbox

tarverator
Level 2
Level 2
Posts: 72
Joined: Fri Aug 17, 2012 2:43 pm

Re: How to disable screen blanking?

Post by tarverator » Wed Feb 12, 2014 10:52 am

$ xset s off
$ xset -dpms

Doesn't fix it either, not even if I run the commands as root.

Other ideas?

tarverator
Level 2
Level 2
Posts: 72
Joined: Fri Aug 17, 2012 2:43 pm

Re: How to disable screen blanking?

Post by tarverator » Wed Feb 12, 2014 6:14 pm

I tried un-installing mate-screensaver to see what would happen, and what happened was that after locking the screen there was no way to log back into the desktop. It was easy enough to re-install mate-screensaver from a terminal, but that didn't work.

So.... I'm still standing by for other ideas.


User avatar
nomko
Level 10
Level 10
Posts: 3026
Joined: Sat Feb 25, 2012 7:28 pm
Location: The Hague, The Netherlands

Re: How to disable screen blanking?

Post by nomko » Wed Jul 02, 2014 5:16 am

I encounter the same problem with Mint 17 Mate, see my post here.

Summary:

1 system running Mint 16 Mate.
1 system running Mint 17 Mate.


system running Mint 16 Mate
When watching a movie with Vlc, the screen never turns blank. Only when watching online movies/series in a webbrowser using Youtube the screen turns blank.

system running Mint 17 Mate
Watching movies with Vlc and watching online movies via webbrowser/Youtube screens turns blank every 30 minutes. Every possible setting is disabled or uninstalled.

User avatar
nomko
Level 10
Level 10
Posts: 3026
Joined: Sat Feb 25, 2012 7:28 pm
Location: The Hague, The Netherlands

Re: How to disable screen blanking?

Post by nomko » Wed Jul 02, 2014 5:20 am

Flemur wrote:I had screen blanking with no screensavers installed.
This fixed it:
$ xset s off
$ xset -dpms
Try it in a terminal; if it works, add it to your login/startup/whatever.
Mint 17/Xfce/fluxbox & Mint 16/Xfce/fluxbox
Looking at your signature it might have worked on those desktop environments, but did you tested it on Mint + Mate as well? I'll check it this evening on my Mint 17 Mate system and Mint 16 Mate system.

User avatar
nomko
Level 10
Level 10
Posts: 3026
Joined: Sat Feb 25, 2012 7:28 pm
Location: The Hague, The Netherlands

Re: How to disable screen blanking?

Post by nomko » Wed Jul 02, 2014 4:47 pm

Flemur wrote:I had screen blanking with no screensavers installed.

This fixed it:
$ xset s off
$ xset -dpms

Try it in a terminal; if it works, add it to your login/startup/whatever.
How to check if this work? Any command?

User avatar
nomko
Level 10
Level 10
Posts: 3026
Joined: Sat Feb 25, 2012 7:28 pm
Location: The Hague, The Netherlands

Re: How to disable screen blanking?

Post by nomko » Wed Jul 02, 2014 4:54 pm

To all reading this thread.

I've might found a solution for Linux Mint + Mate desktop that requires some (system file) editing:
  • Open a terminal
  • Type the following command

    Code: Select all

    sudo pluma /etc/X11/xorg.conf
  • At the bottom of this file add the following:
    Section "ServerFlags"
    Option "BlankTime" "0"
    Option "StandbyTime" "0"
    Option "SuspendTime" "0"
    Option "OffTime" "0"
    Option "DontZap" "false"
    EndSection
  • Save the file and close it
According the source i found this should work.
Last edited by nomko on Thu Jul 03, 2014 3:05 am, edited 1 time in total.

User avatar
DrHu
Level 17
Level 17
Posts: 7539
Joined: Wed Jun 17, 2009 8:20 pm

Re: How to disable screen blanking?

Post by DrHu » Wed Jul 02, 2014 4:59 pm

I think that last post is simply turning off all power managemet (batter control, hibernate or sleep) for the computer
--and it should also be available withing the seetings for power control

You could also simply not load the screensaver service on startup
--that should be an option again within..

I used to use rcconf tool
http://www.cyberciti.biz/tips/how-to-co ... vices.html
--to manage services on boot..
http://ubuntuforums.org/showthread.php?t=1721789
--ubuntu went to upstart as their nmechanism, and it is controllable via the desktop menus

User avatar
nomko
Level 10
Level 10
Posts: 3026
Joined: Sat Feb 25, 2012 7:28 pm
Location: The Hague, The Netherlands

Re: How to disable screen blanking?

Post by nomko » Thu Jul 03, 2014 3:11 am

DrHu wrote:I think that last post is simply turning off all power managemet (batter control, hibernate or sleep) for the computer
--and it should also be available withing the seetings for power control
The website were i found this solution it was reported that this solved the issue of screen blanking under Mate while watching online/streaming videos and/or watching movies with Vlc. If it works, why not? And i really don't need nor want hibernate or sleep on my desktop system!
DrHu wrote: You could also simply not load the screensaver service on startup
--that should be an option again within..
I think you haven't read my thread about the same issue properly. I did everything possible whitout any luck. I don't know which desktop environment you're using, but don't start mixing up Cinnamon with Mate please.

User avatar
nomko
Level 10
Level 10
Posts: 3026
Joined: Sat Feb 25, 2012 7:28 pm
Location: The Hague, The Netherlands

Re: How to disable screen blanking?

Post by nomko » Fri Jul 04, 2014 2:09 am

The solution i provided here: http://forum.linuxmint.com/viewtopic.ph ... 72#p884699 didn't worked. I tried it yesterday eveving and after rebooting my system, i got an error messages saying something about my Xorg and ended up in a terminal-like environment were i could restore my xorg.conf file and reboot in a normal desktop environment.

cve60069
Level 1
Level 1
Posts: 1
Joined: Thu Mar 10, 2016 8:58 am

Re: How to disable screen blanking?

Post by cve60069 » Thu Mar 10, 2016 9:03 am

This post works for Linux Mint 17.3.

I altered the power settings and my screen has been active for over two-hours without me touching anything.

Thanks for the solution.

User avatar
LinuxMintLover
Level 1
Level 1
Posts: 11
Joined: Wed Jan 20, 2016 1:59 am

Re: How to disable screen blanking?

Post by LinuxMintLover » Thu Jul 06, 2017 8:43 pm

Got the same issue here. I have a laptop on Linux Mint 17, and I have gone into `Control Center > Screensaver > Regard the computer as idle after` and set the value to 2 hours. I also checked `Power Management > On AC Power > Put computer to sleep when inactive for` and set it to 2 hours. However, when running either VLC or Videos (GNOME video player), it blanks every five or ten minutes! I do not unplug my computer often, so what do I do?
"A cup of Mint a day keeps Windows and Macintosh away!" - Unknown Author

Brian Potter
Level 2
Level 2
Posts: 65
Joined: Mon Feb 27, 2017 8:40 pm
Location: United Kingdom

Re: How to disable screen blanking?

Post by Brian Potter » Thu Jul 13, 2017 8:12 pm

I have the same problem. It am running 18.2 but it was the same on 17.3 and 18.1. I did all the things that LinuxMintLover mentions in the post directly above this one. But it still blanks after roughly 30 minutes regardless of whether i am watching videos or not...if the keyboard or mouse has not been used then the screen goes to sleep regardless.

I wondered if it might be a feature of my Dell monitor and not a Mint issue?
Dell Inspiron 530 Desktop (a relic from 2007 still running with its original HDD!!!)
8GB DDR2 RAM @ 800Mhz, 160GB HDD, Intel® Core™2 Duo CPU E8600 @ 3.33GHz
Linux Mint Mate 19.1

User avatar
Seadreamer
Level 3
Level 3
Posts: 152
Joined: Sat Jun 25, 2016 10:12 pm

Re: How to disable screen blanking?

Post by Seadreamer » Sat Jul 15, 2017 12:12 pm

I use LM 18.2 Mate. This works for me.

Code: Select all

 xset s 00 
I put it in "startup software" as a command with the title NoBlank. I use my computer for ship navigation so it needs to stay on.

Control Center/startup applications/add
Homebrew Intel system
LinuxMint 19 Mate

Post Reply

Return to “MATE”