How to disable screen blanking?

Forum rules
Before you post please read how to get help
Mephestopheles
Level 1
Level 1
Posts: 17
Joined: Mon Sep 21, 2015 3:00 am

Re: How to disable screen blanking?

Post by Mephestopheles » Sun Aug 27, 2017 7:22 pm

After updating to LM18.2 Cinnamon - i am having the same problem.
After about One minute of inactivity my screen will go blank.
I have tried everything I can think of, ... and tried ALL of the suggestions for Mate or any others i find posted.
Nothing seems to be stopping this.
I have resorted to Manually going into System Monitor and "killing" the screensaver app.
Hopefully that will continue to do the trick.
Other than that I am VERY satisfied with Linux Mint Cinnamon 18.2 .
Thanks for a Great product.

Brian Potter
Level 2
Level 2
Posts: 68
Joined: Mon Feb 27, 2017 8:40 pm
Location: United Kingdom

Re: How to disable screen blanking?

Post by Brian Potter » Thu Sep 14, 2017 9:48 pm

Manually killing the screensaver app in system monitor does not work for me. Neither does End Process or Stop Process. I might try changing to a newer kernel.
Dell Inspiron 530 Desktop (a relic from 2007 still running with its original HDD!!!)
8GB DDR2 RAM @ 800Mhz, 160GB HDD, Intel® Core™2 Duo CPU E8600 @ 3.33GHz
Linux Mint Mate 19.1

Greenwood
Level 1
Level 1
Posts: 5
Joined: Fri Aug 04, 2017 2:06 pm

Re: How to disable screen blanking? Solved (for me)

Post by Greenwood » Sat Oct 14, 2017 1:22 am

I suffered with this also, for almost 4 months, almost gave up, nothing seemed to fix this..
AS OF......OCTOBER 13, 2017

I use dual 19" "e-Machines" monitors, and, I have a screen saver installed,
tried everyone's suggestions in vain until I
opened a Terminal, and finally found this from "Flemur" way back in 2014:
$ xset s off
$ xset -dpms
Three hours so far of no blanking. Yaaaay!! Thanks Flemur, if you're still here!

My system info, follows


OptiPlex-740 ~ $ inxi -Fxzd


System: Host: OptiPlex-740 Kernel: 3.13.0-24-generic x86_64 (64 bit, gcc: 4.8.2) Desktop: N/A Distro: Linux Mint 17 Qiana
Machine: System: Dell product: OptiPlex 740 Enhanced
Mobo: Dell model: 0YP806 version: A00 Bios: Dell version: 2.1.6 date: 05/04/2008
CPU: Dual core AMD Athlon 64 X2 4400+ (-MCP-) cache: 1024 KB flags: (lm nx sse sse2 sse3 svm) bmips: 4008.48
Clock Speeds: 1: 1000.00 MHz 2: 1000.00 MHz
Graphics: Card: Advanced Micro Devices [AMD/ATI] Cedar [Radeon HD 5000/6000/7350/8350 Series] bus-ID: 03:00.0
X.Org: 1.15.1 drivers: ati,radeon (unloaded: fbdev,vesa) Resolution: 1920x1080@60.0hz, 1920x1080@60.0hz
GLX Renderer: Gallium 0.4 on AMD CEDAR GLX Version: 3.0 Mesa 10.1.3 Direct Rendering: Yes
Audio: Card-1: NVIDIA MCP51 High Definition Audio driver: snd_hda_intel bus-ID: 00:10.1
Card-2: Advanced Micro Devices [AMD/ATI] Cedar HDMI Audio [Radeon HD 5400/6300 Series] driver: snd_hda_intel bus-ID: 03:00.1
Sound: Advanced Linux Sound Architecture ver: k3.13.0-24-generic
Network: Card-1: Broadcom NetXtreme BCM5754 Gigabit Ethernet PCI Express driver: tg3 ver: 3.134 bus-ID: 02:00.0
IF: eth0 state: up speed: 100 Mbps duplex: full mac: <filter>
Card-2: Realtek RTL8188CUS 802.11n WLAN Adapter usb-ID: 0bda:8176
IF: N/A state: N/A mac: N/A
Drives: HDD Total Size: 1240.3GB (2.0% used) 1: id: /dev/sda model: SAMSUNG_HD083GJ size: 80.0GB
2: USB id: /dev/sdg model: 2ACE size: 160.0GB 3: USB id: /dev/sdf model: EAVS size: 1000.2GB
Optical: /dev/sr0 model: N/A rev: N/A dev-links: cdrom
Features: speed: 48x multisession: yes audio: yes dvd: yes rw: none state: N/A
Partition: ID: / size: 74G used: 9.6G (14%) fs: ext2 ID: swap-1 size: 4.29GB used: 0.00GB (0%) fs: swap
RAID: No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors: None detected - is lm-sensors installed and configured?
Info: Processes: 181 Uptime: 21:13 Memory: 1471.8/3952.5MB Runlevel: 2 Gcc sys: 4.8.4 Client: Shell inxi: 1.8.4

Greenwood
Level 1
Level 1
Posts: 5
Joined: Fri Aug 04, 2017 2:06 pm

Re: How to disable screen blanking?(solved for me) NOT!

Post by Greenwood » Wed Oct 25, 2017 2:40 am

using the code in a terminal, it only worked for a few days.
it still continues blanking, every few minutes, even with running the code as sudo.

So.... back to square 1.

User avatar
BG405
Level 7
Level 7
Posts: 1887
Joined: Fri Mar 11, 2016 3:09 pm
Location: England

Re: How to disable screen blanking?

Post by BG405 » Thu Oct 26, 2017 3:27 pm

What does cat /sys/module/kernel/parameters/consoleblank return?
Dell Inspiron 1525 - LM17.3 CE 64-------------------Lenovo T440 8GB - Manjaro KDE with Mint VMs
Toshiba NB250 - Manjaro KDE------------------------K7S5A AMD 1.2GHz - LM17.3 Xfce 32 & WinXP-Pro
Acer Aspire E11 ES1-111M - LM18.2 KDE 64 ----Dell PII 350 64MB - Puppy 4.3 & Win98-SE

Säteri
Level 1
Level 1
Posts: 38
Joined: Sun Nov 19, 2017 12:29 pm

Re: How to disable screen blanking?

Post by Säteri » Wed Nov 29, 2017 8:53 am

I'm also having this annoying issue with LM18.2 mate, and as everyone else, i also have tried every possible setting with no success.

When i run that command that BG405 gave, it returns "0"
Nothing else.
Has anyone come up with a solution?

User avatar
Faust
Level 4
Level 4
Posts: 497
Joined: Thu Jul 14, 2016 3:40 am

Re: How to disable screen blanking?

Post by Faust » Wed Nov 29, 2017 10:03 am

It's a royal PITA and no mistake .

I've been using 17.3 cinnamon for years and I finally found a nice fix for this with an app called "wakefull " , and I made some notes here :-
viewtopic.php?f=47&t=252968&p=1361119&h ... e#p1361119

I recently started to build a twin of my system onto a fresh install of 18.2 cinnamon ( as an experiment in " future-proofing " :) )
and most things were very easy to duplicate , but "wakefull " did not play nicely , and I semi-borked my new system trying to force it :mrgreen:

I'd like to hear from any 18.2 users who have made wakefull work ( or something similar ) .
Such a nice little app !
It did exactly what the OP wants , and everything that I had wanted .... it shouldn't be difficult to adapt for 18.2 , should it ?

https://sourceforge.net/projects/wakefull/files/
" And so it goes " - Kurt Vonnegut
The modern reality and the satirical parody are rapidly converging .

User avatar
RienP
Level 1
Level 1
Posts: 11
Joined: Sat Mar 23, 2019 9:48 am
Contact:

Re: How to disable screen blanking?

Post by RienP » Sun Apr 07, 2019 8:37 am

Brian Potter wrote:
Thu Jul 13, 2017 8:12 pm
But it still blanks after roughly 30 minutes regardless of whether i am watching videos or not...if the keyboard or mouse has not been used then the screen goes to sleep regardless.
Here's what solved the same problem for me:
viewtopic.php?f=59&t=291658

Rien

Brian Potter
Level 2
Level 2
Posts: 68
Joined: Mon Feb 27, 2017 8:40 pm
Location: United Kingdom

Re: How to disable screen blanking?

Post by Brian Potter » Tue May 28, 2019 1:30 am

I upgraded to LM 19.1 and no longer have this issue. Why that is, I have no idea. LM 19.1 seems a lot better than LM18 was. I had niggly annoying little issues with LM18 but so far 19 is running nicely.
Dell Inspiron 530 Desktop (a relic from 2007 still running with its original HDD!!!)
8GB DDR2 RAM @ 800Mhz, 160GB HDD, Intel® Core™2 Duo CPU E8600 @ 3.33GHz
Linux Mint Mate 19.1

Post Reply

Return to “MATE”