LM17 Mate Mintmenu "Couldn't init plugin applications"

Forum rules
Before you post please read how to get help
VTWiT
Level 1
Level 1
Posts: 2
Joined: Tue Dec 18, 2012 5:33 pm

LM17 Mate Mintmenu "Couldn't init plugin applications"

Postby VTWiT » Thu Jul 31, 2014 8:26 pm

Not quite a noob but at quite a loss as to what went wrong. Mintmenu will start but there's no applications populated and the errors are:
Couldn't initialize plugin applications : Traceback (most recent call last):

File "/usr/lib/linuxmint/mintMenu/mintMenu.py", line 317, in PopulatePlugins
MyPlugin.do_plugin()

File "/usr/lib/linuxmint/mintMenu/plugins/applications.py", line 1336, in do_plugin
self.Todos()

File "/usr/lib/linuxmint/mintMenu/plugins/applications.py", line 582, in Todos
self.buildButtonList()

File "/usr/lib/linuxmint/mintMenu/plugins/applications.py", line 611, in buildButtonList
self.updateBoxes(False)

File "/usr/lib/linuxmint/mintMenu/plugins/applications.py", line 1617, in updateBoxes
newCategoryList = self.buildCategoryList()

File "/usr/lib/linuxmint/mintMenu/plugins/applications.py", line 1783, in buildCategoryList
for child in menu.directory.get_contents():

AttributeError: 'NoneType' object has no attribute 'get_contents'


I have no idea where to start & would appreciate any help.

VTWiT
Level 1
Level 1
Posts: 2
Joined: Tue Dec 18, 2012 5:33 pm

Re: LM17 Mate Mintmenu "Couldn't init plugin applications"

Postby VTWiT » Fri Aug 01, 2014 4:41 pm

A bit more info. I'm just not sure where to start so I'm considering reinstalling.
Terminal:
~ $ mintmenu
/usr/lib/python2.7/dist-packages/gi/overrides/Gtk.py:50: RuntimeWarning: You have imported the Gtk 2.0 module. Because Gtk 2.0 was not designed for use with introspection some of the interfaces and API will fail. As such this is not supported by the pygobject development team and we encourage you to port your app to Gtk 3 or greater. PyGTK is the recomended python module to use with Gtk 2.0
warnings.warn(warn_msg, RuntimeWarning)

I've backed up my Home directory and will go experiment with installing PyGTK.

schpeck
Level 1
Level 1
Posts: 1
Joined: Thu Aug 14, 2014 9:46 am

Re: LM17 Mate Mintmenu "Couldn't init plugin applications"

Postby schpeck » Thu Aug 14, 2014 9:52 am

Did you find any solution? I have the same problem now...


Return to “MATE”

Who is online

Users browsing this forum: No registered users and 2 guests