How do I exclude Mint Menu from 'Place Windows' (Compiz)

Forum rules
Before you post please read how to get help
Post Reply
tpprynn
Level 3
Level 3
Posts: 189
Joined: Fri May 27, 2011 7:09 pm

How do I exclude Mint Menu from 'Place Windows' (Compiz)

Post by tpprynn »

The standard Mint Menu is dumped half an inch further up the screen if I have Place Windows activated in Compiz, but randomly, not every time. I'm sure there was some way of excluding some types of window/applet from being affected by Compiz settings but it's been years since I felt familiar with Compiz. Does anyone here know?

Thanks.

Sabaki
Level 1
Level 1
Posts: 1
Joined: Fri Nov 04, 2011 12:37 pm

Re: How do I exclude Mint Menu from 'Place Windows' (Compiz)

Post by Sabaki »

Good question. It took me a little playing around to figure out I needed Place Windows to keep apps from opening with their title bar hidden under the mate panel at the top of my screen. Anyway, this looks a little complicated, but there is some info at http://wiki.compiz.org/Plugins/Place
that looks like the right stuff, if I can just figure it out. I'll post here if I do. If you get it solved, be sure and post it here for me and others, too.

Chuck Bell

pepperbox
Level 1
Level 1
Posts: 1
Joined: Fri Mar 20, 2015 10:14 am

Re: How do I exclude Mint Menu from 'Place Windows' (Compiz)

Post by pepperbox »

I also have this problem, but on XFCE. So it is clearly not a Mate related problem.
Do the Linux Mint developers know about this bug?
It is 100% reproducible on every fresh or updated Linux Mint installation.
Come on people, we need to make some noise in order to get this fixed.

Monsta
Level 10
Level 10
Posts: 3038
Joined: Fri Aug 19, 2011 3:46 am

Re: How do I exclude Mint Menu from 'Place Windows' (Compiz)

Post by Monsta »

pepperbox wrote:Do the Linux Mint developers know about this bug?
Yes.

We didn't know that it's related to "Place Windows" feature though.
Does the problem go away 100% if you disable that feature?

Monsta
Level 10
Level 10
Posts: 3038
Joined: Fri Aug 19, 2011 3:46 am

Re: How do I exclude Mint Menu from 'Place Windows' (Compiz)

Post by Monsta »

So... looks like it's a cross-desktop and cross-distro issue in Compiz itself. See this bug report.

Post Reply

Return to “MATE”