Login screen defaulting to HDMI - VGA preferred

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
MWave6
Level 1
Level 1
Posts: 11
Joined: Mon Jul 11, 2016 5:04 pm

Login screen defaulting to HDMI - VGA preferred

Post by MWave6 » Sun Jul 17, 2016 2:52 pm

Hey Folks,

I've got a Gigabyte Radeon R7 250 board w/2GB RAM. Had a single 19" Samsung connected to the VGA and recently connected a new LED TV to the HDMI. Running Mint v18 x64 at the latest patch levels via Update Manager.

My primary display at the login screen has now become the HDMI port instead of VGA. XRANDR enumerates them as HDMI-0 & VGA-0 (output below). I've set the VGA display as my primary and disabled the HDMI altogether within MATE "Monitor Preferences". However, I've learned that the display manager is responsible for the login screen prior to MATE loading.

***** BEGIN XRANDR OUTPUT *****
minimum 320 x 200, current 1280 x 1024, maximum 16384 x 16384
HDMI-0 connected (normal left inverted right x axis y axis)
1360x768 60.37 +
1920x1080 60.00 50.00 59.94 24.00 23.98
1920x1080i 60.00 60.00 50.00 59.94
1280x1024 60.02
1280x720 60.61 60.00 50.00 59.94
1024x768 60.00
800x600 60.32
720x576 50.00
720x576i 50.00
720x480 60.00 59.94
720x480i 60.00 59.94
640x480 60.00 59.94
720x400 70.08
DVI-0 disconnected (normal left inverted right x axis y axis)
VGA-0 connected primary 1280x1024+0+0 (normal left inverted right x axis y axis) 376mm x 301mm
1280x1024 60.02 + 75.02*
1152x864 75.00
1024x768 75.08 75.03 70.07 60.00
832x624 74.55
800x600 72.19 75.00 60.32 56.25
640x480 75.00 72.81 66.67 60.00 59.94
720x400 70.08

***** END XRANDR OUTPUT *****


Researched a bit and found that displays are prioritized by MDM as the default manager in Mint. Also read where one can run "sudo mdmsetup" and tweak which display MDM should use for the login screens, namely the "Primary monitor" selector in the "Options" section. Trouble is, my MDMSETUP has no such field from which to choose a primary monitor (see attached).
MDMSETUP.png
I've noticed a "PrimaryMonitor=None" entry in /etc/mdm/mdm.conf and also /usr/share/mdm/distro.conf. Have set each to "PrimaryMonitor=VGA-0" and noticed that this DOES add a "Primary monitor" field in MDMSETUP; However, the pull-down is blank and has no actual options to choose.

Furthermore, I get the attached warnings/errors when running MDMSETUP which leads me to believe something isn't right or needs updated. I did experiment with removing MDM and installing GDM which hosed things up altogether. Booted into recovery mode and was able to reinstall MDM via command line.
GTK_errors.png

I'd be interested to know what fixed this from anyone here who ran into something similar... TIA!

Post Reply

Return to “Software & Applications”