Mintmenu and Caja start too slow

Forum rules
Before you post please read how to get help
Post Reply
havon
Level 1
Level 1
Posts: 13
Joined: Sun Jul 31, 2016 6:11 am

Mintmenu and Caja start too slow

Post by havon » Sun Jul 31, 2016 7:34 am

When I click mintmenu for the first time after reboot, it has an about 3 seconds delay. If I click the Menu button again, menu appears instantly. Caja also has a delay when I try to open my home directory for the first time in the session.
I've tried to update the icon cache and launch caja after boot up. My /etc/rc.local:

Code: Select all

cd /usr/share/icons/ ; for d in * ; do [ -d $d ] && gtk-update-icon-cache -f /usr/share/icons/$d ; done

caja
Menu loads a bit faster, but not fast enough. I also did:

Code: Select all

$ cat /usr/bin/startcaja
#sleep 3
caja -n "$@"

but the problem still exists.

My system is Linux mint 17.

Hoser Rob
Level 12
Level 12
Posts: 4203
Joined: Sat Dec 15, 2012 8:57 am

Re: Mintmenu and Caja start too slow

Post by Hoser Rob » Sun Jul 31, 2016 9:19 am

The slowness of the MInt menu opening is a long standing issue with Mate and frankly I'm not optimistic it'll ever get much faster. So when I used to use Mate I just stopped worrying about it.

The reason it opens much quicker the 2nd time is that Linux uses unused RAM as a cache, so it doesn't have to load all apps from disc when you run them subsequently. This is the reason why one of the best Linux speed tweaks is to cram as much RAM into the system as you can.

I don't know what you mean by caja taking a long time to load or if however long it takes is abnormal. Post system details ... copy/paste this into terminal and copy/paste the text output here:

Code: Select all

inxi -Fxz

havon
Level 1
Level 1
Posts: 13
Joined: Sun Jul 31, 2016 6:11 am

Re: Mintmenu and Caja start too slow

Post by havon » Mon Aug 01, 2016 4:24 am

I understand that some data has to be loaded to cache for the first time, and I tried to do it right after boot up, but I want to know, why doesn't it work?
Caja takes about 3 or 5 seconds to load and I think it's too long.

Code: Select all

$ inxi -Fxz
System:    Host: book Kernel: 3.13.0-24-generic i686 (32 bit gcc: 4.8.2) Desktop: MATE 1.8.1 (Gtk 3.10.8~8+qiana)
           Distro: Linux Mint 17 Qiana
Machine:   System: Acer product: Aspire 6935 v: V1.04
           Mobo: Acer model: Aspire 6935 v: PSMBOU-1234567 Bios: Acer v: V1.04 date: 07/25/2008
CPU:       Dual core Intel Core2 Duo P7350 (-MCP-) cache: 3072 KB
           flags: (lm nx pae sse sse2 sse3 sse4_1 ssse3) bmips: 7980
           clock speeds: max: 2000 MHz 1: 1600 MHz 2: 1600 MHz
Graphics:  Card: NVIDIA G96M [GeForce 9600M GT] bus-ID: 01:00.0
           Display Server: X.Org 1.15.1 drivers: nouveau (unloaded: fbdev,vesa) Resolution: 1366x768@60.0hz
           GLX Renderer: Gallium 0.4 on NV96 GLX Version: 3.0 Mesa 10.1.0 Direct Rendering: Yes
Audio:     Card Intel 82801I (ICH9 Family) HD Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k3.13.0-24-generic
Network:   Card-1: Qualcomm Atheros AR8121/AR8113/AR8114 Gigabit or Fast Ethernet
           driver: ATL1E port: 4000 bus-ID: 02:00.0
           IF: eth0 state: up speed: 1000 Mbps duplex: full mac: <filter>
           Card-2: Intel WiFi Link 5100 driver: iwlwifi v: in-tree: bus-ID: 05:00.0
           IF: wlan0 state: down mac: <filter>
Drives:    HDD Total Size: 320.1GB (16.8% used) ID-1: /dev/sda model: WDC_WD3200BEVT size: 320.1GB
Partition: ID-1: / size: 290G used: 47G (17%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 4.29GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 43.0C mobo: 36.0C gpu: 43.0
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 163 Uptime: 2:38 Memory: 751.5/4031.2MB Init: Upstart runlevel: 2 Gcc sys: 4.8.4
           Client: Shell (bash 4.3.111) inxi: 2.2.21

havon
Level 1
Level 1
Posts: 13
Joined: Sun Jul 31, 2016 6:11 am

Re: Mintmenu and Caja start too slow

Post by havon » Wed Feb 28, 2018 11:06 am

I've finally solved the problem by installing a faster hard drive (SSD). However, MATE desktop works quite slow with old hard drives and I don't know how to fix it.

Hoser Rob
Level 12
Level 12
Posts: 4203
Joined: Sat Dec 15, 2012 8:57 am

Re: Mintmenu and Caja start too slow

Post by Hoser Rob » Thu Mar 01, 2018 9:24 am

That's a 2008 model and no Mint version is going to be all that fast on it. You should open Driver Manager and if there's a recommended Nvidia video driver, install that. Also, disable all desktop compositing/eye candy.

BTW the slow loading of the menu is also a ... ahem ... feature of the Xfce desktop. And I don't expect that to get fixed any time soon either. The same thing in KDE 5 as installed on my 18.2 netbook pops up almost instantly. And KDE, which is supposed to be a resource hog, takes about 325Mb after booting in (or it did before I installled preload). Not much more RAM than Xfce or Mate. The 'light' Mint DEs aren't that light any more.

havon
Level 1
Level 1
Posts: 13
Joined: Sun Jul 31, 2016 6:11 am

Re: Mintmenu and Caja start too slow

Post by havon » Thu Mar 01, 2018 1:03 pm

Hoser Rob wrote:
Thu Mar 01, 2018 9:24 am
That's a 2008 model
I had this issue on 2015 machine with SATA III HDD too! It was not too bad, but still slow.
Hoser Rob wrote:
Thu Mar 01, 2018 9:24 am
You should open Driver Manager and if there's a recommended Nvidia video driver, install that. Also, disable all desktop compositing/eye candy.
For what? Now my system works fine including all MATE desktop features. I have tried using proprietary driver for video adapter, but free one works better for me.
Hoser Rob wrote:
Thu Mar 01, 2018 9:24 am
BTW the slow loading of the menu is also a ... ahem ... feature of the Xfce desktop. And I don't expect that to get fixed any time soon either. The same thing in KDE 5 as installed on my 18.2 netbook pops up almost instantly. And KDE, which is supposed to be a resource hog, takes about 325Mb after booting in (or it did before I installled preload). Not much more RAM than Xfce or Mate. The 'light' Mint DEs aren't that light any more.
It's upsetting, I've never had this issue even in Windows start menu, however Linux is known for better performance and less hardware requirements. And what about LXDE? I have used KDE a little and X-server failed often with this environment, unlike MATE.

User avatar
Sir Charles
Level 7
Level 7
Posts: 1832
Joined: Thu Jan 04, 2018 1:00 pm

Re: Mintmenu and Caja start too slow

Post by Sir Charles » Thu Mar 01, 2018 1:14 pm

Slow opening menu in Xfce sounds foreign to me. I have never experienced that and I have a rather low-spec machine.
I suppose that's one of the ironies of life, doing the wrong thing at the right moment -C.C.

havon
Level 1
Level 1
Posts: 13
Joined: Sun Jul 31, 2016 6:11 am

Re: Mintmenu and Caja start too slow

Post by havon » Mon Mar 05, 2018 5:20 am

Is it possible (for other users) to fix it with scripts of anything like that? Is it really that difficult?

Post Reply

Return to “MATE”