KDE systemsetting matching problems

Forum rules
Before you post please read how to get help
rob1
Level 1
Level 1
Posts: 20
Joined: Wed Sep 21, 2011 11:56 am

KDE systemsetting matching problems

Postby rob1 » Tue Oct 10, 2017 10:57 am

When installing KDE applications in Linux Mint Mate 18.2, all of the applications appear to be qt4-based (contrary to Linux Mint KDE 18, where all stuff is qt5-based). This alone wonders me a bit, but that's not problematic for me.

Problems arise when systemsettings shall be installed. Then automatically systemsettings5 is installed, where compatibility fails.
In my case I had to manually retrieve libkdecorations4abi1_4.11.11-0ubuntu0.2_amd64.deb and systemsettings_4.11.11-0ubuntu0.2_amd64.deb from the packages repositories and install them.

Along this route, I'm able to control the appearence of KDE applications (e.g. fonts) within Mate.

User avatar
phd21
Level 14
Level 14
Posts: 5034
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: KDE systemsetting matching problems

Postby phd21 » Tue Oct 10, 2017 12:38 pm

Hi "rob1",

In the Linux Mint release notes for all editions, there are instructions for using KDE applications in non-KDE desktops like Cinnamon, Mate, and Xfce. I just recommend installing "kde-runtime", and then most KDE applications will work well.

Hope this helps ...
Phd21: Mint KDE 17.3 & 18.2, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,3gb Ram,160gb hdd, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

rob1
Level 1
Level 1
Posts: 20
Joined: Wed Sep 21, 2011 11:56 am

Re: KDE systemsetting matching problems

Postby rob1 » Tue Oct 10, 2017 2:20 pm

Answer:

Code: Select all

rob@rob-notebook ~ $ dpkg --list |grep kde-runtime
ii  kde-runtime                                   4:15.12.3-0ubuntu1                           amd64        runtime components from the official KDE release
ii  kde-runtime-data                              4:15.12.3-0ubuntu1                           all          shared data files for the KDE base runtime module

kde-runtime has been installed for sure automatically at the time where I installed krusader or so.
The apparent problem is another one: systemsettings5 and KDE4 applications in the same repository:
Here's some terminal output:

Code: Select all

rob@rob-notebook ~ $ systemsettings --version
Qt: 4.8.7
KDE Development Platform: 4.14.16
System Settings: 4.11.11

When I do apt upgrade (yes, systemsettings is listed for upgrade), the output is as follows:

Code: Select all

rob@rob-notebook ~ $ systemsettings --version
bash: /usr/bin/systemsettings: No such file or directory
rob@rob-notebook ~ $ systemsettings5 --version
systemsettings 5.5.5

Hoser Rob
Level 9
Level 9
Posts: 2891
Joined: Sat Dec 15, 2012 8:57 am

Re: KDE systemsetting matching problems

Postby Hoser Rob » Wed Oct 11, 2017 9:50 am

I had Kubuntu installed for several years and have also had all the other MInt DEs plus others. My laptop runs mint 18.2 KDE now,l replacing Xfce. BTW before I installed preload it ran in about 320 Mb after the usual KDE speed tweaks ... that's not much more than Xfce used. KDE isn't as much of a resource hog as everyone thinks. But as usual I digress.

What I've found is that it's just not really possible to get Qt-based KDE apps to work as well and/or look as good as you want in non KDE GTK-based DEs. GTK apps work and look much, much better in KDE than vice versa. I don't see any way around this.


Return to “MATE”