System not asking for password at resume

Forum rules
Before you post please read how to get help
amaci
Level 1
Level 1
Posts: 12
Joined: Mon Nov 06, 2017 7:37 am

System not asking for password at resume

Postby amaci » Sun Nov 19, 2017 2:00 pm

My Linux Mint Mate installation doesn't ask for password at resume from suspension.
How is it possible? I do not understand whether the settings are right or not.
Which are the exact settings I have to change to be sure the system is not so unprotected when I close the laptop lid or suspend?
Thank you in advance

User avatar
Spearmint2
Level 14
Level 14
Posts: 5308
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: System not asking for password at resume

Postby Spearmint2 » Sun Nov 19, 2017 2:30 pm

Menu > All Applications > Users and Groups >

highlight your user name if not already done. Click on password, ask on login.

Uncheck "don't ask for password on login"
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....

amaci
Level 1
Level 1
Posts: 12
Joined: Mon Nov 06, 2017 7:37 am

Re: System not asking for password at resume

Postby amaci » Sun Nov 19, 2017 2:35 pm

Very strange: my settings seem to be right according to what you wrote @Spearmint2
but if the laptop lid is closed or I suspend the system, it will not ask the password at resume. It is a bug or my system is broken.
How to understand what's wrong? How can I solve manually?

User avatar
Spearmint2
Level 14
Level 14
Posts: 5308
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: System not asking for password at resume

Postby Spearmint2 » Sun Nov 19, 2017 2:38 pm

Try this. Press CTRL-ALT-L and see if that will lock it.
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....

amaci
Level 1
Level 1
Posts: 12
Joined: Mon Nov 06, 2017 7:37 am

Re: System not asking for password at resume

Postby amaci » Sun Nov 19, 2017 2:42 pm

@Spearmint2
Yes, it locks

User avatar
Spearmint2
Level 14
Level 14
Posts: 5308
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: System not asking for password at resume

Postby Spearmint2 » Sun Nov 19, 2017 2:42 pm

https://www.linuxquestions.org/question ... 175610274/

https://wiki.debian.org/Suspend

others having problems with suspend in version 18, maybe kernel related. The second link may work for you.
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....

User avatar
Spearmint2
Level 14
Level 14
Posts: 5308
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: System not asking for password at resume

Postby Spearmint2 » Sun Nov 19, 2017 2:46 pm

amaci wrote:@Spearmint2
Yes, it locks


open termina and enter command

Code: Select all

dconf-editor


If not installed, do so.

Code: Select all

sudo apt-get install dconf-editor


then open the program and then clk on top left "dconf editor", use the Find, and put in suspend
You should arrive at ubuntu-lock-on-suspend. Put an X in that box.
See if it works now.

If not, use the lock method I gave you above each time till it's fixed.
Last edited by Spearmint2 on Sun Nov 19, 2017 2:48 pm, edited 1 time in total.
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....

User avatar
all41
Level 11
Level 11
Posts: 3572
Joined: Tue Dec 31, 2013 9:12 am
Location: Computer, Car, Cage

Re: System not asking for password at resume

Postby all41 » Sun Nov 19, 2017 2:46 pm

Try setting your Screensaver Preferences to 'Lock screen'
Proud to be a supporter and monthly contributor to Mint.

amaci
Level 1
Level 1
Posts: 12
Joined: Mon Nov 06, 2017 7:37 am

Re: System not asking for password at resume

Postby amaci » Sun Nov 19, 2017 2:52 pm

@all41 it worked but I think it is still a bug, so they have to fix it.

aleks_yugovic
Level 1
Level 1
Posts: 2
Joined: Sun Nov 26, 2017 1:47 pm

Re: System not asking for password at resume

Postby aleks_yugovic » Sun Nov 26, 2017 1:55 pm

i encounter a similar problem, specifically when i first enter suspension with a *second screen* plugged in, which i *unplug while in suspension*: then, there is no password question at resume, but full access to programs and filesystem. though keyboard and right mouse clicks are disabled, left mouse clicks are working opening up a security leak. i reported it as https://bugs.launchpad.net/linuxmint/+bug/1734548

aleks_yugovic
Level 1
Level 1
Posts: 2
Joined: Sun Nov 26, 2017 1:47 pm

Re: System not asking for password at resume

Postby aleks_yugovic » Sun Nov 26, 2017 7:33 pm

i fear mate-screensaver, same as gnome-screensaver or cinnamon-screensaver, will stay insecure for a longer time period.
how to uninstall it? (without removing mate-meta) and replace it completely by a screen lock that works better?
i installed i3lock but could not even get it to run as daemon process.
then i installed and configured xscreensaver to run as daemon process instead of mate-screensver, but it did not screenlock with suspension/closing the laptop lid, so the screen kept unlocked after reopening.


Return to “MATE”