Error after upgrade to 18.3

Forum rules
Before you post please read how to get help
buscon
Level 1
Level 1
Posts: 14
Joined: Tue Sep 19, 2017 4:27 pm

Error after upgrade to 18.3

Postby buscon » Sun Dec 03, 2017 10:46 am

hi all,

I get this error every time I login into Mate since I upgraded from 18.2 to 18.3.
Otherwise everything is working fine.

Any idea how should i fix it?

thanks!




Error activating XKB configuration.
It can happen under various circumstances:
• a bug in libxklavier library
• a bug in X server (xkbcomp, xmodmap utilities)
• X server with incompatible libxkbfile implementation

X server version data:
The X.Org Foundation
11804000
If you report this situation as a bug, please include:
• The result of xprop -root | grep XKB
• The result of gsettings list-keys org.mate.peripherals-keyboard-xkb.kbd

$ xprop -root | grep XKB
6:_XKB_RULES_NAMES_BACKUP(STRING) = "evdev", "", "it,us,de", ",,", "terminate:ctrl_alt_bksp"
33:_XKB_RULES_NAMES(STRING) = "evdev", "", "it,us,de", ",,", "terminate:ctrl_alt_bksp"

$ gsettings list-keys org.mate.peripherals-keyboard-xkb.kbd
layouts
model
options

phil d
Level 1
Level 1
Posts: 2
Joined: Mon Dec 04, 2017 1:14 am

Re: Error after upgrade to 18.3

Postby phil d » Mon Dec 04, 2017 1:38 am

Im new here in fact this is my first post, but, I suspect thats a graphics card driver issue, the main reason i suspect that is due to the fact that, the x.org foundation is listed as being linked to the driver for my graphics card, by a utility called hard info (radeon hd 6670) and its listed in you quotes,

From what i gather older ati / amd graphics cards use legacy support (including mine) which comes with the distro, which are not likely to be updated, newer ati cards and nvidia cards have better driver support, which is ongoing and can be upgraded using propriatory drivers.

Although im no expert have you tried the driver manager ?

Failing that, try ;-

sudo apt-get update && sudo apt-get dist-upgrade -y

when it completes

sudo reboot

fingers crossed for you there.

User avatar
catweazel
Level 11
Level 11
Posts: 3738
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: Error after upgrade to 18.3

Postby catweazel » Mon Dec 04, 2017 3:37 am

buscon wrote:Error activating XKB configuration.

Your keyboard layout is set incorrectly. Use System Settings and set it to the correct keyboard.
There is no spoon.

buscon
Level 1
Level 1
Posts: 14
Joined: Tue Sep 19, 2017 4:27 pm

Re: Error after upgrade to 18.3

Postby buscon » Mon Dec 04, 2017 5:04 am

about video driver: my laptop uses the intel video card, so it should not be an issue. The system is also updated to last version

catweazel wrote:Your keyboard layout is set incorrectly. Use System Settings and set it to the correct keyboard.


ok, what do you mean exactly with "correct keyboard"?
I use three layouts, italian, german and US, they are there in the list and i can switch between them and they all work.
Keyboard model is set to unknown because it does not appear in the given option, is that what you mean maybe?

thanks!


Return to “MATE”