[SOLVED] Login Manager Keeps Forgetting The Language

Forum rules
Before you post please read how to get help
User avatar
nsk7even
Level 1
Level 1
Posts: 30
Joined: Tue Nov 29, 2011 1:50 pm
Location: http://www.server7even.de
Contact:

[SOLVED] Login Manager Keeps Forgetting The Language

Postby nsk7even » Tue Dec 05, 2017 3:11 pm

Hi all,

since a while, my login manager keeps forgetting the language setting. Instead of a country flag, there is a grey area only. I can click on it and select my language and it works for the current session without a problem. But after reboot, this field is grey again. When logging in without selecting my language, everything is in english... :D

This is not that super problematic, cause I understand english as well. But it's kind of irritating sometimes to have different button descriptions than previously.

How can I try to trace this down?

System:

Code: Select all

me@mymachine ~ $ uname -a
Linux mymachine 4.10.0-40-generic #44~16.04.1-Ubuntu SMP Thu Nov 9 15:37:44 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
me@mymachine ~ $ lsb_release -a
LSB Version:   core-9.20160110ubuntu0.2-amd64:core-9.20160110ubuntu0.2-noarch:security-9.20160110ubuntu0.2-amd64:security-9.20160110ubuntu0.2-noarch
Distributor ID:   LinuxMint
Description:   Linux Mint 18.3 Sylvia
Release:   18.3
Codename:   sylvia
me@mymachine ~ $


This is the mate version of mint and this system has an upgrade history since .... aehhmm .... something like 17.x I think.
I am not sure, but I think this issue occurred with one of the upgrades.

Thanks for any help!
Last edited by nsk7even on Wed Dec 20, 2017 3:41 pm, edited 1 time in total.

User avatar
nsk7even
Level 1
Level 1
Posts: 30
Joined: Tue Nov 29, 2011 1:50 pm
Location: http://www.server7even.de
Contact:

Re: Login Manager Keeps Forgetting The Language

Postby nsk7even » Mon Dec 11, 2017 2:06 pm

I noticed that a different accout than my main account is working correctly, though that there is no country flag for this account as well.

Question: where does the login manager stores its user specific settings?


User avatar
nsk7even
Level 1
Level 1
Posts: 30
Joined: Tue Nov 29, 2011 1:50 pm
Location: http://www.server7even.de
Contact:

Re: Login Manager Keeps Forgetting The Language

Postby nsk7even » Mon Dec 11, 2017 2:21 pm

Ouh, this is interesting...

Session with correct language selected:

Code: Select all

me@mymachine ~ $ cat /etc/default/locale
#  File generated by update-locale
LANG=de_DE.utf8


Session logged in, without having selected the language (grey field):

Code: Select all

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
   LANGUAGE = (unset),
   LC_ALL = (unset),
   LANG = "!! MYPASSWORD IS HERE IN CLEAR TEXT !!"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").

me@mymachine ~ $ cat /etc/default/locale
#  File generated by update-locale
LANG=de_DE.utf8


confused:

Code: Select all

me@mymachine ~ $ env | grep LANG
LANG=MYPASSWORD
MDM_LANG=MYPASSWORD


mdm tells my clear text password to the whole system!!?? :D :shock:

User avatar
nsk7even
Level 1
Level 1
Posts: 30
Joined: Tue Nov 29, 2011 1:50 pm
Location: http://www.server7even.de
Contact:

Re: Login Manager Keeps Forgetting The Language

Postby nsk7even » Wed Dec 20, 2017 2:42 pm

I installed slim, rebooted via slim, purged mdm, rebooted again, reinstalled mdm ..... but the issue persists!

Where does mdm stores the user specific selections? These where preserved over mdm's purge. For other users there is no problem, so I have to reset my mdm user settings only to solve the problem.

User avatar
nsk7even
Level 1
Level 1
Posts: 30
Joined: Tue Nov 29, 2011 1:50 pm
Location: http://www.server7even.de
Contact:

Re: Login Manager Keeps Forgetting The Language

Postby nsk7even » Wed Dec 20, 2017 3:39 pm

WAAAAH I FIXED IT!!

I digged into the source code of mdm and in https://github.com/linuxmint/mdm/blob/m ... n-config.c I found a reference to $HOME/.dmrc - in this file there was an entry like this:

Code: Select all

Language=MYPASSWORD

After removing this entry, it works now!

I don't really know how and why my password was entered into this file - it wasn't me! At least not directly.... I can remember that once I was in a hurry and confused and tired and I entered my password as username in mdm or something like that, but I can't remember accurately.

There are still no language flags, but I don't care as long as I can login now without having to choose my language all the times.....


Return to “MATE”