Touchscreen pointer not aligned after signin

Forum rules
Before you post please read how to get help
Post Reply
Level 2
Level 2
Posts: 98
Joined: Fri Oct 14, 2016 2:22 pm

Touchscreen pointer not aligned after signin

Post by earthlingkc » Fri Jan 26, 2018 2:26 pm

I have a Thinkpad S1 Yoga with Mint 18.3/Mate 1.18. On the login screen, the touchscreen works fine. The pointer is precisely located wherever touched. But after logging in, the pointer is several inches to the right of where touched. Any idea what might be executed/changed after startup to change behavior? It's as if the driver or Windows Manager settings changed since login. I also have a Yoga 700 and touchscreen works fine after login, same versions.

Code: Select all

$ inxi -F
System:    Host: xxxx Kernel: 4.13.0-31-generic x86_64 (64 bit)
           Desktop: MATE 1.18.0  Distro: Linux Mint 18.3 Sylvia
Machine:   System: LENOVO (portable) product: 20CD00B1US v: ThinkPad S1 Yoga
           Mobo: LENOVO model: 20CD00B1US v: SDK0E50510 Pro
           Bios: LENOVO v: B0ET19WW (1.06 ) date: 04/21/2014
CPU:       Dual core Intel Core i7-4600U (-HT-MCP-) cache: 4096 KB 
           clock speeds: max: 3300 MHz 1: 2693 MHz 2: 2693 MHz 3: 2693 MH, 
           4: 2693 MHz
Graphics:  Card: Intel Haswell-ULT Integrated Graphics Controller
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1920x1080@60.04hz, 1920x1080@60.00hz
           GLX Renderer: Mesa DRI Intel Haswell Mobile
           GLX Version: 3.0 Mesa 17.2.4
Audio:     Card-1 Intel 8 Series HD Audio Controller driver: snd_hda_intel
           Card-2 Intel Haswell-ULT HD Audio Controller driver: snd_hda_intel
           Card-3 Lenovo driver: USB Audio
           Sound: Advanced Linux Sound Architecture v: k4.13.0-31-generic
Network:   Card: Intel Wireless 7260 driver: iwlwifi
           IF: wlp4s0 state: up mac: fc:f8:ae:55:ba:5e
Drives:    HDD Total Size: 256.1GB (73.8% used)
           ID-1: USB /dev/sda model: ASM1351 size: 256.1GB
Partition: ID-1: / size: 227G used: 169G (79%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 8.42GB used: 0.00GB (0%) fs: swap dev: /dev/dm-0
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 64.0C mobo: N/A
           Fan Speeds (in rpm): cpu: 0
Info:      Processes: 244 Uptime: 18:59 Memory: 1983.9/7867.4MB
           Client: Shell (bash) inxi: 2.2.35 

Post Reply

Return to “MATE”