Date setting

Forum rules
Before you post please read how to get help
Post Reply
Klaas Vaak
Level 1
Level 1
Posts: 5
Joined: Fri Feb 16, 2018 6:18 am

Date setting

Post by Klaas Vaak » Fri Feb 16, 2018 8:32 am

1 week ago I installed Mate 18.3 in Virtual Box. I was able to change the date format in the bottom right corner, but the date format in Thunderbird did not react. I understand that Thunderbird's date format depends on the Linux date format.
Can someone tell me how to get the same date format in Thunderbird as in Linux?

User avatar
catweazel
Level 17
Level 17
Posts: 7774
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: Date setting

Post by catweazel » Fri Feb 16, 2018 6:52 pm

¡uʍop ǝpısdn sı buıɥʇʎɹǝʌǝ os ɐıןɐɹʇsnɐ ɯoɹɟ ɯ,ı

Klaas Vaak
Level 1
Level 1
Posts: 5
Joined: Fri Feb 16, 2018 6:18 am

Re: Date setting

Post by Klaas Vaak » Sat Feb 17, 2018 12:03 am

Thanks Catweazel, I had seen those 2 things too but they don't work, they don't support yyyy-mm-dd as in 2018-02-17.
From what I understand about Linux is that this is not a Thunderbird issue but is controlled by the regional settings, like in Windows.
My regional settings in Linux are done, as shown in the date in the bottom right corner: yyyy-mm-dd, but Thunderbird has not "complied".
Last edited by Klaas Vaak on Sat Feb 17, 2018 12:25 am, edited 1 time in total.

User avatar
MrEen
Level 8
Level 8
Posts: 2012
Joined: Mon Jun 12, 2017 8:39 pm

Re: Date setting

Post by MrEen » Sat Feb 17, 2018 12:20 am

From catweazel's first link:

Code: Select all

In Linux, these settings are based on your locale. 
If the environment variable "LANG" is set to "en_US", for example, Thunderbird will show the date in "MM/DD/YYYY" format. 
To override the locale only for showing dates, set the "LC_TIME" environment variable (for example, "LC_TIME=en_GB"). 
If you want the ISO 8601 date format (YYYY-MM-DD), use the "en_DK" locale. 

Klaas Vaak
Level 1
Level 1
Posts: 5
Joined: Fri Feb 16, 2018 6:18 am

Re: Date setting

Post by Klaas Vaak » Sat Feb 17, 2018 4:27 am

MrEen wrote:
Sat Feb 17, 2018 12:20 am
From catweazel's first link:

Code: Select all

In Linux, these settings are based on your locale. 
If the environment variable "LANG" is set to "en_US", for example, Thunderbird will show the date in "MM/DD/YYYY" format. 
To override the locale only for showing dates, set the "LC_TIME" environment variable (for example, "LC_TIME=en_GB"). 
If you want the ISO 8601 date format (YYYY-MM-DD), use the "en_DK" locale. 
Thanks Mr Een. Can you please tell me how I can get into the "locale" and/or how to change the "LANG" to "en_DK"?
The reason I ask this is that I am a 10-day young newbie :-)

User avatar
MrEen
Level 8
Level 8
Posts: 2012
Joined: Mon Jun 12, 2017 8:39 pm

Re: Date setting

Post by MrEen » Sat Feb 17, 2018 1:01 pm

From searching I found 2 ways to achieve this.

1.https://askubuntu.com/questions/918973/ ... efault-for has instructions just below "2 Answers" if your system uses US english.

2. https://ccollins.wordpress.com/2009/01/ ... on-ubuntu/ gives a very thorough way that prevents possibly changing language for month and day names. From the date in the URL this is quite old, but I think it would still work. You might need to change the use of gedit to whatever text editor you use. This one may be too difficult for a newbie.

You might want to wait for a more experienced user to offer further suggestions as these are not things I have done myself.

Good luck, and welcome to the forum! :)

Klaas Vaak
Level 1
Level 1
Posts: 5
Joined: Fri Feb 16, 2018 6:18 am

Re: Date setting

Post by Klaas Vaak » Sun Feb 18, 2018 1:05 pm

Many thanks for your help.

Using your solution 1 and with the "en_DK" locale I managed to get to get Thunderbird to display the dd/mm/yy format, which is better than mm/dd/yyyy, but it still not optimal. I'll keep looking.

Post Reply

Return to “MATE”