[Solved] Start GRUB, system does not start automatically

Forum rules
Before you post please read how to get help
Hobbit_222
Level 1
Level 1
Posts: 16
Joined: Tue Dec 12, 2017 7:13 am

[Solved] Start GRUB, system does not start automatically

Post by Hobbit_222 » Mon Feb 26, 2018 6:36 am

Hi all.
After turning on the computer I see GRUB command line.
I manually load kernel (linux vmlinuz), initrd and boot
After these operations, the system runs without problems, but not automatically.
How to fix it and return the system to automatic boot?
Thanks
Last edited by Hobbit_222 on Wed Feb 28, 2018 10:43 am, edited 3 times in total.

asinoro
Level 4
Level 4
Posts: 245
Joined: Mon Feb 12, 2018 11:43 am

Re: Start GRUB, system does not start automatically

Post by asinoro » Mon Feb 26, 2018 7:20 am

If you have the grub of Mint installed.

Code: Select all

sudo su

Code: Select all

update-grub

Code: Select all

update-initramfs -u
Then reboot.

Hobbit_222
Level 1
Level 1
Posts: 16
Joined: Tue Dec 12, 2017 7:13 am

Re: Start GRUB, system does not start automatically

Post by Hobbit_222 » Mon Feb 26, 2018 7:21 am

Thank you!

Hobbit_222
Level 1
Level 1
Posts: 16
Joined: Tue Dec 12, 2017 7:13 am

Re: Start GRUB, system does not start automatically

Post by Hobbit_222 » Wed Feb 28, 2018 7:05 am

After the entered commands rebooted, but there is no effect. Anyway GRUB command prompt

User avatar
Pjotr
Level 20
Level 20
Posts: 10158
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: Start GRUB, system does not start automatically

Post by Pjotr » Wed Feb 28, 2018 7:07 am

Please generate an overview of your system like this:
- Launch a terminal window (this is how to launch a terminal window);
- make the terminal window full screen, to avoid chopped lines;
- Copy/paste this command into the terminal:

Code: Select all

inxi -Fxz
(if you type: the letter F is a capital letter)

Press Enter.

Copy/paste the output in your next message.
Tip: 10 things to do after installing Linux Mint 18.3 Sylvia
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

Hobbit_222
Level 1
Level 1
Posts: 16
Joined: Tue Dec 12, 2017 7:13 am

Re: Start GRUB, system does not start automatically

Post by Hobbit_222 » Wed Feb 28, 2018 7:08 am

Code: Select all

System:    Host: AVALONTM Kernel: 4.13.0-26-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: MATE 1.18.0 (Gtk 3.18.9-1ubuntu3.3) Distro: Linux Mint 18.3 Sylvia
Machine:   System: Gigabyte product: N/A
           Mobo: Gigabyte model: H77-DS3H Bios: American Megatrends v: F2 date: 03/09/2012
CPU:       Quad core Intel Core i5-3570K (-MCP-) cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 27138
           clock speeds: max: 3800 MHz 1: 3392 MHz 2: 3392 MHz 3: 3392 MHz 4: 3392 MHz
Graphics:  Card: NVIDIA GF119 [GeForce GT 520] bus-ID: 01:00.0
           Display Server: X.org 1.18.4 driver: nvidia tty size: 238x68 Advanced Data: N/A for root
Audio:     Card-1 Intel 7 Series/C210 Series Family High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2 NVIDIA GF119 HDMI Audio Controller driver: snd_hda_intel bus-ID: 01:00.1
           Sound: Advanced Linux Sound Architecture v: k4.13.0-26-generic
Network:   Card: Qualcomm Atheros AR8151 v2.0 Gigabit Ethernet
           driver: atl1c v: 1.0.1.1-NAPI port: d000 bus-ID: 03:00.0
           IF: eth0 state: down mac: <filter>
Drives:    HDD Total Size: 2120.4GB (5.6% used) ID-1: /dev/sda model: ST2000DM001 size: 2000.4GB temp: 32C
           ID-2: /dev/sdb model: INTEL_SSDSC2CW12 size: 120.0GB temp: 0C
Partition: ID-1: / size: 92G used: 78G (90%) fs: ext4 dev: /dev/sdb1
           ID-2: swap-1 size: 17.00GB used: 0.00GB (0%) fs: swap dev: /dev/sda3
           ID-3: swap-2 size: 20.03GB used: 0.00GB (0%) fs: swap dev: /dev/sdb2
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 29.8C mobo: 27.8C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 283 Uptime: 4 min Memory: 4580.5/16002.3MB Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 

User avatar
Pjotr
Level 20
Level 20
Posts: 10158
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: Start GRUB, system does not start automatically

Post by Pjotr » Wed Feb 28, 2018 7:22 am

Why do you have two swap partitions? And your root partition is much too full: 80 % is a reasonable maximum, in order to prevent file fragmentation.

About Grub: try if it helps when you install all level 4 updates, including the non-security ones. And while you're at it: upgrade your kernel to the latest one of the 4.13 series (-36), because the Meltdown/Spectre disaster makes it too risky to skip kernel updates.

For example like this:

Code: Select all

sudo apt-get update && sudo apt-get dist-upgrade
Then reboot.
Tip: 10 things to do after installing Linux Mint 18.3 Sylvia
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

Hobbit_222
Level 1
Level 1
Posts: 16
Joined: Tue Dec 12, 2017 7:13 am

Re: Start GRUB, system does not start automatically

Post by Hobbit_222 » Wed Feb 28, 2018 8:05 am

There is no effect from the upgrade. I cleaned the disk a little, but this also did not bring success.

Code: Select all

System:    Host: AVALONTM Kernel: 4.13.0-26-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: MATE 1.18.0 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.3 Sylvia
Machine:   System: Gigabyte product: N/A
           Mobo: Gigabyte model: H77-DS3H
           Bios: American Megatrends v: F2 date: 03/09/2012
CPU:       Quad core Intel Core i5-3570K (-MCP-) cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 27137
           clock speeds: max: 3800 MHz 1: 3392 MHz 2: 3392 MHz 3: 3392 MHz
           4: 3392 MHz
Graphics:  Card: NVIDIA GF119 [GeForce GT 520] bus-ID: 01:00.0
           Display Server: X.Org 1.18.4 driver: nvidia
           Resolution: 1920x1080@60.00hz, 1920x1080@60.00hz
           GLX Renderer: GeForce GT 520/PCIe/SSE2
           GLX Version: 4.6.0 NVIDIA 387.34 Direct Rendering: Yes
Audio:     Card-1 Intel 7 Series/C210 Series Family High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2 NVIDIA GF119 HDMI Audio Controller
           driver: snd_hda_intel bus-ID: 01:00.1
           Sound: Advanced Linux Sound Architecture v: k4.13.0-26-generic
Network:   Card: Qualcomm Atheros AR8151 v2.0 Gigabit Ethernet
           driver: atl1c v: 1.0.1.1-NAPI port: d000 bus-ID: 03:00.0
           IF: eth0 state: down mac: <filter>
Drives:    HDD Total Size: 2120.4GB (5.0% used)
           ID-1: /dev/sda model: ST2000DM001 size: 2000.4GB
           ID-2: /dev/sdb model: INTEL_SSDSC2CW12 size: 120.0GB
Partition: ID-1: / size: 92G used: 66G (76%) fs: ext4 dev: /dev/sdb1
           ID-2: swap-1 size: 17.00GB used: 0.00GB (0%) fs: swap dev: /dev/sda3
           ID-3: swap-2 size: 20.03GB used: 0.00GB (0%) fs: swap dev: /dev/sdb2
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 29.8C mobo: 27.8C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 235 Uptime: 1 min Memory: 2576.7/16002.3MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 

Cosmo.
Level 23
Level 23
Posts: 17830
Joined: Sat Dec 06, 2014 7:34 am

Re: Start GRUB, system does not start automatically

Post by Cosmo. » Wed Feb 28, 2018 8:16 am

When (after which system change) did this problem at first happen?

Open the file manager and navigate to /etc/default and load the file grub in a text editor. Copy and paste the content here.

Hobbit_222
Level 1
Level 1
Posts: 16
Joined: Tue Dec 12, 2017 7:13 am

Re: Start GRUB, system does not start automatically

Post by Hobbit_222 » Wed Feb 28, 2018 8:17 am

Code: Select all

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
#GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX_DEFAULT=""
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

asinoro
Level 4
Level 4
Posts: 245
Joined: Mon Feb 12, 2018 11:43 am

Re: Start GRUB, system does not start automatically

Post by asinoro » Wed Feb 28, 2018 8:51 am

Re install the grub by :
Find first your Uefi partition to mount.

Code: Select all

sudo su

Code: Select all

parted -l
Where sdXX your EFI partition sdX your os drive partition and run the command.

Code: Select all

mount /dev/sdXX /boot/efi ; grub-install /dev/sdX ; update-grub ; update-initramfs -u
Rebbot.

Hobbit_222
Level 1
Level 1
Posts: 16
Joined: Tue Dec 12, 2017 7:13 am

Re: Start GRUB, system does not start automatically

Post by Hobbit_222 » Wed Feb 28, 2018 9:29 am

I did everything, but everything remained as before after the reboot.

asinoro
Level 4
Level 4
Posts: 245
Joined: Mon Feb 12, 2018 11:43 am

Re: Start GRUB, system does not start automatically

Post by asinoro » Wed Feb 28, 2018 9:32 am

Can you post:

Code: Select all

lsblk --sort name --output name,label,size,fstype,mountpoint

Hobbit_222
Level 1
Level 1
Posts: 16
Joined: Tue Dec 12, 2017 7:13 am

Re: Start GRUB, system does not start automatically

Post by Hobbit_222 » Wed Feb 28, 2018 9:33 am

System is installed on sdb1.
sda by default not mounted.

Code: Select all

sda          1.8T        
sda1         512M vfat   /boot/efi
sda2         1.8T ext4   
sda3        15.9G swap   [SWAP]
sdb        111.8G        
sdb1        93.1G ext4   /
sdb2        18.7G swap   [SWAP]
Last edited by Hobbit_222 on Wed Feb 28, 2018 9:37 am, edited 1 time in total.

Marziano
Level 6
Level 6
Posts: 1216
Joined: Thu Jan 04, 2018 1:00 pm

Re: Start GRUB, system does not start automatically

Post by Marziano » Wed Feb 28, 2018 9:36 am

You are still on
Host: AVALONTM Kernel: 4.13.0-26-generic x86_64 (64 bit gcc: 5.4.0)
while judging from what was suggested above you would be running 4.13.0-36. But maybe that is beside the point relating to the specific issue you are having.
Last edited by Marziano on Wed Feb 28, 2018 9:42 am, edited 1 time in total.
"Those are my principles, and if you don't like them...well, I have others." -Marx...
Groucho { Marx

asinoro
Level 4
Level 4
Posts: 245
Joined: Mon Feb 12, 2018 11:43 am

Re: Start GRUB, system does not start automatically

Post by asinoro » Wed Feb 28, 2018 9:40 am

If you run:

Code: Select all

blkid
the UUID of swap are the same with:

Code: Select all

cat /etc/fstab 

Hobbit_222
Level 1
Level 1
Posts: 16
Joined: Tue Dec 12, 2017 7:13 am

Re: Start GRUB, system does not start automatically

Post by Hobbit_222 » Wed Feb 28, 2018 9:53 am

inxi

Code: Select all

System:    Host: AVALONTM Kernel: 4.13.0-36-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: MATE 1.18.0 (Gtk 3.18.9-1ubuntu3.3) Distro: Linux Mint 18.3 Sylvia
Machine:   System: Gigabyte product: N/A
           Mobo: Gigabyte model: H77-DS3H Bios: American Megatrends v: F2 date: 03/09/2012
CPU:       Quad core Intel Core i5-3570K (-MCP-) cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 27137
           clock speeds: max: 3800 MHz 1: 3392 MHz 2: 3392 MHz 3: 3392 MHz 4: 3392 MHz
Graphics:  Card: NVIDIA GF119 [GeForce GT 520] bus-ID: 01:00.0
           Display Server: X.Org 1.18.4 driver: nvidia Resolution: 1920x1080@60.00hz, 1920x1080@60.00hz
           GLX Renderer: GeForce GT 520/PCIe/SSE2 GLX Version: 4.6.0 NVIDIA 387.34 Direct Rendering: Yes
Audio:     Card-1 Intel 7 Series/C210 Series Family High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2 NVIDIA GF119 HDMI Audio Controller driver: snd_hda_intel bus-ID: 01:00.1
           Sound: Advanced Linux Sound Architecture v: k4.13.0-36-generic
Network:   Card: Qualcomm Atheros AR8151 v2.0 Gigabit Ethernet
           driver: atl1c v: 1.0.1.1-NAPI port: d000 bus-ID: 03:00.0
           IF: eth0 state: down mac: <filter>
Drives:    HDD Total Size: 2151.7GB (55.5% used) ID-1: /dev/sda model: ST2000DM001 size: 2000.4GB
           ID-2: /dev/sdb model: INTEL_SSDSC2CW12 size: 120.0GB
           ID-3: USB /dev/sdc model: Transcend_32GB size: 31.3GB
Partition: ID-1: / size: 92G used: 67G (77%) fs: ext4 dev: /dev/sdb1
           ID-2: swap-1 size: 17.00GB used: 0.00GB (0%) fs: swap dev: /dev/sda3
           ID-3: swap-2 size: 20.03GB used: 0.00GB (0%) fs: swap dev: /dev/sdb2
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 29.8C mobo: 27.8C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 273 Uptime: 9 min Memory: 4325.7/16002.4MB Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 
fstab

Code: Select all

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sdb1 during installation
# swap was on /dev/sda3 during installation
UUID=86af527d-c7ff-4b3f-821b-0a5ba916adf6 none            swap    sw              0       0
# swap was on /dev/sdb2 during installation
UUID=2ce7a28b-f8e1-497a-aa27-577ccfd6d7f1 none            swap    sw              0       0

tmpfs /tmp tmpfs defaults 0 0
tmpfs /var/tmp tmpfs defaults 0 0
#tmpfs /var/lock tmpfs defaults 0 0
tmpfs /var/spool/postfix tmpfs defaults 0 0
UUID=0b7a69fd-8f8a-4952-82cb-cdf5c767f53e / ext4 discard,errors=remount-ro 0 1

UUID=BED8-33A7	/boot/efi	vfat	defaults	0	1

asinoro
Level 4
Level 4
Posts: 245
Joined: Mon Feb 12, 2018 11:43 am

Re: Start GRUB, system does not start automatically

Post by asinoro » Wed Feb 28, 2018 10:01 am

You don’t need to post these info, I ask you if blkid UUID is the same in fstab. Is it?

Hobbit_222
Level 1
Level 1
Posts: 16
Joined: Tue Dec 12, 2017 7:13 am

Re: Start GRUB, system does not start automatically

Post by Hobbit_222 » Wed Feb 28, 2018 10:04 am

asinoro wrote:
Wed Feb 28, 2018 10:01 am
You don’t need to post these info, I ask you if blkid UUID is the same in fstab. Is it?
Yes

User avatar
Pjotr
Level 20
Level 20
Posts: 10158
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: Start GRUB, system does not start automatically

Post by Pjotr » Wed Feb 28, 2018 10:04 am

Start by disabling the superfluous double swap partition on sda3:

Code: Select all

gksudo xed /etc/fstab
Put a hash tag before its line:

Code: Select all

# UUID=86af527d-c7ff-4b3f-821b-0a5ba916adf6 none            swap    sw              0       0
That leaves only sdb1 for root and sdb2 for swap.

Save the modified fstab, close it and reboot.
Tip: 10 things to do after installing Linux Mint 18.3 Sylvia
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

Post Reply

Return to “MATE”