"MintMenuAppletFactory::MintMenuApplet" and multiple user configs?

Forum rules
Before you post please read how to get help
Post Reply
User avatar
geekomatic
Level 4
Level 4
Posts: 218
Joined: Sun Jun 06, 2010 1:11 am
Location: Awesome Western Australia!

"MintMenuAppletFactory::MintMenuApplet" and multiple user configs?

Post by geekomatic » Mon Apr 30, 2018 11:21 pm

Hi everyone,

I'm running 17.1/64. File manager is the default, Caja. All has been basically fine for, well, years now. :)

However, in the past 3-4 days, when I start the computer in the morning, I get the "MintMenuAppletFactory::MintMenuApplet" cannot be started error (and do I want to delete or not).

I ctrl/alt/del>restart, and the menu is back. It's not currently a huge issue, but I don't like it when something like that, a main feature, suddenly starts having a problem.

I found quite a few others online with this problem & one "solution" (it was a workaround, not a fix) was to add a new user>log out>log in>if it worked>copy the new config file to the original user config.

I'm not one to simply wipe out config files, but I decided to have a look at mine. In the .config/.dconf folder, I have no less than five user configs in there?

user (1 May 2018) 33.9kb
user.1HGY2Y (2 July 2017) 31.6kb
user.KOJ15Y (26 Aug 2017) 31.7kb
user.Q3MWVX (15 Mar 2015) 17.8kb
user.YDCB2Y (16 Jun 2017) 31.6kb

I tried using terminal to open them with gedit, but they all show as blank? How do I get in to look at them?

Am I right to think it's something to do with this or entirely off-base? Any ideas to find the cause for the disappearing menu greatly appreciated!

User avatar
Pierre
Level 16
Level 16
Posts: 6931
Joined: Fri Sep 05, 2008 5:33 am
Location: Perth, AU.

Re: "MintMenuAppletFactory::MintMenuApplet" and multiple user configs?

Post by Pierre » Mon Apr 30, 2018 11:29 pm

that does sound like the system crashed out, for some reason:
- most likely *not* a HDD issue, but it would pay to check that, via Disks, which is in Accessories.

on this Laptop, in that /user/.config/.dconf folder, there is only one file: User .. .. nothing else.

you could also, create another User, on the machine, use that for a while,
and see if that error comes back, again.

yeah - - I've had the odd issue like that, and it's hard to *not* click on the suggested 'Delete' . ..
but, that issue, never came back again, so it's hard to know what caused it.
Image
Please edit your original post title to include [SOLVED] - when your problem is solved!
and DO LOOK at those Unanswered Topics - - you may be able to answer some!.

User avatar
geekomatic
Level 4
Level 4
Posts: 218
Joined: Sun Jun 06, 2010 1:11 am
Location: Awesome Western Australia!

Re: "MintMenuAppletFactory::MintMenuApplet" and multiple user configs?

Post by geekomatic » Tue May 01, 2018 12:28 am

Hi Pierre,

Disks says all is well with the drives.

So, is there any way for me to open these files to see what's in them? They obviously have "something" in them, considering their sizes?

Ta

Post Reply

Return to “MATE”