Desktop goes black Solved (for all time!)

Forum rules
Before you post please read how to get help
User avatar
mintyfresh2
Level 1
Level 1
Posts: 22
Joined: Sun Jan 14, 2018 3:59 pm

Re: Desktop goes black

Post by mintyfresh2 » Sun May 20, 2018 4:05 pm

JoeFootball,

I have been updating thru the level 4 option, and thought I had
the latest Kernel <4.13.0-41-generic x86_64> installed.

I have no idea how to update a kernel aside from the "Install updates" screen..
thx.

now running
charlie@OptiPlex-740 ~ $ sudo inxi -Fxxrzc0
[sudo] password for charlie:
System: Host: OptiPlex-740 Kernel: 4.13.0-41-generic x86_64 (64 bit gcc: 5.4.0)

and still suffer the issue of screen blanking, after exactly, 10 minutes of operation,
as if the video cable (only) is disconnected. Tap a key, or move the mouse,
count to 3 and the screen is restored only to happen again in 10 minutes.

This was not an issue until the upgrade to 18.3 mate/ Sylvia
Desktop: MATE 1.18.0 (Gtk 3.18.9-1ubuntu3.3) dm: lightdm
now Running Firefox 60.0.1 (64-bit)
Mintyfresh2
aka Charlie

User avatar
MrEen
Level 6
Level 6
Posts: 1043
Joined: Mon Jun 12, 2017 8:39 pm

Re: Desktop goes black

Post by MrEen » Sun May 20, 2018 6:53 pm

Hi mintyfresh2. Maybe give this a try. In the Software Manager, install Mate-power-manager. I'm betting you find a setting with it that'll fix you.

User avatar
JoeFootball
Level 6
Level 6
Posts: 1392
Joined: Tue Nov 24, 2009 1:52 pm
Location: /home/usa/mn/minneapolis/joe

Re: Desktop goes black

Post by JoeFootball » Mon May 21, 2018 6:26 pm

mintyfresh2 wrote:I have no idea how to update a kernel aside from the "Install updates" screen.
You can add/delete kernels with Update Manager, from the View menu, select Kernel Updates.

GRUB will default to the latest-installed kernel version, so if your looking to test with the 4.4.x LTS branch, don't delete any existing kernels, but install the latest version of 4.4.x. If you boot to the GRUB menu, select Advanced Options and select the 4.4.x kernel. If you don't automatically boot to the GRUB menu, hold down the shift key during boot.

If 4.4.x solves your problem, then you can delete the other installed kernel branches, and you will automatically boot to 4.4.x instead.

EDIT: Here's more info on installing kernels via the Update Manager.

Joe

User avatar
mintyfresh2
Level 1
Level 1
Posts: 22
Joined: Sun Jan 14, 2018 3:59 pm

Re: Desktop goes black

Post by mintyfresh2 » Tue May 22, 2018 12:43 am

JoeFootball:
OK, I loaded Kernel 4.4.0-127.xxx... and rebooted.

Something changed
I let it go thru half a dozen or so blankings, timing it.
Now it runs an extra minute ( was 10, now is 11) before blanking.
I think that may be just a fluke...
Mintyfresh2
aka Charlie

User avatar
JoeFootball
Level 6
Level 6
Posts: 1392
Joined: Tue Nov 24, 2009 1:52 pm
Location: /home/usa/mn/minneapolis/joe

Re: Desktop goes black

Post by JoeFootball » Tue May 22, 2018 7:25 am

mintyfresh2 wrote:I loaded Kernel 4.4.0-127.xxx... and rebooted.
ok, not the kernel then.
mintyfresh2 wrote:This was not an issue until the upgrade to 18.3 mate/ Sylvia
For clarity, this was a version upgrade via the Update Manager? (i.e., not a fresh install of 18.3) If so, was this from 18.2?

My speculation is that the video card is killing the signal to the TV for whatever reason. I don't think it's the screensaver. I don't think it's the TV.

If you create a new account and log into it, does it exhibit the same behavior?

If you were to boot to a live session of 18.3, does it exhibit the same behavior?

EDIT: Are you using the recommended video driver (if any) in Driver Manager?

Joe

User avatar
mintyfresh2
Level 1
Level 1
Posts: 22
Joined: Sun Jan 14, 2018 3:59 pm

Re: Desktop goes black

Post by mintyfresh2 » Sat May 26, 2018 12:53 am

JoeFootball:

1) Agreed! Not Kernel

2) this was a fresh install 17.2 .. to 18.3 from CD. I first booted in a live session,
and watched a full movie, no blanking. So I decided to try with another reinstall, this time a side by side.

I now have two separate versions. the original 18.2 on sda1, and... THE REINSTALL ON sda2
seems for the time being, I can watch a movie without interruption... on sda2

Still do not know for sure what the difference is that causes the blanking... but I suspect it may be that "fix"
for the "Spectre" flaw that's been giving folks a hard time ( I DL'd the "fix" as a prophylactic. ) but neglected to do so this time.

Going to see what happens, this way, for a while. marking it solved for now...

Charlie
Mintyfresh2
aka Charlie

User avatar
mintyfresh2
Level 1
Level 1
Posts: 22
Joined: Sun Jan 14, 2018 3:59 pm

Re: Desktop goes black[EXPLANATION] Solved (for now )

Post by mintyfresh2 » Sat May 26, 2018 12:02 pm

Hey All, for future reference :
I've run

Code: Select all

 xset q 
in a terminal and compared it to the problematic install
I found these differences:

old install w/video blanking issue:

Code: Select all

 cnn@Charlie-OptiPlex ~ $ xset q
Keyboard Control:
  auto repeat:  on    key click percent:  0    LED mask:  00000000
  XKB indicators:
    00: Caps Lock:   off    01: Num Lock:    off    02: Scroll Lock: off
    03: Compose:     off    04: Kana:        off    05: Sleep:       off
    06: Suspend:     off    07: Mute:        off    08: Misc:        off
    09: Mail:        off    10: Charging:    off    11: Shift Lock:  off
    12: Group 2:     off    13: Mouse Keys:  off
  auto repeat delay:  500    repeat rate:  30
  auto repeating keys:  00ffffffdffffbbf
                        fadfffefffedffff
                        9fffffffffffffff
                        fff7ffffffffffff
  bell percent:  50    bell pitch:  400    bell duration:  100
Pointer Control:
  acceleration:  2/1    threshold:  4 
Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
SO far.. So good~!

but here, it is different

Code: Select all

 timeout: 600    cycle: 600 

And also different, here

Code: Select all

 DPMS (Energy Star):  Standby:600    Suspend: 600    Off: 0 
the rest is OK.

Code: Select all

  DPMS is Enabled
  Monitor is On
cnn@Charlie-OptiPlex ~ $ 

Then, I ran the same command on the new install. The difference was :

Code: Select all

 Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
   timeout:  0    cycle:  0 
And the

Code: Select all

 DPMS (Energy Star):   Standby: 0    Suspend: 0    Off: 0 
It seems that this, is what, apparently, voided the problem.

Weird, as the Screensaver GUI, should have reset these parameters to zero,
when "never" was chosen but, it apparently didn't. I just recently found the
xset q
on the "StackOverflow" website.

I have no recollection, intentionally or otherwise, of setting these parameters, at any time in the past.
Their appearance is a mystery to me.
Mintyfresh2
aka Charlie

User avatar
JoeFootball
Level 6
Level 6
Posts: 1392
Joined: Tue Nov 24, 2009 1:52 pm
Location: /home/usa/mn/minneapolis/joe

Re: Desktop goes black[EXPLANATION] Solved (for now )

Post by JoeFootball » Sun May 27, 2018 9:46 am

mintyfresh2 wrote:DPMS (Energy Star): Standby:600 Suspend: 600 Off: 0
That's quite a find, and indeed 600 seconds is your 10 minute timeout. Thanks for posting the follow up. Good work! :)

Joe

User avatar
mintyfresh2
Level 1
Level 1
Posts: 22
Joined: Sun Jan 14, 2018 3:59 pm

Re: Desktop goes black Solved (for now )

Post by mintyfresh2 » Tue May 29, 2018 12:33 pm

Thanks, JoeFootball.
this thing has been a thorn in my paw, for over a month now!!
I must have put in 30 - 40 hours researching, and testing,
cause it seems that is all I've been doing... :cry:

But, perseverance pays off! :D

Many thanks to all who assisted, and gave support...you know who y'all are.

and Oh!
That Spectre/Meltdown flaw I spoke of is a firmware fix.
you do not have to reinstall it , even if you format the hard drive,
as it stays with the hardware.

It was not connected AFAIK to the DPMS settings, as I had originally thought.

Hope this can help someone else with this headache!
Mintyfresh2
aka Charlie

Dusenberg
Level 1
Level 1
Posts: 5
Joined: Mon Jul 28, 2014 10:46 am

Re: Desktop goes black Solved (for all time!)

Post by Dusenberg » Wed Jun 13, 2018 11:47 am

Thanks so much mintyfresh2 and contributors.

I had exactly the same problem on a new Gigabit BRIX i5 after install of Mint 18.2-Mate.
For ages we've used a small linux pc as a media player (mainly iplayer, netflix and own
videos) strapped to the back of a ASUS 27inch monitor connected by HDMI, but the old Zotac
AMD box was way past it (not enough oomph for HD) so last week I finally replaced it.

Mint install on the BRIX was very easy and the ONLY problem was the 10 minute screen blanking which
is completely unacceptable for a media player.

Like mintyfresh2 I'd tried everything (screensaver, power managemnt) and then stumbled on this thread so went through the same steps, but I immediately hit a problem with xset on the BRIX:

Code: Select all

@j-laptop ~ $ ssh mediauser@mediapc
mediauser@mediapc's password: 
Welcome to Linux Mint 18.2 Sonya (GNU/Linux 4.8.0-53-generic x86_64)
mediauser@mediapc ~ $ xset q
xset:  unable to open display ""
mediauser@mediapc ~ $ xset
usage:  xset [-display host:dpy] option ...
Don't understand why this happens on the BRIX, as the same command on my Mint18.2-Mate laptop does give output

Code: Select all

j@j-laptop ~ $ xset q
Keyboard Control:
  auto repeat:  on    key click percent:  0    LED mask:  00000002
  XKB indicators:
    00: Caps Lock:   off    01: Num Lock:    on     02: Scroll Lock: off
    03: Compose:     off    04: Kana:        off    05: Sleep:       off
    06: Suspend:     off    07: Mute:        off    08: Misc:        off
    09: Mail:        off    10: Charging:    off    11: Shift Lock:  off
    12: Group 2:     off    13: Mouse Keys:  off
  auto repeat delay:  500    repeat rate:  30
  auto repeating keys:  00ffffffdffffbbf
                        fadfffefffedffff
                        9fffffffffffffff
                        fff7ffffffffffff
  bell percent:  50    bell pitch:  400    bell duration:  100
Pointer Control:
  acceleration:  2/1    threshold:  4
Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  0    cycle:  0
Colors:
  default colormap:  0x22    BlackPixel:  0x0    WhitePixel:  0xffffff
Font Path:
  /usr/share/fonts/X11/misc,/usr/share/fonts/X11/Type1,built-ins
DPMS (Energy Star):
  Standby: 0    Suspend: 0    Off: 0
  DPMS is Enabled
  Monitor is On
So I looked for a display device name but couldn't find it.... until I read this VERY useful reply on askubuntu
https://askubuntu.com/questions/121014/ ... mmand-line

Don't forget to add -display :0.0 if trying this from remote log-in (putty?). – Nikola Malešević Mar 5 '15 at 0:31
I WAS connecting to the BRIX by terminal and ssh so that must be why xset was playing up, so used Nikola's advice and.....

Code: Select all

mediauser@mediapc ~ $ xset -display :0.0 q
Keyboard Control:
  auto repeat:  on    key click percent:  0    LED mask:  00000000
  XKB indicators:
    00: Caps Lock:   off    01: Num Lock:    off    02: Scroll Lock: off
    03: Compose:     off    04: Kana:        off    05: Sleep:       off
    06: Suspend:     off    07: Mute:        off    08: Misc:        off
    09: Mail:        off    10: Charging:    off    11: Shift Lock:  off
    12: Group 2:     off    13: Mouse Keys:  off
  auto repeat delay:  500    repeat rate:  30
  auto repeating keys:  00ffffffdffffbbf
                        fadfffefffedffff
                        9fffffffffffffff
                        fff7ffffffffffff
  bell percent:  50    bell pitch:  400    bell duration:  100
Pointer Control:
  acceleration:  2/1    threshold:  4
Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  0    cycle:  0
Colors:
  default colormap:  0x22    BlackPixel:  0x0    WhitePixel:  0xffffff
Font Path:
  /usr/share/fonts/X11/misc,/usr/share/fonts/X11/Type1,built-ins
DPMS (Energy Star):
  Standby: 600    Suspend: 600    Off: 600
  DPMS is Enabled
  Monitor is Off
Bingo! In my case, DPMS is enabled and timeout is 10 minutes - and the screen had actually blanked while I was trying things out.

I found you can change DPMS settings in xset (see its usage info) and switch off standby, suspend and off by setting them to zero so coded:

Code: Select all

xset -display :0.0 dpms 0 0 0
.......and problem solved.

So once again, thanks to all!

IMO this issue is so fundamental (and hidden) that the settings controlling it need to be in the Mint Monitor Preferences and/or Power Management screens.

Dusenberg
Level 1
Level 1
Posts: 5
Joined: Mon Jul 28, 2014 10:46 am

Re: Desktop goes black Solved (for all time!)

Post by Dusenberg » Wed Jun 20, 2018 2:44 pm

...but I was too quick - it did not work. Next reboot and it was the same problem..... It seems xset only changes settings for the currrent session... and I was working over ssh.

I eventually found the right info in ArchLinux (https://wiki.archlinux.org/index.php/Di ... _Signaling) but had to figure out which file to use in 18.2. Adding the following entry into /etc/X11/xorg.conf retained the dpms and screensave settings across boots:

Code: Select all

Section "ServerLayout"
    Identifier "ServerLayout0"
    Option "StandbyTime" "0"
    Option "SuspendTime" "0"
    Option "OffTime"     "0"
    Option "BlankTime"   "0"
EndSection
The first three are the dpms settings, the last the screensaver.

So far it seems to have worked.......

Post Reply

Return to “MATE”