in Mint 19 Mate, some themes disable desktop wallpapers

Forum rules
Before you post please read how to get help
Post Reply
Jim Shaffer
Level 1
Level 1
Posts: 8
Joined: Sun Mar 09, 2014 9:27 pm

in Mint 19 Mate, some themes disable desktop wallpapers

Post by Jim Shaffer » Sun Jun 03, 2018 8:42 pm

If I use only the themes supplied with Mint, everything works fine. But if I install certain other themes (for example, https://www.mate-look.org/p/1225712/), my wallpaper vanishes, replaced by a solid background. I found that if I turn off desktop icons, my wallpaper comes back. But I should be able to have both wallpaper and desktop icons, shouldn't I? And why does it only happen with certain themes? (The themes I've tried are specifically said to be designed for GTK 3.22 -- and some themes I've tried that were designed for earlier versions of GTK don't work at all.)

KBD47
Level 7
Level 7
Posts: 1588
Joined: Fri Jul 29, 2011 12:03 am

Re: in Mint 19 Mate, some themes disable desktop wallpapers

Post by KBD47 » Sun Jun 03, 2018 9:33 pm

This may be a bug in the beta version. Might mention it on the blog when Mint 19 beta is officially announced tomorrow. There are glitches in these betas and you may have found one.

Jim Shaffer
Level 1
Level 1
Posts: 8
Joined: Sun Mar 09, 2014 9:27 pm

Re: in Mint 19 Mate, some themes disable desktop wallpapers

Post by Jim Shaffer » Sat Jun 09, 2018 6:04 pm

Apparently this isn't a Mint problem after all, as I tried it in a different distro with the latest Maté and it still manifests.

JosephM
Level 6
Level 6
Posts: 1052
Joined: Sun May 26, 2013 6:25 pm

Re: in Mint 19 Mate, some themes disable desktop wallpapers

Post by JosephM » Sat Jun 09, 2018 7:58 pm

This sounds like it might actually be an issue with the theme. When you enable the desktop icons you get a window which covers your entire desktop that holds the icons. The theme might be inadvertently setting a color on that window instead of allowing it to be transparent so your wallpaper can show through.
When I give opinions, they are my own. Not necessarily those of any other Linux Mint developer or the Linux Mint project as a whole.

User avatar
Pierre
Level 17
Level 17
Posts: 7157
Joined: Fri Sep 05, 2008 5:33 am
Location: Perth, AU.

Re: in Mint 19 Mate, some themes disable desktop wallpapers

Post by Pierre » Sun Jun 10, 2018 3:31 am

yet, some themes are tied to a fixed wallpaper as well,
& so the changing of the one, will the affect the other as well.
Image
Please edit your original post title to include [SOLVED] - when your problem is solved!
and DO LOOK at those Unanswered Topics - - you may be able to answer some!.

Jim Shaffer
Level 1
Level 1
Posts: 8
Joined: Sun Mar 09, 2014 9:27 pm

Re: in Mint 19 Mate, some themes disable desktop wallpapers

Post by Jim Shaffer » Sun Jun 10, 2018 2:02 pm

JosephM wrote:
Sat Jun 09, 2018 7:58 pm
This sounds like it might actually be an issue with the theme. When you enable the desktop icons you get a window which covers your entire desktop that holds the icons. The theme might be inadvertently setting a color on that window instead of allowing it to be transparent so your wallpaper can show through.
This sounds like it might be the problem, however I have no idea how one edits a theme other than with the control panel tools which are no help in this area, so I guess I'll either be using a theme I don't particularly care for or not having desktop icons. (The reason I went looking for new themes is that several that I had really liked finally broke beyond my ability to tolerate them with the latest GTK, after developing minor irritations with the previous version.) I did leave a note for the theme's author, but with no reply so far.

Jim Shaffer
Level 1
Level 1
Posts: 8
Joined: Sun Mar 09, 2014 9:27 pm

Re: in Mint 19 Mate, some themes disable desktop wallpapers

Post by Jim Shaffer » Wed Jul 04, 2018 4:07 pm

I finally had time to hunt this one down.

In the gtk-3.0 directory of the theme is a file named gtk-widgets.css. Within that file is a section that looks like

Code: Select all

/* Client Side Decoration */
.background {
	background-image: linear-gradient(to right,
	                                  #080608,
					  #252423 25%,
					  #353535 50%,
					  #252423 75%,
					  #080608);
}
Commenting this out disabled the annoying overriding of my wallpaper choice.

Post Reply

Return to “MATE”