Page 1 of 1

Linux Mint Mate Menu Issues

Posted: Fri Jun 15, 2018 11:08 am
by Caltrop
New Computer, new Linux Mint, new problems...

I see the Mate Menu is still messed up as ever.

New apps don't install menu items so it has to be done manually.

I got some Wine items added to the menu & tried to move them around.

Now I have a BLANK Menu! :o
Can not edit the menu anymore either, wow...
Menu Blank - 0.5x.png
here's what mozo gives me:

Code: Select all

caltrop@dragon ~ $ mozo
Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.

** (mozo:3753): WARNING **: Error loading menu layout from "/home/caltrop/.config/menus/mate-applications.menu": Line 121 character 1: Element <Old> is required to contain text and was empty

Traceback (most recent call last):
  File "/usr/bin/mozo", line 36, in <module>
    main()
  File "/usr/bin/mozo", line 33, in main
    app.run()
  File "/usr/lib/python2.7/dist-packages/Mozo/MainWindow.py", line 82, in run
    self.loadMenus()
  File "/usr/lib/python2.7/dist-packages/Mozo/MainWindow.py", line 227, in loadMenus
    self.loadMenu(iters, menu)
  File "/usr/lib/python2.7/dist-packages/Mozo/MainWindow.py", line 242, in loadMenu
    iters[depth] = self.menu_store.append(None, (icon, cgi.escape(parent.get_name()), parent))
AttributeError: 'NoneType' object has no attribute 'get_name'
caltrop@dragon ~ $ 

Re: Linux Mint Mate Menu Issues

Posted: Fri Jun 15, 2018 12:46 pm
by all41
Try
In a terrminal:

Code: Select all

mintmenu --reset

Re: Linux Mint Mate Menu Issues

Posted: Fri Jun 15, 2018 2:16 pm
by Spearmint2
Was it OK when first installed, or was like this? Did you check the hash on the downloaded ISO to insure it was OK?