[SOLVED] Most of applications won't start

Forum rules
Before you post please read how to get help
Post Reply
zemunelo
Level 1
Level 1
Posts: 5
Joined: Sun Aug 20, 2017 12:42 pm

[SOLVED] Most of applications won't start

Post by zemunelo » Sun Jun 24, 2018 6:28 pm

It was working for a year very well.
I don't know exactly what OS I have.
I know it is Linux Mint Mate, but don't know what version. Because I can't even start welcome screen.
I can't start text editor (I installed pluma and pluma is working now) or any of browsers. Most of the applications will not start when I click on icon or type start command in terminal. Yes, terminal is working.
Disks, Synaptic, Update manager not working...Sensor monitor is working only as icon in panel but not if I try to start it.
Image Viewer can't show the image but Gimp is working. Also Wine is working with its notepad.

So OS is mostly dead. I installed it before a year and the version was latest LTS available at the time.

I suspect on HDD.
However S.M.A.R.T system shows self test passed, but some error 283 occurred at power-on lifetime 3938 hours blabla...
and it says about error I can't copy the whole table obviously because I am writing from another computer.
Something like: Error: UNC 128 sectors at LBA = 0x00038607 = 230919.

Anyway, it is dual boot with W$ 7 that is working ok (I really can't use that OS, I am on linux from 2008 till now). But Mint is not working as I said.
Any advice?
Last edited by zemunelo on Thu Jun 28, 2018 5:01 am, edited 1 time in total.

gm10
Level 11
Level 11
Posts: 3547
Joined: Thu Jun 21, 2018 5:11 pm

Re: Most of applications won't start

Post by gm10 » Mon Jun 25, 2018 5:03 am

UNC = uncorrectable errors = your disk is failing, time to backup your data (make sure it's not already bad) and run (i.e. get a new disk).

zemunelo
Level 1
Level 1
Posts: 5
Joined: Sun Aug 20, 2017 12:42 pm

Re: Most of applications won't start

Post by zemunelo » Mon Jun 25, 2018 5:20 am

Hm, badblocks command says no bad blocks, no errors. Oh well :(

gm10
Level 11
Level 11
Posts: 3547
Joined: Thu Jun 21, 2018 5:11 pm

Re: Most of applications won't start

Post by gm10 » Mon Jun 25, 2018 6:05 am

It's not necessarily about bad blocks, but if a SMART self-test fails with unrecoverable errors then something is wrong for sure - SMART self-tests don't rely on any drivers/operating systems, they are handled by the drive's firmware itself so their results are pretty reliable.

You can boot the system from a live USB/DVD and run a full disk check/repair from there, see what happens.

User avatar
MrEen
Level 6
Level 6
Posts: 1497
Joined: Mon Jun 12, 2017 8:39 pm

Re: Most of applications won't start

Post by MrEen » Mon Jun 25, 2018 5:05 pm

Hi zemunelo, and welcome to the forum.

There was an issue a few months ago that caused some of the symptoms you seem to be having. Just in case this is what's affecting your computer the "cure" was to remove the virtualbox-guest packages. In the terminal, type apt remove virtualbox-guest* I can't remember if you needed to reboot after so let's just assume you do.

Good luck.

zemunelo
Level 1
Level 1
Posts: 5
Joined: Sun Aug 20, 2017 12:42 pm

Re: Most of applications won't start

Post by zemunelo » Mon Jun 25, 2018 7:10 pm

Oh My Mint!
Thank you so much!
I was looking for a fix so long and before 2-3 months I decided to stop using the laptop and this Mint system.
It is working like a charm now. Btw it is Mint Mate 18 "Sarah", 64 bit.
And yes you need to reboot but after that all the systems are ready and operational :D

I am curious, I don't even remember that I installed virtualbox-guest packages. Is it preinstalled or I did it. Probably I did it to try something. But after a problem occurred I tried update && upgrade in terminal and the problems were still there. So I assume virtualbox packages would still make the problems on this hardware/system?

Did I say thank you :wink:

gm10
Level 11
Level 11
Posts: 3547
Joined: Thu Jun 21, 2018 5:11 pm

Re: Most of applications won't start

Post by gm10 » Mon Jun 25, 2018 7:19 pm

Interesting, didn't know about that one. And no, I don't think those are pre-installed, at least I don't have them and I don't remember uninstalling them.

I'd still watch the smart status of that disk carefully though since I don't see how the virtualbox driver could have influenced a smart self-test.

User avatar
MrEen
Level 6
Level 6
Posts: 1497
Joined: Mon Jun 12, 2017 8:39 pm

Re: Most of applications won't start

Post by MrEen » Mon Jun 25, 2018 7:46 pm

Glad you're fixed, zemunelo!

The vb-guest* stuff was preinstalled until 18.3, I believe. Of course, upgrading from 18.2 to 18.3 doesn't remove it. This is a good moment to stress the importance of using the Update Manager instead of apt-get upgrade. The Update Manager had a fix added within a couple days for this (applied by updating the UM itself.)

Those packages are only needed when Mint is running inside VB, and the packages can be safely added inside the running VB instead (if I remember correctly.)

zemunelo
Level 1
Level 1
Posts: 5
Joined: Sun Aug 20, 2017 12:42 pm

Re: Most of applications won't start

Post by zemunelo » Mon Jun 25, 2018 8:17 pm

Well I couldn't use the Update Manager because I already had the problem and one among many apps that was not working was UM itself. However just to mention that I was using the system regularly for about a year or more. It seems the problem occurred probably after some update.
How to change the name of topic as SOLVED?
Maybe we can help another poor soul :)
(Or the admin can do it only?)

User avatar
catweazel
Level 17
Level 17
Posts: 7566
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: Most of applications won't start

Post by catweazel » Mon Jun 25, 2018 8:20 pm

zemunelo wrote:
Mon Jun 25, 2018 7:10 pm
It is working like a charm now.
Don't discount the idea that your HDD might be on its last legs.
¡uʍop ǝpısdn sı buıɥʇʎɹǝʌǝ os ɐıןɐɹʇsnɐ ɯoɹɟ ɯ,ı

zemunelo
Level 1
Level 1
Posts: 5
Joined: Sun Aug 20, 2017 12:42 pm

Re: Most of applications won't start

Post by zemunelo » Mon Jun 25, 2018 8:26 pm

catweazel wrote:
Mon Jun 25, 2018 8:20 pm
zemunelo wrote:
Mon Jun 25, 2018 7:10 pm
It is working like a charm now.
Don't discount the idea that your HDD might be on its last legs.
I know that but all the important data is already backed up because of the problem that was before. I was forced to do it so I will use the system only for fun (browsing, movies, music...etc, well maybe I can play Eve online just to prove that I can do it on Linux on laptop :wink: ).

Post Reply

Return to “MATE”