Of the 3 menus offered, the 2 MATE menus fail

Forum rules
Before you post please read how to get help
Post Reply
AlbertWagner
Level 1
Level 1
Posts: 9
Joined: Fri Dec 29, 2017 12:56 am

Of the 3 menus offered, the 2 MATE menus fail

Post by AlbertWagner » Wed Aug 29, 2018 11:43 pm

When using either "Main Menu (The Main MATE menu)"
or "Menu Bar (A custom menu bar)"
and "Places" is selected, then
no matter which place you click on (Home, Desktop, Downloads, etc)
then Xplayer pops up and tries to play the sorted contents of that place, whatever that happens to be .pdf, .txt, .tar.gz, etc, etc.

The "mintMenu (Advanced Menu) circumvents this MATE bug by not having a "Places" option.

gm10
Level 13
Level 13
Posts: 4652
Joined: Thu Jun 21, 2018 5:11 pm

Re: Of the 3 menus offered, the 2 MATE menus fail

Post by gm10 » Thu Aug 30, 2018 3:41 am

1. The default menu has a "Places" option, too. It's even enabled by default. If you disabled it, you can enable it again by right clicking the menu button > Preferences.
2. Xplayer popping up is no bug, either, just another misconfiguration on your system (I take it you re-used an existing home folder?). Go Menu > Preferred Applications and make sure the file browser is set to Caja. If caja is no option, edit ~/.config/mimeapps.list in a text editor and either remove all inode/directory entries or make sure they look like this inode/directory=caja-folder-handler.desktop.

AlbertWagner
Level 1
Level 1
Posts: 9
Joined: Fri Dec 29, 2017 12:56 am

Re: Of the 3 menus offered, the 2 MATE menus fail

Post by AlbertWagner » Thu Aug 30, 2018 1:08 pm

Thank you for your reply. It's good to know that someone who understands MATE is on the forum.
However, in my view, a "misconfiguration", or installed code that misconfigures, on my system IS a bug.

1. I did not disable any "Places" option. There are 3 menus. Which are you calling the "default" menu? Do you mean the Linux Mint menu? Could you be more specific about what to do after clicking the menu button > Preferences?

2. I never "re-use" an existing home folder, whatever that means. In "Preferred Applications", File Manager is set to "Open Folder with Thunar" as 1st option and Caja as second. I didn't directly change that option, although I did install Thunar, because Caja has a selectable option named "Open Folder with Thunar", plus I like some of Thunar's behaviour in preference to Caja.

Below is the file ~/.config/mimeapps.list.
How do I comment out a line? #? Or do I really have to remove the inode lines?
-----------------------------------
[Added Associations]
audio/mpeg=vlc.desktop;xplayer.desktop;
text/plain=xed.desktop;
inode/directory=caja-folder-handler.desktop;Thunar-folder-handler.desktop;

[Default Applications]
inode/directory=caja-folder-handler.desktop
x-scheme-handler/http=firefox.desktop
x-scheme-handler/https=firefox.desktop
text/html=firefox.desktop
x-scheme-handler/about=firefox.desktop
x-scheme-handler/mailto=thunderbird.desktop
application/x-extension-eml=thunderbird.desktop
message/rfc822=thunderbird.desktop
text/plain=xed.desktop
audio/mpeg=vlc.desktop
audio/x-mpegurl=vlc.desktop
audio/x-scpls=vlc.desktop
audio/x-vorbis+ogg=vlc.desktop
audio/x-wav=vlc.desktop
video/mp4=xplayer.desktop
video/mpeg=xplayer.desktop
video/mp2t=xplayer.desktop
video/msvideo=xplayer.desktop
video/quicktime=xplayer.desktop
video/webm=xplayer.desktop
video/x-avi=xplayer.desktop
video/x-flv=xplayer.desktop
video/x-matroska=xplayer.desktop
video/x-mpeg=xplayer.desktop
video/x-ogm+ogg=xplayer.desktop
image/bmp=xviewer.desktop
image/gif=xviewer.desktop
image/jpeg=xviewer.desktop
image/png=xviewer.desktop
image/tiff=xviewer.desktop
application/pdf=xreader.desktop
application/vnd.oasis.opendocument.text=libreoffice-writer.desktop
application/msword=libreoffice-writer.desktop
application/vnd.openxmlformats-officedocument.wordprocessingml.document=libreoffice-writer.desktop
application/vnd.oasis.opendocument.spreadsheet=libreoffice-calc.desktop
application/vnd.ms-excel=libreoffice-calc.desktop
application/vnd.openxmlformats-officedocument.spreadsheetml.sheet=libreoffice-calc.desktop
---------------------------------------------------------

I'm guessing that the bug is related to the inappropriate handling of the installation of Thunar.

There is also another problem with the LinuxMint menu: It truncates items in the 2nd and 3rd columns because it cannot adjust to a larger font being chosen.

Thanks again for your help.

gm10
Level 13
Level 13
Posts: 4652
Joined: Thu Jun 21, 2018 5:11 pm

Re: Of the 3 menus offered, the 2 MATE menus fail

Post by gm10 » Thu Aug 30, 2018 1:24 pm

AlbertWagner wrote:
Thu Aug 30, 2018 1:08 pm
1. I did not disable any "Places" option. There are 3 menus. Which are you calling the "default" menu? Do you mean the Linux Mint menu? Could you be more specific about what to do after clicking the menu button > Preferences?
Default is the menu you got in an unmodified installation, basically what the live USB looks like. So yes, the one with the Mint logo. Preferences look like this, the Places plugin is enabled by default but maybe you unchecked it accidentally:
Screenshot at 2018-08-30 19-10-39.png
Screenshot at 2018-08-30 19-10-39.png (7.94 KiB) Viewed 219 times
AlbertWagner wrote:
Thu Aug 30, 2018 1:08 pm
2. I never "re-use" an existing home folder, whatever that means. In "Preferred Applications", File Manager is set to "Open Folder with Thunar" as 1st option and Caja as second. I didn't directly change that option, although I did install Thunar, because Caja has a selectable option named "Open Folder with Thunar", plus I like some of Thunar's behaviour in preference to Caja.
That looks good, I see nothing in that file that would associate folders with xplayer. seems to be correctly set to caja now. Log out and back in and that should work. It should also be possible to use Thunar but I don't have that installed so can't test.
AlbertWagner wrote:
Thu Aug 30, 2018 1:08 pm
There is also another problem with the LinuxMint menu: It truncates items in the 2nd and 3rd columns because it cannot adjust to a larger font being chosen.
The menu has a fixed width. You can make it wider like this (paste into a terminal window, adjust the number to the width you want, default is 480):

Code: Select all

dconf write /com/linuxmint/mintmenu/plugins/applications/width 800
You can also adjust the height (switch width with height in that command).

AlbertWagner
Level 1
Level 1
Posts: 9
Joined: Fri Dec 29, 2017 12:56 am

Re: Of the 3 menus offered, the 2 MATE menus fail

Post by AlbertWagner » Thu Aug 30, 2018 11:21 pm

@GM10
Thank you very much.
I'm slow on the uptake, but I work hard at it.
Everything is working well now.

Post Reply

Return to “MATE”