Page 1 of 1

[SOLVED] Updating to 18.3

Posted: Fri Sep 14, 2018 2:55 pm
by GiuTor
Hello guys,

I want to update to 18.3 by I'm prompted to install mint-meta-cinnamon metapackage. I went to install it and it brings with him a bunch of dependancies which I DO NOT want to install as I use Mate. Why this mandatory step? Any other way to udate to 18.3 without installing cinnamon which I don't need?

Thanks
Giutor

Re: Updating to 18.3

Posted: Fri Sep 14, 2018 7:11 pm
by AZgl1500
a fresh install of 18.3 Mate will avoid all of that

Re: Updating to 18.3

Posted: Sat Sep 15, 2018 3:03 am
by GiuTor
Yep I came to the same conclusion. Thanks.

Re: Updating to 18.3

Posted: Sat Sep 15, 2018 3:12 am
by smurphos
Sounds like your original install was Cinnamon and you've changed it to Mate at some point.

if so try apt remove mint-info-cinnamon && apt install mint-info-mate before retrying the upgrade.

Re: Updating to 18.3

Posted: Sat Sep 15, 2018 3:18 am
by GiuTor
Exactly mate! Cinnamon was really slow at start-up. Thank you so much. I will try your suggestion and let you know.

Re: Updating to 18.3

Posted: Sat Sep 15, 2018 4:25 am
by GiuTor
Everything works like a charm! Thank you guys!

Re: Updating to 18.3

Posted: Sat Sep 15, 2018 9:05 am
by AZgl1500
smurphos wrote:
Sat Sep 15, 2018 3:12 am
Sounds like your original install was Cinnamon and you've changed it to Mate at some point.

if so try apt remove mint-info-cinnamon && apt install mint-info-mate before retrying the upgrade.
@smurphos

do I understand correctly, that one can change the DE as easily as what you just posted, and not have to mess with doing a new install.... just to simply change the DE, ot the OS ??

Re: [SOLVED] Updating to 18.3

Posted: Sat Sep 15, 2018 9:13 am
by smurphos
Not quite as simple as that, but it is possible to change DEs without a fresh install, but you have to be confident that you know what you are doing.

These particular packages are just small config files from the original install that are used by the mint upgrade tools to identify which version it thinks it is dealing with. They have no inter-dependencies with other DE components so I guess are overlooked by most people installing one version and then manually switching to a different DE.