Issue with icon removal in mintMenu applet

Forum rules
Before you post please read how to get help
Post Reply
mp107
Level 1
Level 1
Posts: 4
Joined: Tue Aug 01, 2017 9:23 am

Issue with icon removal in mintMenu applet

Post by mp107 » Sun Sep 23, 2018 6:49 am

Hi,
I have installed Linux Mint 19 MATE several months ago and I came across some issue with mintMenu applet.

Steps to reproduce the problem:
1. Open mintMenu;
2. Select category;
3. Select an icon with right click mouse and choose "Delete from menu" (this option is not visible for Linux applications);
4. Shortly after that click on the previously chosen icon (one needs to manage click it before it disappears but it is possible as it takes around a second);
5. The whole mintMenu applet hangs.

I came across an issue during removal of a few icons created for Windows applications by Wine.
I accidentally clicked on an icon before it has been removed from the menu.

Notebook: Lenovo X230
OS: Linux Mint 19 MATE 64-bit
mintMenu applet version: 5.9.0

I will provide logs but I am not sure where to look for those related with an issue.
Last edited by mp107 on Tue Sep 25, 2018 7:40 am, edited 1 time in total.

gm10
Level 10
Level 10
Posts: 3456
Joined: Thu Jun 21, 2018 5:11 pm

Re: Issue with icon removal in mintMenu applet

Post by gm10 » Sun Sep 23, 2018 7:31 am

Can't reproduce that hang, deleted links would still get launched without a problem. Might be specific to the application you had linked, or maybe it depends on the exact timing when you click. Bug reports would have to go here: https://github.com/linuxmint/mintmenu/issues

mp107
Level 1
Level 1
Posts: 4
Joined: Tue Aug 01, 2017 9:23 am

Re: Issue with icon removal in mintMenu applet

Post by mp107 » Tue Sep 25, 2018 7:40 am

Thank you for the interest and the answer.

In the meantime I have captured a log (placed in syslogs): https://gist.github.com/mp107/6350a2f96 ... f07ca66dd7.

The icon I have created before using this script: https://gist.github.com/mp107/bb301b06a ... ebc49fe3a1.

Furthermore, as an effect of this issue it appeared some kind of trace after the context menu showed on the image below.
https://obrazki.elektroda.pl/7276687700_1537728081.png
It disappeared after force restarting mate-panel using:
killall -9 mate-panel

EDIT: I have created related bug report here - https://github.com/linuxmint/mintmenu/issues/197.

Post Reply

Return to “MATE”