[SOLVED] switched to Compiz and now the screen is all white

Forum rules
Before you post please read how to get help
Post Reply
User avatar
dentex
Level 1
Level 1
Posts: 37
Joined: Thu Sep 23, 2010 3:45 am
Location: Italy
Contact:

[SOLVED] switched to Compiz and now the screen is all white

Post by dentex » Mon Oct 08, 2018 6:54 am

Hi!
I searched around with no results, so I'm posting here.
I have an old laptop with Linux Mint 18.3, Mate edition, just updated to the latest versions for all installed packages.

I switched to Compiz under the desktop settings UI, just to see if it was faster (it's the old pentium-IV that's slow... I know) and suddenly I got an all white screen. Rebooted, reinstalled all mate* and marco* packages, and also I reset the window manager with:

Code: Select all

gsettings set org.mate.session.required components windowmanager marco
...and I checked that actually this was set. Rebooted again... Nothing, again the white screen instead of the login page.

Any suggestion? Thanks
Last edited by dentex on Tue Oct 09, 2018 1:26 am, edited 1 time in total.

rickNS
Level 4
Level 4
Posts: 278
Joined: Tue Jan 25, 2011 11:59 pm

Re: switched to Compiz and now the screen is all white

Post by rickNS » Mon Oct 08, 2018 9:48 am

If you can get a terminal while on said white screen.

Code: Select all

marco --replace
Should restore the window manager.
You may want to wait for a second opinion, I'm NOT an expert.

I thought the default WM for Mate was metacity ?
Mint 18 mate on 2 identical Thinkpad T420's

User avatar
dentex
Level 1
Level 1
Posts: 37
Joined: Thu Sep 23, 2010 3:45 am
Location: Italy
Contact:

Re: switched to Compiz and now the screen is all white

Post by dentex » Mon Oct 08, 2018 10:12 am

rickNS wrote:
Mon Oct 08, 2018 9:48 am
If you can get a terminal while on said white screen.

Code: Select all

marco --replace
Should restore the window manager.
Unfortunately no way to get a terminal emulator. I tried all the recovering stuff after doing Ctrl+alt+F1.
I forgot to mention that I tried this command from there, but obviously doesn't work from a ttyX console. I'm not an expert too, but the command complains about not being able to connect to a graphical server o something.
I thought the default WM for Mate was metacity ?
Well Marco was selected actually. Tried metacity and worked OK. Gone to Compiz and... Boom!
Last edited by dentex on Mon Oct 08, 2018 10:13 am, edited 1 time in total.

gm10
Level 12
Level 12
Posts: 4145
Joined: Thu Jun 21, 2018 5:11 pm

Re: switched to Compiz and now the screen is all white

Post by gm10 » Mon Oct 08, 2018 10:13 am

rickNS wrote:
Mon Oct 08, 2018 9:48 am
I thought the default WM for Mate was metacity ?
Nope, Marco is the default. It's a fork of metacity though, that's probably what you remembered.

As to the actual issue, my guess is when (likely unnecessarily) reinstalling all the desktop environment, more was lost and not replaced. If not even the login screen is shown - which doesn't use the desktop environment, anyway - then the display manager and/or the greeter aren't working properly. I'd say start with a

Code: Select all

sudo dpkg-reconfigure lightdm
Maybe you'll need to reinstall lightdm and slick-greeter.

User avatar
dentex
Level 1
Level 1
Posts: 37
Joined: Thu Sep 23, 2010 3:45 am
Location: Italy
Contact:

Re: switched to Compiz and now the screen is all white

Post by dentex » Tue Oct 09, 2018 1:30 am

gm10 wrote:
Mon Oct 08, 2018 10:13 am
...If not even the login screen is shown - which doesn't use the desktop environment, anyway - then the display manager and/or the greeter aren't working properly...
Indeed... I've been lucky: one of the users actually had the auto login enabled. So the white screen was the desktop, not the login screen. So I blindly opened a terminal emulator (Ctrl+alt+t) and typed "marco --replace". Bingo! Desktop was back. Then I opened its settings and reset the wm to Marco.

Thanks everyone!

Bye

Post Reply

Return to “MATE”