DE is offset on external monitor.

Forum rules
Before you post please read how to get help
Post Reply
LinuxEnforcer
Level 1
Level 1
Posts: 3
Joined: Wed Nov 07, 2018 6:16 am

DE is offset on external monitor.

Post by LinuxEnforcer » Wed Nov 07, 2018 6:55 am

Hi.

I have a couple of laptops with hd4000-graphics and older. They are having problems handling resolutions grater than the laptops native resolution on external monitors in linux mint mate 19. Ubuntu 18.04 mate and other distros handles this just fine.
When I set a resolution higher than that of the laptop-screen native resolution on an external monitor, it will set the resolution correctly, but it will offset the DE from the screen and the mouse cursor. So I can move the cursor all around the display real estate, but about 1/3 is just black bars. The mouse does not follow the DE, but stays on the display. Furthermore, the mouse is offset vertically from the DE with the same distance as the lower black bar.

I have tried searching this problem, and found a few similar incidents of this in older versions of Mint as well.
https://unix.stackexchange.com/question ... nd-monitor
viewtopic.php?t=13406
https://unix.stackexchange.com/question ... arger-reso

On the picture you see how the cursor highlights the restore button, from a distance below.
Image

Hope you can shed some light on the problem, or point me to the right post. Can't seem to find the right words for a good search. Also, guess it is something I should report as a bug?

Thanks.

LinuxEnforcer
Level 1
Level 1
Posts: 3
Joined: Wed Nov 07, 2018 6:16 am

Re: DE is offset on external monitor.

Post by LinuxEnforcer » Wed Nov 07, 2018 11:41 am

So I kind of solved the problem, like I did on the other laptop with HD-graphics older than HD4000. The approach was to try random combinations of dual displays and loging in and out. This approach worked on the older laptop, but not the newer one, because I am using QWHD(2560x1440) on HDMI on this one. This resolution is not detected by default, I think it has do to with the older version of HDMI in my laptop, it is capable but I have to add it manually with xrandr(on all distros). Have seen it work with linux on HDMI on a newer laptop, out of the box.
For some reason, linux mint mate can't handle the resolution if it is not present in the login manager(lightdm). So I added it, following this tutorial:

http://www.gregfreeman.io/2012/fix-wron ... nt-ubuntu/

In my bash-script I only put the lines to set the output I want for now:

Code: Select all

xrandr --newmode "2560x1440" 220.812 2560 2608 2640 2720 1440 1443 1448 1478 -hsync -vsync
xrandr --addmode HDMI-1 2560x1440
xrandr --output HDMI-1 --mode 2560x1440
So I have the full resolution on the external monitor at login, and can now change it after login as well.

Can anyone figure out the problem here, why is this a problem in mint and not other distros?

User avatar
AndyMH
Level 5
Level 5
Posts: 845
Joined: Fri Mar 04, 2016 5:23 pm
Location: Wiltshire

Re: DE is offset on external monitor.

Post by AndyMH » Wed Nov 07, 2018 3:17 pm

Might be a red herring, but try an older kernel, say 4.4. Had a lot of problems with LM19 and my 2560x1080 monitor and found that any kernel after 4.5.7 would not correctly identify it. My post:
viewtopic.php?f=46&t=280143

My fix was similar to what you have done.
Homebrew i5-8400+GTX1080 Cinnamon 19, Thinkpad T430 i7-3632 Cinnamon 19, Thinkpad T420 Cinnamon 18.3, Thinkpad T410 Cinnamon 17.3, Thinkpad T60 19.0 Mate

LinuxEnforcer
Level 1
Level 1
Posts: 3
Joined: Wed Nov 07, 2018 6:16 am

Re: DE is offset on external monitor.

Post by LinuxEnforcer » Thu Nov 08, 2018 3:08 am

Thx AndyMH.

I checked the kernels, ubuntu mate and mint mate runs the same kernel if I am not mistaken. It is only mint that is showing these difficulties, running Solus it was no problem, can't remember the kernel but I was running the one they called current, so I expect it to be on par or newer. And as mentioned in my second post, I have it working now, by running the script setting my resolution, through lightdm.conf. I don't know why, but the additional resolutions has to be available to the login manager, for me to also be able to set them in my DE on mint. In other distros, I can just run the the script adding my new resolutions, via the user sessions applications startup.
I don't know if you looked at my picture, but going through your thread it did not seem like the same problem. But your problem kind of reminded of an other of mine, where I had to force QWHD(2560x1440) resolution on HDMI 1.2 I think it is. The modelines I landed on, was taken from an other thread, because the ones I checked with gtf command would not work, going up to 55/60 Hz, but the specified in the thread did work. So the system might be capable, but you have to tweak the output of gtf.

Wrote about it here:
https://getsol.us/forums/viewtopic.php? ... ion#p36766

If you still have your kernel lying around, you can try to run the command

Code: Select all

gtf/cvt 2560 1080 30
, and specify a low frequency after your desired resolution. I found that the output of gtf was reliable at lower frequency, up to 40 or 45Hz I think. If it works, you know that perhaps it can be done with that kernel, but you need some tweaking. And please let me now if you find some useful resources on tweaking the gtf/cvt -output.

And thx. for the nice expression ;-)
https://en.wikipedia.org/wiki/Red_herring

Post Reply

Return to “MATE”