how to get panel transparent in full

Forum rules
Before you post please read how to get help
Post Reply
rat in a cage
Level 1
Level 1
Posts: 8
Joined: Thu May 14, 2009 12:37 pm

how to get panel transparent in full

Post by rat in a cage »

when i adjust transparency in panel properties, panel is transparent, but right part of it, where the notification area & clock is, is not (see picture). how to get this part transparent as well? Also how to remove shadow from panel?
Is it possible to add mintMenu to gnome-do docky?

edit: ups, here's picture: http://i41.tinypic.com/68g3dl.png

User avatar
richyrich
Level 19
Level 19
Posts: 9063
Joined: Mon May 04, 2009 8:31 pm

Re: how to get panel transparent in full

Post by richyrich »

Hi,
You need to change to a Theme that can handle transparency! :D I use Clearlooks, which also allows you to customise colours, the Window border, etc, etc.

regards, Richard

rat in a cage
Level 1
Level 1
Posts: 8
Joined: Thu May 14, 2009 12:37 pm

Re: how to get panel transparent in full

Post by rat in a cage »

tnx :)
still other questions remain unanswered :(

clhodapp
Level 3
Level 3
Posts: 124
Joined: Wed Feb 04, 2009 3:57 am
Location: Tuscaloosa, AL
Contact:

Re: how to get panel transparent in full

Post by clhodapp »

First, you can make your entire panel transparent with whatever theme you want by using Compiz. Open Compiz Settings Manager (NOT Simple Compiz Settings Manager) and enable the plugin for "Opacity, Brightness, and Saturation". You can them place your mouse over the panel, hold alt, and roll your mouse wheel to adjust transparency (this does depend upon being able to enable desktop effects).

Second, mintMenu cannot appear on Gnome-Do's Docky interface, because it is a gnome-panel applet (unless someone has a way to put panel applets into Docky).

I'm still working on figuring out the shadow.

clhodapp
Level 3
Level 3
Posts: 124
Joined: Wed Feb 04, 2009 3:57 am
Location: Tuscaloosa, AL
Contact:

Re: how to get panel transparent in full

Post by clhodapp »

Ok the shadow is also added by Compiz. Go back in to CompizConfig Settings Manager and open the properties for the "Window Decorations" plugin. change the text in the "Shadow Windows" category to be "(any) & !(class=Gnome-panel)", rather than "any". I do have an idea on your mintMenu issue. You could create a gnome-panel with just mintmenu on it and then uncheck "expand" in its properties. You can move the resulting panel around the screen to where you want it.

clhodapp
Level 3
Level 3
Posts: 124
Joined: Wed Feb 04, 2009 3:57 am
Location: Tuscaloosa, AL
Contact:

Re: how to get panel transparent in full

Post by clhodapp »

Ok. There are some problems with that way of changing the opacity. First, it doesn't give very granular control of the opacity level. Second, I don't think it will stay across a system restart. This can easily be fixed. Just make a rule in Compiz. Open up CompizConfig Settings Manger again, and click on that Opacity, Brightness, and Saturation you just enabled. Under "Window-Specific Settings" say "New". Hit the little plus button at the end of the first line. Hit grab. Click your panel. Say add, adjust, the slider, close, and voilà.

User avatar
dlkreations
Level 5
Level 5
Posts: 781
Joined: Mon Jan 12, 2009 8:40 pm
Location: Orange County, California
Contact:

Re: how to get panel transparent in full

Post by dlkreations »

This is how I set mine:
Screenshot-CompizConfig Settings Manager.png
Screenshot-CompizConfig Settings Manager.png (14.44 KiB) Viewed 2725 times
It will give you all the transparency you need.
Image
It's perfectly OK to express an opinion, but refrain from foul and stupid language
- Husse

Morgen
Level 1
Level 1
Posts: 10
Joined: Wed Sep 16, 2009 1:40 pm

Re: how to get panel transparent in full

Post by Morgen »

I do not think that the solutions provided to this so far really address the issue. You need to edit the panel.rc file found in /usr/share/themes/shiki-wise, replace shiki-wise if you are not using the default theme. Find and comment out (insert a # sign in front of) the line that reads: bg_pixmap[NORMAL] = "panel_bg_dark.png". You will have to do this as administrator.

This information is based on the following tutorial and modified for linux mint specifically:

http://www.webupd8.org/2010/05/fix-tran ... large.html

Hope this helps,

Morgen

Post Reply

Return to “MATE”