[SOLVED]python3 app doesn't autostart in mate

Forum rules
Before you post please read how to get help
Post Reply
dancer_69
Level 1
Level 1
Posts: 30
Joined: Thu May 19, 2011 1:25 pm

[SOLVED]python3 app doesn't autostart in mate

Post by dancer_69 » Wed Mar 20, 2019 3:38 am

I've created a python3 application which I use for a long time without problems. I already created an autostart entry which run without problems in cinnamon and also in xfce, plasma which I have tested before, in arch linux. I just installed mate yesterday, and even there is an entry for this application in autostart applications, it doesn't start when I login to mate desktop. I tried different things:
-use a script:

Code: Select all

#!/bin/bash
python3 /home/user/pysnoozeshutdown/main.py
-add a delay:

Code: Select all

#!/bin/bash
sleep 20
python3 /home/user/pysnoozeshutdown/main.py
-specify python3 path:

Code: Select all

#!/bin/bash
sleep 20
/usr/bin/python3 /home/user/pysnoozeshutdown/main.py
-add the command directly without script:

Code: Select all

/usr/bin/python3 /home/user/pysnoozeshutdown/main.py
Both the script execution and the direct command from terminal work fine and the application runs.
I alse have check the autostart folder in .config and the .desktop file is there and its contents change when I change something from autostart applications setting.
Is there something special that mate needs? Because there is no problem in cinnamon, plasma, xfce desktop environments.
Last edited by dancer_69 on Thu Mar 21, 2019 5:55 am, edited 1 time in total.

dancer_69
Level 1
Level 1
Posts: 30
Joined: Thu May 19, 2011 1:25 pm

Re: python3 app doesn't autostart in mate

Post by dancer_69 » Wed Mar 20, 2019 4:00 am

Again, I found the problem minutes after created the thread :oops:
I opended the .desktop file and there wasn't an entry for Name and Description, but only Name[el] and Description[el](my native language translated entries). I didn't think that this was a problem because as I wrote above this file worked on cinnamon(which originaly created).
I checked the .xsession-errors file and I found an error parsing this .desktop file. So I remove the [el] from Name and then the application autostarted without problem.

Post Reply

Return to “MATE”