[Solved]Preventing mintMenu from going under an open full-screen window when invoked with "Super"

Forum rules
Before you post please read how to get help
Post Reply
ColdBootII
Level 4
Level 4
Posts: 284
Joined: Wed Aug 02, 2017 8:19 am

[Solved]Preventing mintMenu from going under an open full-screen window when invoked with "Super"

Post by ColdBootII » Mon Jun 03, 2019 12:44 pm

I have noticed that if some window is opened in full screen and if Compiz is the WM, mintMenu widget goes under that window when Super key is pressed. Clicking on it works Ok but I wonder if there's something in Compiz setting that can be tweaked to fix this "Super" key behaviour?
Last edited by ColdBootII on Mon Jun 03, 2019 5:49 pm, edited 1 time in total.

gm10
Level 17
Level 17
Posts: 7403
Joined: Thu Jun 21, 2018 5:11 pm

Re: Preventing mintMenu from going under an open full-screen window when invoked with "Super"

Post by gm10 » Mon Jun 03, 2019 1:35 pm

Doesn't happen for me, but I'm using different software versions than you (whatever yours may be though). That said, are you sure you didn't simply toggle always-on-top on the fullscreen window? Because then it happens with the official version of mintMenu (it's fixed in my version but that only works with MATE 1.22 or higher).
Tune up your LM 19.x: ppa:gm10/linuxmint-tools

ColdBootII
Level 4
Level 4
Posts: 284
Joined: Wed Aug 02, 2017 8:19 am

Re: Preventing mintMenu from going under an open full-screen window when invoked with "Super"

Post by ColdBootII » Mon Jun 03, 2019 4:18 pm

No, Always on Top feature is disabled, I've checked.

In fact, I've just tried with Caja opened not in full screen, and if it has the focus, the menu is also displayed under it.

Image

Mate 1.20 here.

gm10
Level 17
Level 17
Posts: 7403
Joined: Thu Jun 21, 2018 5:11 pm

Re: Preventing mintMenu from going under an open full-screen window when invoked with "Super"

Post by gm10 » Mon Jun 03, 2019 4:33 pm

Hmm, check your focus prevention rules in the general options I suppose.

Just for reference, I just tried in a LM 19.1 live environment with default compiz settings and it's working correctly there, so in case of doubt just reset your settings to defaults and take it from there:
VirtualBox_Live USB_03_06_2019_22_30_29.jpg
Tune up your LM 19.x: ppa:gm10/linuxmint-tools

ColdBootII
Level 4
Level 4
Posts: 284
Joined: Wed Aug 02, 2017 8:19 am

Re: Preventing mintMenu from going under an open full-screen window when invoked with "Super"

Post by ColdBootII » Mon Jun 03, 2019 5:00 pm

Reseting Comiz settings didn't help. Nothing unusual about focus, I guess, only mintMenu won't show up on top via keyboard press.

Image

Right now I tried adding

Code: Select all

class=MintMenu.py
in Window Rules and that kind of fixed it. Kind of, because it still doesn't have the focus when it appears.

gm10
Level 17
Level 17
Posts: 7403
Joined: Thu Jun 21, 2018 5:11 pm

Re: Preventing mintMenu from going under an open full-screen window when invoked with "Super"

Post by gm10 » Mon Jun 03, 2019 5:07 pm

It's weird it wouldn't work for you when it does work in the live environment. Have you tried logging out and back in after resetting the settings?

Otherwise once you get MATE 1.22 feel free to try my version of the menu, I'd expect it to work correctly even though I'm not sure what's wrong in your case.
Tune up your LM 19.x: ppa:gm10/linuxmint-tools

ColdBootII
Level 4
Level 4
Posts: 284
Joined: Wed Aug 02, 2017 8:19 am

Re: Preventing mintMenu from going under an open full-screen window when invoked with "Super"

Post by ColdBootII » Mon Jun 03, 2019 5:26 pm

Yes, but no luck. When WM is switched to Marco, this is not an issue.

May I ask, will you make it available for Mint 19.1 also? I'd rather not switch to 19.2 when it comes out, since everything else is flawless.

gm10
Level 17
Level 17
Posts: 7403
Joined: Thu Jun 21, 2018 5:11 pm

Re: Preventing mintMenu from going under an open full-screen window when invoked with "Super"

Post by gm10 » Mon Jun 03, 2019 5:32 pm

ColdBootII wrote:
Mon Jun 03, 2019 5:26 pm
May I ask, will you make it available for Mint 19.1 also?
No, sorry, I won't. I don't want to maintain two incompatible versions of it when I'm only using one of them, I'm sure you understand.

Regarding your issue, I was thinking in the Compiz General Options, wouldn't registering the menu in the Focus Prevention Windows field fix your focus issue?
Tune up your LM 19.x: ppa:gm10/linuxmint-tools

ColdBootII
Level 4
Level 4
Posts: 284
Joined: Wed Aug 02, 2017 8:19 am

Re: Preventing mintMenu from going under an open full-screen window when invoked with "Super"

Post by ColdBootII » Mon Jun 03, 2019 5:49 pm

gm10 wrote:
Mon Jun 03, 2019 5:32 pm
ColdBootII wrote:
Mon Jun 03, 2019 5:26 pm
May I ask, will you make it available for Mint 19.1 also?
No, sorry, I won't. I don't want to maintain two incompatible versions of it when I'm only using one of them, I'm sure you understand.

Regarding your issue, I was thinking in the Compiz General Options, wouldn't registering the menu in the Focus Prevention Windows field fix your focus issue?
Pity but Ok since registering the menu in Focus Prevention solved it! Thank you very much! :D

Post Reply

Return to “MATE”