Window Borders/Controls Missing After Updating

Forum rules
Before you post please read how to get help
Post Reply
lehnerus2000
Level 1
Level 1
Posts: 27
Joined: Sun May 18, 2014 11:07 pm
Location: Australia

Window Borders/Controls Missing After Updating

Post by lehnerus2000 » Fri Jun 14, 2019 9:34 am

My SSD died.
SSDs are so unreliable, I haven't had one last 3 years in my main PC (this one was <2 years old).

I'm dual booting Windows 7 & LM19.1 MATE (both 64 bit).
I re-imaged the new SSD with my backup image, however whilst W7 worked LM19.1 was broken.
I couldn't use the Advanced Recovery Options as a message would appear and overwrite the options so nothing could be selected from the list.

I was forced to reinstall LM19.1 MATE (64 bit).

After the install was complete, I ran the "Update Manager".
When I rebooted my PC, the GRUB menu showed "Ubuntu" instead of "Linux Mint" in the boot options.

After I logged in I discovered that all of my windows had lost their borders/controls! :shock:
When I went to the Control Centre and clicked on the "Windows" option in the "Look & Feel" section, I got a message stating "Unsupported Window Manager".

I'm using the default graphic driver (not the NVidia driver).

I used the "Timeshift" tool to restore my install, and after rebooting the window borders/controls returned (as expected).

Now I am reluctant to run the Update Manager again in case the problem recurs.
Which packages should I disable in the Update Manger to prevent this from happening again? :?
PJL
"If your plan was any more 'perfect', you'd be dead!"

pablok
Level 1
Level 1
Posts: 15
Joined: Tue Dec 23, 2014 4:43 pm

Re: Window Borders/Controls Missing After Updating

Post by pablok » Wed Jun 19, 2019 11:24 am

Same here. Especially the
After I logged in I discovered that all of my windows had lost their borders/controls! :shock:
When I went to the Control Centre and clicked on the "Windows" option in the "Look & Feel" section, I got a message stating "Unsupported Window Manager".
makes me wonder.

lehnerus2000
Level 1
Level 1
Posts: 27
Joined: Sun May 18, 2014 11:07 pm
Location: Australia

Re: Window Borders/Controls Missing After Updating

Post by lehnerus2000 » Fri Jun 21, 2019 6:24 am

The Updater is totally broken.

I just reinstalled LM 19.1 MATE.
It still is unable to perform any updates successfully.

The output is gibberish, but it seems to fail on initramfs.

Useless webkit also fails.
Screenshot at 2019-06-21 19-43-09.png
PJL
"If your plan was any more 'perfect', you'd be dead!"

Post Reply

Return to “MATE”