Gnome Keyboard Shortcuts Don't All Work

Forum rules
Before you post please read how to get help
Post Reply
csiebester
Level 1
Level 1
Posts: 9
Joined: Fri Apr 03, 2009 1:18 pm

Gnome Keyboard Shortcuts Don't All Work

Post by csiebester »

I believe this issue is caused by compiz, so to try to solve it I went to the compiz settings manger and enabled gnome compatibility, but the shortcuts still don't work. Anyone have a solution?
Thanks

User avatar
lagagnon
Level 7
Level 7
Posts: 1879
Joined: Wed Jun 17, 2009 7:38 pm
Location: an island in the Pacific...

Re: Gnome Keyboard Shortcuts Don't All Work

Post by lagagnon »

With Compiz running you use Compiz settings to do the keyboard shortcuts: Menu, Control Center, Look & Feel, Compiz Settings Manager, General, Commands

csiebester
Level 1
Level 1
Posts: 9
Joined: Fri Apr 03, 2009 1:18 pm

Re: Gnome Keyboard Shortcuts Don't All Work

Post by csiebester »

Yea I tried that too. I am fairly new and don't know all the commands needed to make that work. The one I tried was lock which i think should be: gnome-screensaver-command --lock, but it doesn't work.

A better solution would be to make compiz allow gnome to run the keyboard commands.

If no one knows how to do that though the shortcuts I really want to get running are lock and mute.

User avatar
lagagnon
Level 7
Level 7
Posts: 1879
Joined: Wed Jun 17, 2009 7:38 pm
Location: an island in the Pacific...

Re: Gnome Keyboard Shortcuts Don't All Work

Post by lagagnon »

I believe that Ctrl-Alt-L is already set up for you to lock.

csiebester
Level 1
Level 1
Posts: 9
Joined: Fri Apr 03, 2009 1:18 pm

Re: Gnome Keyboard Shortcuts Don't All Work

Post by csiebester »

Tried it. It doesn't work. That's my problem.

Felfire90
Level 1
Level 1
Posts: 1
Joined: Thu Jul 30, 2009 5:40 am

Re: Gnome Keyboard Shortcuts Don't All Work

Post by Felfire90 »

Hi,

I am unsure if this is the same problem as I have, basically I have a very recent install of 'Gloria' and I have noticed that ALT-TAB does not work, similarly ALT-(Right arrow) does not change desktop as I expected it to, Super-TAB similarly does nothing.
I have not made any Compiz settings, if Compiz is being used then it will be based on defaults.
Video is Intel (built-in), I am aware of reported issues with the Intel video driver but I do not think this is related.

If you have these problems then I will monitor here for a solution.

Thanks.

User avatar
lagagnon
Level 7
Level 7
Posts: 1879
Joined: Wed Jun 17, 2009 7:38 pm
Location: an island in the Pacific...

Re: Gnome Keyboard Shortcuts Don't All Work

Post by lagagnon »

Felfire90 & csiebester:

go to Menu, Control Center, Look & Feel, Compiz Settings Manager, General, Commands. Make sure that there is a check in the box beside "Commands".

csiebester
Level 1
Level 1
Posts: 9
Joined: Fri Apr 03, 2009 1:18 pm

Re: Gnome Keyboard Shortcuts Don't All Work

Post by csiebester »

My Commands icon is already checked in compiz settings manager, as is gnome compatibility.

Felfire90:
alt-tab does work on mine; to switch desktop I use ctrl-alt-arrow and that works for me though I may have changed that setting. That can be changed in control center- keyboard shortcuts; I don't know what you mean by super tab.

uilenspiegel
Level 1
Level 1
Posts: 26
Joined: Tue Aug 04, 2009 8:23 pm

Re: Gnome Keyboard Shortcuts Don't All Work

Post by uilenspiegel »

I've only been using Mint (Gloria, Main) for a few days, and all of a sudden noticed that ALT-tab, which worked fine for the first couple of days, was no longer working. CTRL-ALT-L was working, CTRL-ALT-arrows were working. I had compiz running since install and had played around with it just a very little; apparently it was that playing around that somehow made me lose ALT-TAB. I found that changing

mintMenu > Preferences > Simple CompizConfig Settings Manager > Effects tab > Switcher

back to (what I believe was the original) Static Application Switcher restored ALT-TAB, and also left the other shortcuts (CTRL-ALT-L etc) still working.

Curiously, I found this thread in the ubuntu forum that suggests just the opposite, that Static Application Switcher causes ALT-TAB *not* to function: http://ubuntuforums.org/showpost.php?p= ... ostcount=2

but in any event it appears that looking at your Switcher setting in the Simple CompizConfig Settings Manager might pay off.

csiebester
Level 1
Level 1
Posts: 9
Joined: Fri Apr 03, 2009 1:18 pm

Re: Gnome Keyboard Shortcuts Don't All Work

Post by csiebester »

uilenspiegel wrote:I've only been using Mint (Gloria, Main) for a few days, and all of a sudden noticed that ALT-tab, which worked fine for the first couple of days, was no longer working. CTRL-ALT-L was working, CTRL-ALT-arrows were working. I had compiz running since install and had played around with it just a very little; apparently it was that playing around that somehow made me lose ALT-TAB. I found that changing

mintMenu > Preferences > Simple CompizConfig Settings Manager > Effects tab > Switcher

back to (what I believe was the original) Static Application Switcher restored ALT-TAB, and also left the other shortcuts (CTRL-ALT-L etc) still working.

Curiously, I found this thread in the ubuntu forum that suggests just the opposite, that Static Application Switcher causes ALT-TAB *not* to function: http://ubuntuforums.org/showpost.php?p= ... ostcount=2

but in any event it appears that looking at your Switcher setting in the Simple CompizConfig Settings Manager might pay off.

My lat tab works with Static Application Switcher and Application switcher on but my other commands don't work. mine was already set to Static Application Switcher. I tried all the other options too to no avail. What are your other compiz settings uilenspiegel?

uilenspiegel
Level 1
Level 1
Posts: 26
Joined: Tue Aug 04, 2009 8:23 pm

Re: Gnome Keyboard Shortcuts Don't All Work

Post by uilenspiegel »

csiebester wrote: My lat tab works with Static Application Switcher and Application switcher on but my other commands don't work. mine was already set to Static Application Switcher. I tried all the other options too to no avail. What are your other compiz settings uilenspiegel?
Appearance Preferences --> Visual Effects tab --> "Custom"

Simple CompizConfigSettingsManager:

Animations tab: Enable animations selected, Open/Close/Minimize window all "Glide 2"
Effects tab: Switcher "Static Application Switcher", Additions checkboxes Enable Scale and Enable Expo checked
Desktop tab: Appearance "Desktop Wall"
Accessibility tab: Enable zoom checkbox Screen zoom checked

Pretty basic stuff, close to what you get out of the box. Try turning off fancy effects and see if you can get back to normal.

csiebester
Level 1
Level 1
Posts: 9
Joined: Fri Apr 03, 2009 1:18 pm

Re: Gnome Keyboard Shortcuts Don't All Work

Post by csiebester »

I haven't fiddled with the standard settings, except keyboard shortcuts and gnome compatibility.

Post Reply

Return to “MATE”