Disable notifications in MATE desktop

Forum rules
Before you post please read how to get help
Post Reply
yoburtu
Level 1
Level 1
Posts: 8
Joined: Wed Jan 08, 2014 5:13 am

Disable notifications in MATE desktop

Post by yoburtu »

Hi,

Does anyone know how to disable desktop notifications in MATE desktop?.

Best regards.
User avatar
ibbill
Level 4
Level 4
Posts: 316
Joined: Thu May 26, 2011 5:07 pm
Location: Canada

Re: Disable notifications in MATE desktop

Post by ibbill »

Bill and so it goes
Mint Mate 19 64 bit
HP xw4600-workstation
NVIDIA Corporation G84GL [Quadro FX 1700] (rev a1)
4gb ram Dual core
Canada
User avatar
Schultz
Level 8
Level 8
Posts: 2027
Joined: Thu Feb 25, 2016 8:57 pm

Re: Disable notifications in MATE desktop

Post by Schultz »

I think the OP is talking about popups from Mate, not a browser.

I searched but can't find a way to turn it off.
User avatar
roblm
Level 13
Level 13
Posts: 4511
Joined: Sun Feb 24, 2013 2:41 pm

Re: Disable notifications in MATE desktop

Post by roblm »

Use this command in the Terminal:
gsettings set org.mate.caja.preferences show-notifications false

To reverse: gsettings set org.mate.caja.preferences show-notifications true


Or if you prefer using a GUI, install dconf Editor: apt install dconf-editor

Open the program and go to /org/mate/caja/preferences and change the setting for show-notifications to OFF.
yoburtu
Level 1
Level 1
Posts: 8
Joined: Wed Jan 08, 2014 5:13 am

Re: Disable notifications in MATE desktop

Post by yoburtu »

Schultz wrote:
Mon Nov 25, 2019 11:49 am
I think the OP is talking about popups from Mate, not a browser.

I searched but can't find a way to turn it off.
Hi,

That’s right, they are the mate desktop notifications, not browsers.

Best regards.
yoburtu
Level 1
Level 1
Posts: 8
Joined: Wed Jan 08, 2014 5:13 am

Re: Disable notifications in MATE desktop

Post by yoburtu »

roblm wrote:
Mon Nov 25, 2019 12:41 pm
Use this command in the Terminal:
gsettings set org.mate.caja.preferences show-notifications false

To reverse: gsettings set org.mate.caja.preferences show-notifications true


Or if you prefer using a GUI, install dconf Editor: apt install dconf-editor

Open the program and go to /org/mate/caja/preferences and change the setting for show-notifications to OFF.
Ok, thanks. But, this setting is only for Caja or for all notifications?.

Regards.
gm10
Level 20
Level 20
Posts: 10999
Joined: Thu Jun 21, 2018 5:11 pm

Re: Disable notifications in MATE desktop

Post by gm10 »

yoburtu wrote:
Mon Nov 25, 2019 5:25 pm
Ok, thanks. But, this setting is only for Caja or for all notifications?.
Only for Caja. Disabling all desktop notifications is not easily possible in the MATE version distributed with Linux Mint. You could delete the notifications service:

Code: Select all

sudo rm -v /usr/share/dbus-1/services/org.freedesktop.mate.Notifications.service
but it will come back with updates to the package.

If you're running the latest MATE (i.e. not Mint's version) then you can disable them via the Popup Notifications tool in the menu:
Image
Maybe in Linux Mint 20. ;)
yoburtu
Level 1
Level 1
Posts: 8
Joined: Wed Jan 08, 2014 5:13 am

Re: Disable notifications in MATE desktop

Post by yoburtu »

gm10 wrote:
Mon Nov 25, 2019 5:48 pm
yoburtu wrote:
Mon Nov 25, 2019 5:25 pm
Ok, thanks. But, this setting is only for Caja or for all notifications?.
Only for Caja. Disabling all desktop notifications is not easily possible in the MATE version distributed with Linux Mint. You could delete the notifications service:

Code: Select all

sudo rm -v /usr/share/dbus-1/services/org.freedesktop.mate.Notifications.service
but it will come back with updates to the package.

If you're running the latest MATE (i.e. not Mint's version) then you can disable them via the Popup Notifications tool in the menu:
Image
Maybe in Linux Mint 20. ;)
Hi,

Thanks you. I use Arch Linux with Mate Desktop 1.22.2. I don’t have that option.

Best regards.
gm10
Level 20
Level 20
Posts: 10999
Joined: Thu Jun 21, 2018 5:11 pm

Re: Disable notifications in MATE desktop

Post by gm10 »

As I said, it's a recent addition, older MATE releases don't have it. Just remove the service as I suggested, should be in the same place on Arch.

And next time best ask in the Arch forums instead of the Linux Mint forums. ;)
yoburtu
Level 1
Level 1
Posts: 8
Joined: Wed Jan 08, 2014 5:13 am

Re: Disable notifications in MATE desktop

Post by yoburtu »

gm10 wrote:
Mon Nov 25, 2019 6:45 pm
As I said, it's a recent addition, older MATE releases don't have it. Just remove the service as I suggested, should be in the same place on Arch.

And next time best ask in the Arch forums instead of the Linux Mint forums. ;)
Yes!. I asked too but they still don’t answer, but I thought it was a common feature of any distro In MATE, hahaha!.

Thanks you.
trapperjohn
Level 5
Level 5
Posts: 849
Joined: Wed Jul 11, 2012 4:10 pm
Contact:

Re: Disable notifications in MATE desktop

Post by trapperjohn »

Yes!. I asked too but they still don’t answer
Well.... I gave it a try. :D

Trapperjohn (alias heroldman)

PS: I have several VMs running on Linux systems with the Mate DE at work. These machines auto-start the VMs at boot and run it full-screen so the habitual Win users are happy (in fact, they don't even know). The VMs are Win 10 machines that must have access to attached Dymo printers. Everything works but, at startup, a notification about a missing printer driver confuses the hapless users. Fortunately, after the VM fully starts, the notification goes away.
Post Reply

Return to “MATE”