blank screen

Forum rules
Before you post please read how to get help
Post Reply
c-m
Level 3
Level 3
Posts: 112
Joined: Mon Aug 24, 2009 2:01 pm

blank screen

Post by c-m »

On mint8 running gnome on an nvidia geforce 6200, i seem to have a problem where every 10mins of inactivity my screen will go blank as if i have a screensaver or power management set up.

This is a pain when watching movies or iplayer.

I have turned all power management off and set the screen saver not to come on for 2 hours, yet still every 10mins or so I end up with a blank screen until i move my cursor again.

Has anyone come across this before?

Husse
Level 23
Level 23
Posts: 18677
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: blank screen

Post by Husse »

Unusual to say the least, but I have seen a handful such reports, none for Helena though
Have you installed the restricted drivers?
Image
Don't fix it if it ain't broken, don't break it if you can't fix it

User avatar
mzsade
Level 5
Level 5
Posts: 777
Joined: Sun Jul 19, 2009 4:36 am

Re: blank screen

Post by mzsade »

Yep, happens in Helena too, i also have set 'Regard the computer as idle' to 2 hours, both actions in Power management to 'never', in addition the blank screen comes on after about 10 minutes even though i have chosen the Ants screensaver.

Edit: I have confirmed that other screensavers do not work either, so the blank screen that i am getting is not the default 'Blanck Screen' screensaver but just a blank screen.
Linux User #481272 Reg: 15th Sept., 2008

pvossen
Level 1
Level 1
Posts: 21
Joined: Mon Jul 02, 2007 10:53 pm

Re: blank screen

Post by pvossen »

Same issue with Helena. I didn't have such an issue in the previous
version though. Its not every ten minutes. It sometimes varies. I've
tried fsck to fix the problem, but nothing changes.

Patrick

User avatar
ipernar
Level 2
Level 2
Posts: 90
Joined: Fri Nov 20, 2009 1:08 pm
Location: Zagreb Croatia
Contact:

Re: blank screen

Post by ipernar »

That's a sweet problem! :D hehe
"Chicks come and go but you will always have your PS3. "

Husse
Level 23
Level 23
Posts: 18677
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: blank screen

Post by Husse »

The thing is that I've seen somewhat similar reports talking of every five minutes, but if that is every ten not five we have a likely cause here
Image
Don't fix it if it ain't broken, don't break it if you can't fix it

pvossen
Level 1
Level 1
Posts: 21
Joined: Mon Jul 02, 2007 10:53 pm

Re: blank screen

Post by pvossen »

Now instead of a blank screen I'm getting just an unresponsive desktop. Without
anything but the mouse working. I'm going to try the KDE side to see if its a
gnome issue on my next bootup. Same thing happening though just freezing up.
I will say last evening for the first time after I did another fsck it did work a few
hours before doing the same thing again. I had hoped possibly an update or
the fsck had fixed it. I tried another hard drive in my machine and installed Helena.
Same thing happened again after the updates were all received.

Patrick

Brian49
Level 5
Level 5
Posts: 611
Joined: Thu Oct 29, 2009 2:27 pm

Re: blank screen

Post by Brian49 »

Any further news about this issue, please? I have been getting it here since I first installed Helena (as I reported in another thread at the time). As far as I can see, the monitor is routinely being put to sleep after 10 minutes, even though I have disabled all relevant power-management settings. Many thanks.

Husse
Level 23
Level 23
Posts: 18677
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: blank screen

Post by Husse »

I am still trying to figure this out - so far no dice
Image
Don't fix it if it ain't broken, don't break it if you can't fix it

Husse
Level 23
Level 23
Posts: 18677
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: blank screen

Post by Husse »

I found this when I searched for a solution to another problem - it can't hurt to try it
I should probably explain that there is a pretty major issue with the clocksource Ubuntu is using, hpet. This particular clocksource was the cause of my system freezing every ten minutes or so.

----------------
Very short English summary in case **** hit the fans outside Finland. :-) If your Ubuntu 9.10 seems to get slower and slower over time, meaning everything from drawing windows to playing video gets laggy and only reboot helps, your computer might have issues with its HPET clock source and/or some peripherals interfere with it. This workaround might fix it for you: in /etc/default/grub change line

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

to be

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash clocksource=jiffies"

Then enter sudo update-grub and reboot. See if your problems are gone.

http://jaba.mbnet.fi/clocksourcejiffies ... miset-pois

---------------------------------------
Image
Don't fix it if it ain't broken, don't break it if you can't fix it

Brian49
Level 5
Level 5
Posts: 611
Joined: Thu Oct 29, 2009 2:27 pm

Re: blank screen

Post by Brian49 »

I'm afraid that makes no difference to the issue reported in this thread (it's not clear to me why it would). Also, it results in a worrying delay in getting to the desktop on system startup.

I'd be inclined to reason that my monitor must be putting itself to sleep due to some hidden setting in its onboard firmware (hidden, since there's no mention of it in the OSD config). But that leaves it a mystery why this only began happening in Helena - it never happened in Gloria, or in Vista.

Is it possible that there's a new monitor driver in Helena/Karmic which has a sleep setting built in? I didn't imagine a driver could do that, but maybe it can.

Husse
Level 23
Level 23
Posts: 18677
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: blank screen

Post by Husse »

This is driving me nuts - I have a few reports of screen going blank or similar after five or ten minutes and I can't figure out why
There has always been such reports but with Helena I see a few more, but it is no major problem
Unfortunately some of the people reporting problems have not told us which graphics card they use, but it is different types that are hit by it
Image
Don't fix it if it ain't broken, don't break it if you can't fix it

Brian49
Level 5
Level 5
Posts: 611
Joined: Thu Oct 29, 2009 2:27 pm

Re: blank screen

Post by Brian49 »

I'm glad I'm not the only one going nuts!

My card is an ATI Radeon X1300.

FeelFreak
Level 1
Level 1
Posts: 1
Joined: Tue Feb 02, 2010 9:46 am

Re: blank screen

Post by FeelFreak »

Code: Select all

xset q
Screen Saver:
prefer blanking: yes allow exposures: yes
timeout: 600 cycle: 600
600s = 10 minutes!

Code: Select all

gksudo gedit /etc/X11/xorg.conf
Add (if you already have a Section "ServerFlags" add the options there!):

Code: Select all

Section "ServerFlags"
	Option "BlankTime" "0"
	Option "StandbyTime" "0"
	Option "SuspendTime" "0"
	Option "OffTime" "0"
EndSection
Save it AND RESTART YOUR SYSTEM.

Code: Select all

xset q
Screen Saver:
prefer blanking: yes allow exposures: yes
timeout: 0 cycle: 600
This is how i solved the problem here - no more blank screens for me!
I hope someone could make it a little bit better! My solution is very nooby..
xset q should put out something like this:
Screen Saver:
prefer blanking: no allow exposures: no
timeout: 0 cycle: 0
But how can i control?!

Brian49
Level 5
Level 5
Posts: 611
Joined: Thu Oct 29, 2009 2:27 pm

Re: blank screen

Post by Brian49 »

FeelFreak - you beat me to it, I was just about to post something very similar.

By way of partial explanation for the benefit of other forum members, it appears that DPMS (Display Power Management Signaling) continues to run under the Xorg server, unaffected by whatever settings you choose in the GNOME Power Management dialog. So as you say, it's a matter of trying to get DPMS under control.

Creating the xorg.conf file (which doesn't exist by default in Helena) in the directory /etc/X11, with the zero-timeout server-flag settings you've specified, effectively disables DPMS. For good measure, you can also prevent DPMS from running in the first place, by creating a new startup application (I've named it "DPMS off"), based on the command "xset -dpms". These moves have cured the 10-minute blank-screen problem on my system too, although I realise they may be a workaround.

As far as I can figure it out, the screen-saver "Prefer blanking" setting in the xset readout is unrelated to this issue; it's about whether you see a blank screen when the saver is activated rather than a pattern.

From my reading on forums around the web, this issue has been present in Ubuntu for at least three years without anybody getting to grips with it.

Husse
Level 23
Level 23
Posts: 18677
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: blank screen

Post by Husse »

Thank you both
I was also thinking of DPMS but my lack of time prevented me from finding this, although I admit I should have
If you follow the xorg.conf line and have a ATI card that uses the fglrx driver this will not work
fglrx completely ignores xorg.conf and you have to change the amdpcsdb file that fglrx uses with this command

Code: Select all

sudo aticonfig --input=/etc/X11/xorg.conf --tls=1
I don't know if fglrx will obey so the startup solution is better
Oh - how did you make that startup app, would help if I don't have to think to get it :)
Image
Don't fix it if it ain't broken, don't break it if you can't fix it

Brian49
Level 5
Level 5
Posts: 611
Joined: Thu Oct 29, 2009 2:27 pm

Re: blank screen

Post by Brian49 »

I have an ATI card, but evidently it doesn't rely on the fglrx driver.

Creating a startup application: from the GNOME menu item System/Preferences/Startup Applications, bring up the dialog, click on Add in that window, fill in the details, and click on Add in that window. Then obviously tick the new application in the startup list.

You might like to mark this thread "partly solved". Many thanks.

walterav
Level 1
Level 1
Posts: 42
Joined: Fri May 29, 2009 5:25 am

Re: blank screen

Post by walterav »

I also have this problem on a machine with a gforce 4 ti 4200, and the Nvidia proprietary driver that ships with restricted Hardware&Drivers. In my situation it was 20 minutes.
terminal:
xset q #shows 1200 seconds instead of 600 so it makes sence.

I'll try the solution posted by feelfreak. I also found a old ubuntu thread with the same symptoms and solution from 3 years ago... also some nvidia got affected.
http://ubuntuforums.org/showthread.php?t=347079&page=2

UPDATE:
The fix works!

User avatar
linuxviolin
Level 8
Level 8
Posts: 2082
Joined: Tue Feb 27, 2007 6:55 pm
Location: France

Re: blank screen

Post by linuxviolin »

FeelFreak wrote:xset q should put out something like this:
Screen Saver:
prefer blanking: no allow exposures: no
timeout: 0 cycle: 0
Just for comparison, in CentOS 5.4 with a Nvidia card and the open driver "nv", I don't use the Nvidia driver, I have by default without changing anything:

Code: Select all

Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  0    cycle:  0

(...)

DPMS (Energy Star):
  Standby: 0    Suspend: 0    Off: 0
  DPMS is Enabled
  Monitor is On
But it's CentOS........ :roll:
K.I.S.S. ===> "Keep It Simple, Stupid"
"Simplicity is the ultimate sophistication." (Leonardo da Vinci)
"Everything should be made as simple as possible, but no simpler." (Albert Einstein)

Post Reply

Return to “MATE”