"Maximized" windows have small border; keep missing "close" button with mouse cursor

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon
Post Reply
fromWinToLin
Level 2
Level 2
Posts: 77
Joined: Thu Nov 19, 2009 11:53 am

"Maximized" windows have small border; keep missing "close" button with mouse cursor

Post by fromWinToLin » Thu Mar 08, 2018 12:09 pm

Certain applications either "attempt" to start maximized, such as the Mint Update Manager, or revert to a maximized state, such as VLC player, yet the problem is that they are not truly maximized because there is a small space from the top and corner of the screen.

In fact, this is 100% reproducable with the Mint Update Manager. Simply launch the Mint Update Manager, then throw your mouse cursor to the very upper right corner of the screen and try to close the window. You will not, since it will "miss" the close button by a pixel or two. This has been an issue for a long time now, yet I never knew what was at fault. Is each application? Is it GTK in general? It happened with Xfce as well, so it might not be unique to Cinnamon?

If the update manager is meant to start maximized, there is something that prevents it from doing so in that there is only a pixel or two that is breaking Fitt's law when trying to close the window quickly.

If I manually maximize the window, then it will work as normal, yet the problem returns when relaunching the application.

User avatar
smurphos
Level 8
Level 8
Posts: 2217
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher...

Re: "Maximized" windows have small border; keep missing "close" button with mouse cursor

Post by smurphos » Thu Mar 08, 2018 12:36 pm

Which windows borders theme are you using?

Can't say I've noticed a problem but I don't use any of the stock window border themes.

Bear in mind that if you have a top panel that is hidden there will be a 1 pixel width of panel activation space across the top of the screen.

Update Manager is not specifically supposed to open full screen but if you closed it from full screen it will open that way at next launch.

Edit - just double checked having moved my top panel to the side - no issue with the window border theme I'm using - Cinnamox-Kashmir-Blue downloadable from the Themes app. The close button is quite small in this theme but with the mouse right up in the corner the indicator is showing hover active and a click closes the app.

If I reopen there is a change - because it's not the natural window size I get the cursor switches to resize mode in the top corner. Are you not seeing a change in the cursor for resize mode?

fromWinToLin
Level 2
Level 2
Posts: 77
Joined: Thu Nov 19, 2009 11:53 am

Re: "Maximized" windows have small border; keep missing "close" button with mouse cursor

Post by fromWinToLin » Thu Mar 08, 2018 12:45 pm

smurphos wrote:
Thu Mar 08, 2018 12:36 pm
Which windows borders theme are you using?
Default. All defaults. However, changing the GTK theme and the Window Manager theme do not resolve this issue. As I wrote originally, this has been a problem even with previous versions of Mint.
Bear in mind that if you have a top panel that is hidden there will be a 1 pixel width of panel activation space across the top of the screen.
There is no top panel. Not even hidden.
Update Manager is not specifically supposed to open full screen but if you closed it from full screen it will open that way at next launch.
Not "full screen" but "maximized" window. All behavior points to the Update Manager opening as a maximized window, as should be expected. However, this "glitch" keeps it a pixel away from the edge, which makes it very frustrating to close the window. This is especially a nuisance when there is a maximized window behind it that gets accidentally closed. The only workaround is the manually maximize the window again, yet this is just a cheap hack workaround.

fromWinToLin
Level 2
Level 2
Posts: 77
Joined: Thu Nov 19, 2009 11:53 am

Re: "Maximized" windows have small border; keep missing "close" button with mouse cursor

Post by fromWinToLin » Thu Mar 08, 2018 12:47 pm

smurphos wrote:
Thu Mar 08, 2018 12:36 pm
Are you not seeing a change in the cursor for resize mode?
Could you rephrase that? I don't quite understand?

Edit: I think I know what you mean. If I swing my cursor to the upper right corner, it treats the corner as a "resize" anchor rather than a close button? Yes, this is what happens, and it's part of the frustration. I do recall accidentally closing the wrong windows as well, perhaps due to focus stealing. However, yes, it acts this way where it appears to be maximized, yet it is ever so slightly away from the corner (1 pixel?) that it is not treated as a maximized window. This is very frustrating and interrupts workflow. Update Manager is the easiest one to recall, yet I believe it has affected other applications that attempt to start in a maximized window.

User avatar
Spearmint2
Level 15
Level 15
Posts: 5746
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: "Maximized" windows have small border; keep missing "close" button with mouse cursor

Post by Spearmint2 » Thu Mar 08, 2018 4:07 pm

I use MATE and in Control Center there's a Desktop Settings where I chose Large Icons. Maybe that will help.

Does your monitor have inbuilt settings that will allow you to stretch the image on screen or move screen image to the top and right side more?
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....

fromWinToLin
Level 2
Level 2
Posts: 77
Joined: Thu Nov 19, 2009 11:53 am

Re: "Maximized" windows have small border; keep missing "close" button with mouse cursor

Post by fromWinToLin » Thu Mar 08, 2018 5:24 pm

Spearmint2 wrote:
Thu Mar 08, 2018 4:07 pm
I use MATE and in Control Center there's a Desktop Settings where I chose Large Icons. Maybe that will help.

Does your monitor have inbuilt settings that will allow you to stretch the image on screen or move screen image to the top and right side more?
This happens on different computers, different video cards, different monitors. Fresh installs with default settings. It's not unique to my setup. The problem with most bug reports and related, there is a loss of communication between those who know they are affected, those who don't mind it or don't know, and the developers themselves.

I'll soon provide a screen capture of this behavior. To reiterate, this is the default behavior. It's not something that is unique to a certain setup, configuration, or hardware.

Imagine that every time you launch Firefox or Chrome, it fills the entire screen and appears to be "maximized". (Keyword: appears). As with most users, launching a web browser on any operating system starts in a "maximized" window. Yet every time you instinctively throw your mouse cursor into the upper right corner of the screen to close the window, it instead grabs the corner. This can be tolerated for some time, but after a while you'll want to know how to fix it as it gets annoying and can also cause mis-clicks during the worst times. You'd get frustrated at having to always precisely aim your mouse cursor to close the window. If you manually maximize the window, then it's no problem, yet the next time you launch Firefox or Chrome, you're back to the same annoyance. Just replace "Firefox or Chrome" with "Mint Update Manager".

fromWinToLin
Level 2
Level 2
Posts: 77
Joined: Thu Nov 19, 2009 11:53 am

Re: "Maximized" windows have small border; keep missing "close" button with mouse cursor

Post by fromWinToLin » Thu Mar 08, 2018 5:51 pm

Here is some more interesting information. It appears related to non-GTK (or Qt) applications that "want" to maximize, yet instead take up the entire screen as a fully resized window. This happens on the following applications when restored from the tray icon or forced to re-launch as a maximized window:

* Mint Update Manager
* KeePassX
* VLC media player
* Clementine

I know for a fact that KeePassX, VLC media player, and Clementine use Qt.

This never happens with Transmission, Firefox, Chrome, Thunderbird, Nemo, and so on.

User avatar
smurphos
Level 8
Level 8
Posts: 2217
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher...

Re: "Maximized" windows have small border; keep missing "close" button with mouse cursor

Post by smurphos » Thu Mar 08, 2018 6:04 pm

Not sure about Clementine but the other three are apps that normally open windowed. Update manager and VLC are GTK.

Consider reporting it as.an issue on Github. I'd guess its something to do with them normally being windowed.

User avatar
Spearmint2
Level 15
Level 15
Posts: 5746
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: "Maximized" windows have small border; keep missing "close" button with mouse cursor

Post by Spearmint2 » Thu Mar 08, 2018 6:11 pm

You do know that double clicking the title bar will toggle between maximum and a smaller window?

open dconf-editor

go to >marco and the general section. You can increase the font size, also can place commas between the title bar maximize, minimize, and close button to spread them out. May find other settings that will help you achieve what you want. Also check the themes settings, may find a different theme that will help.

Maybe changing the work space wrap will do it.

The wrap style is used to determine how to switch from one workspace to another at the border of the workspace switcher. When set to "no wrap", nothing will happen if you try to switch to a workspace past the border of the workspace switcher. If set to "classic", the old marco behavior is used: the end of one row leads to the beginning of the next and the end of a column leads to the beginning of the next. If set to "toroidal", workspaces are connected like a doughnut: the end of each row leads to its own beginning and the end of each column leads to its own beginning.

there are settings in it for windows sizes for many programs.
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....

fromWinToLin
Level 2
Level 2
Posts: 77
Joined: Thu Nov 19, 2009 11:53 am

Re: "Maximized" windows have small border; keep missing "close" button with mouse cursor

Post by fromWinToLin » Thu Mar 08, 2018 11:11 pm

smurphos wrote:
Thu Mar 08, 2018 6:04 pm
Not sure about Clementine but the other three are apps that normally open windowed. Update manager and VLC are GTK.

Consider reporting it as.an issue on Github. I'd guess its something to do with them normally being windowed.
VLC is Qt since before version 1.0: https://wiki.videolan.org/Qt_and_GTK/

fromWinToLin
Level 2
Level 2
Posts: 77
Joined: Thu Nov 19, 2009 11:53 am

Re: "Maximized" windows have small border; keep missing "close" button with mouse cursor

Post by fromWinToLin » Thu Mar 08, 2018 11:13 pm

Spearmint2 wrote:
Thu Mar 08, 2018 6:11 pm
You do know that double clicking the title bar will toggle between maximum and a smaller window?

open dconf-editor

go to >marco and the general section. You can increase the font size, also can place commas between the title bar maximize, minimize, and close button to spread them out. May find other settings that will help you achieve what you want. Also check the themes settings, may find a different theme that will help.

Maybe changing the work space wrap will do it.
I appreciate the tips, yet none of those will resolve the core issue. Once I upload a screen capture, it will better demonstrate what is occurring.

User avatar
smurphos
Level 8
Level 8
Posts: 2217
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher...

Re: "Maximized" windows have small border; keep missing "close" button with mouse cursor

Post by smurphos » Fri Mar 09, 2018 5:30 am

fromWinToLin wrote:
Thu Mar 08, 2018 11:11 pm
VLC is Qt since before version 1.0: https://wiki.videolan.org/Qt_and_GTK/
Sorry my mistake - it pulls theme elements from GTK2 theme hence my mistake.

I can reproduce your issue with the Update manager - but not with VLC or KeepPassX.

You won't get the issue fixed here - https://github.com/linuxmint/muffin

For update manager assuming you don't need it maximised a work-around is to resize it to a reasonable size and then close it. It will open in that size subsequently.

fromWinToLin
Level 2
Level 2
Posts: 77
Joined: Thu Nov 19, 2009 11:53 am

Re: "Maximized" windows have small border; keep missing "close" button with mouse cursor

Post by fromWinToLin » Sat Mar 10, 2018 11:07 pm

I'm having difficulty making a presentable screen capture, since the mouse cursor skips many frames in the recording. Going to try something else.

As for maximizing the Update Manager, and then closing it, it will subsequently launch with the same "almost" maximized window, just as KeePassX and Clementine (both Qt) behave. (KeePassX only acts this way when restoring from the tray icon.) However, doing the same thing with any GTK application does exactly as you describe. They will launch as a maximized window and can easily be closed by throwing the mouse cursor to the top right corner of the screen.

JosephM
Level 6
Level 6
Posts: 1086
Joined: Sun May 26, 2013 6:25 pm

Re: "Maximized" windows have small border; keep missing "close" button with mouse cursor

Post by JosephM » Sun Mar 11, 2018 5:07 am

Taking a quick look at the code I think the update manager is saving the window width and height but not the window "state". That's what would tell it to restore to maximized instead of just the closed size.
When I give opinions, they are my own. Not necessarily those of any other Linux Mint developer or the Linux Mint project as a whole.

aes2011
Level 5
Level 5
Posts: 504
Joined: Wed Jul 06, 2011 10:39 pm

Re: "Maximized" windows have small border; keep missing "close" button with mouse cursor

Post by aes2011 » Sun Mar 11, 2018 6:11 am

@fromWinToLin, some applications accept "--open-maximized" as a switch. You could modify the .desktop file's "Exec=" line accordingly for such applications.

Alternatively, your window manager may allow you to set application-specific rules for normal windows (as opposed to dialogue windows).

BTW, which screen recorder are you using? I like Simple Screen Recorder.

Post Reply

Return to “Cinnamon”