Re: Destop icons auto-arrange after restart (Resolved)

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon
Post Reply
benchrest
Level 2
Level 2
Posts: 77
Joined: Tue Jan 17, 2012 2:19 pm

Re: Destop icons auto-arrange after restart (Resolved)

Post by benchrest » Thu Dec 06, 2018 12:06 pm

Yesterday I installed LAMP on my Cinnamon 19 dual monitor system. I had it installed on the previous release but now that it appeared stable after a couple of weeks I thought I could get my server working. After a reboot two problems occur,
1. icons appear auto-arranged on the left side of the primary monitor.
2. dragging an icon from its new location to the other monitor it doesn't move but it copies. There ends up two copies of the icon. One on each monitor. Dragging the icon to another spot on the primary monitor it does a normal move.
A reboot all goes back to the auto-arranged. This is a big deal for me as I have quit a few arranged by subject.
Desktop settings has "Show desktop icons on all monitors"
desktop has "auto-arrange" unchecked
I had gedit installed for a bit but it is uninstalled with no effect. Also I ran Nemo with sudo during the install. From post I have read it appears Nemo might be involved. I installed Launchy the day before.
Any ideas?
Last edited by benchrest on Thu Dec 20, 2018 1:12 pm, edited 1 time in total.
LM Cinnamon 19, ASUS M5A97 R2.0 MB, FX-4100, Samsung SSD 850 Pro 256gb, dual 24" monitors, MSI GEFORCE GTX 1050ti Areo ITX. Big user of Gramps, LibreOffice, Unison. Entire system on SSD, also WD black 500gb for backup.

kingsthane
Level 1
Level 1
Posts: 26
Joined: Wed Jan 18, 2012 1:38 pm

Re: Destop icons auto-arrange after restart

Post by kingsthane » Thu Dec 06, 2018 11:44 pm

Have you tried, rt click anywhere on desktop, left click on "Desktop", click to toggle "Auto Arrange" to off (if it is set to on)?

benchrest
Level 2
Level 2
Posts: 77
Joined: Tue Jan 17, 2012 2:19 pm

Re: Destop icons auto-arrange after restart

Post by benchrest » Fri Dec 07, 2018 12:50 pm

Auto-arrange is off.
I have a suspicion that I caused the problem. During the process of installing the LAMP products I was having problems with synapse which I have used for ever. It would not work correctly with 19. So I uninstalled it and installed Launchy. Launchy does seem to work. But anyhow after removing Synapse I searched for synapse in system files and found quite a few modules still there. One of my pet peeves is that programs that are removed do not really completely remove with lots of trash left. So I foolishly removed 50 or so modules to clean up. I suspect I deleted something I shouldn't have deleted. One thing that leads me to believe this is no one else seems to be having this problem. My plan now is to go over my installation documentation to update. And then upgrade to 19.1 in couple of weeks. If that doesn't fix the problem or if no one else reports the same issue I will reinstall fresh. If the problem still occurs open a bug report.
LM Cinnamon 19, ASUS M5A97 R2.0 MB, FX-4100, Samsung SSD 850 Pro 256gb, dual 24" monitors, MSI GEFORCE GTX 1050ti Areo ITX. Big user of Gramps, LibreOffice, Unison. Entire system on SSD, also WD black 500gb for backup.

benchrest
Level 2
Level 2
Posts: 77
Joined: Tue Jan 17, 2012 2:19 pm

Re: Destop icons auto-arrange after restart (Resolved)

Post by benchrest » Thu Dec 20, 2018 1:11 pm

I have tried several things, none of which worked. Deleted .config/nemo/desktop-metadata
Removed Nemo and reinstalled Nemo and Cinnamon (not for the faint of heart, do not recommend)
And lastly upgraded to 19.1 which has a lot of desktop upgrades. So I am writing this off as my doing and will do a fresh install of 19.1
If it reoccurs I will open new topic.
LM Cinnamon 19, ASUS M5A97 R2.0 MB, FX-4100, Samsung SSD 850 Pro 256gb, dual 24" monitors, MSI GEFORCE GTX 1050ti Areo ITX. Big user of Gramps, LibreOffice, Unison. Entire system on SSD, also WD black 500gb for backup.

stoffl
Level 1
Level 1
Posts: 22
Joined: Sun Sep 21, 2014 5:48 am

Re: Destop icons auto-arrange after restart (Resolved)

Post by stoffl » Fri Dec 21, 2018 8:41 am

I have the same problem: Each time I reboot, the icons are auto-arranged even though I've turned that off. It happened in 19 and also still in 19.1 (just updated)

Can you elaborate a bit more which steps you did to solve the problem? I also wonder a bit how nemo is involved here.

ajgreeny
Level 4
Level 4
Posts: 342
Joined: Mon Nov 19, 2007 3:27 pm

Re: Destop icons auto-arrange after restart (Resolved)

Post by ajgreeny » Fri Dec 21, 2018 9:41 am

I used to have the same problem in Xubuntu 14.04 and earlier.
I don't know where the configuration for cinnamon is saved but look for a config file for the desktop and see if there's a file which saves the icon positions in the same way that Xfce4 has in ~/.config/xfce4/desktop/icons.screen0-1904x1030.rc

When I used desktop icons, which I no longer do, I would make that icons------ file immutable with command

Code: Select all

sudo chattr +i path-to-file
Icons should then always be positioned in the same place at boot, or could be moved back to default with F5 to refresh the desktop.

If cinnamon does not have any similar file I do not have other ideas, unfortunately.

Post Reply

Return to “Cinnamon”