Enable maximizing window across multiple displays

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon
Post Reply
Feynt
Level 1
Level 1
Posts: 3
Joined: Wed Jun 19, 2019 2:43 pm

Enable maximizing window across multiple displays

Post by Feynt » Wed Jun 19, 2019 3:05 pm

Morning folks. Rather annoying issue, been working on it for the better part of the day, and frustratingly the closest I get to a solution is, "I want to stop my windows from spanning multiple monitors" followed by "Resolved!" across the net. >P

I have a Shuttle DL10J which I'm currently using a Mint 19.1 live USB on, attempting to get it to display output across three monitors using a splitter (a Startech displayport to 3 displayport splitter). The good news is automatically everything is set up and in order, so all three screens are being detected and are being made into individual desktops. The bad news is I'm trying to get it so that I can maximize a window and have it span all three screens and this does not appear to be my default, unlike some others who don't want that.

I've tried a few xorg.conf edits to enable xinerama to no avail, tried messing with arandr and a few other graphical desktop messer uppers, also with no success, and searching online seems to indicate that anyone having problems with multi-screen setups are having problems getting them to be detected in the first place. Anyone have any insights or suggestions to convince the computer that it should be using a single 5760x1080 @ 60fps desktop instead of three 1920x1080 desktops side by side? I know that this computer is capable of it because the default installed Windows 10 Pro can do it, I've set it up and used it that way. I'm just trying to decouple from Windows.

I believe the live USB uses Cinnamon as its windowing manager, but I haven't been able to find anything relevant to the past few months regarding it, and anything from 2016 and back seems to be useless.

jp734
Level 4
Level 4
Posts: 261
Joined: Wed Apr 27, 2011 12:18 pm

Re: Enable maximizing window across multiple displays

Post by jp734 » Wed Jun 19, 2019 7:00 pm

How did you enable xinerama? Did you add it under section "ServerLayout" of you xorg.conf?
Section "ServerLayout"
......
Option "Xinerama" "on"
EndSection
Intel Xeon X5470; [Multi-Boot] Puppy Linux 64Bit - Xenial 7.5; Win7; Radeon HD5850

Feynt
Level 1
Level 1
Posts: 3
Joined: Wed Jun 19, 2019 2:43 pm

Re: Enable maximizing window across multiple displays

Post by Feynt » Thu Jun 20, 2019 9:26 am

In this case Option "Xinerama" "1", as per Wideguy, but I had tried "on" previously when messing with xorg.conf myself. I've also set the Virtual property in the appropriate section with the resolution required, but no change. To confirm, Cinnamon does use /etc/X11/xorg.conf?

jp734
Level 4
Level 4
Posts: 261
Joined: Wed Apr 27, 2011 12:18 pm

Re: Enable maximizing window across multiple displays

Post by jp734 » Thu Jun 20, 2019 10:30 am

Not 100% sure but I believe if it exists, it will use it. There are also config files under /usr/share/X11/xorg.conf.d - If you look at your log file "/var/log/xorg.0.log", it will tell you what config file is used.
Intel Xeon X5470; [Multi-Boot] Puppy Linux 64Bit - Xenial 7.5; Win7; Radeon HD5850

Feynt
Level 1
Level 1
Posts: 3
Joined: Wed Jun 19, 2019 2:43 pm

Re: Enable maximizing window across multiple displays

Post by Feynt » Thu Jun 20, 2019 2:24 pm

The log mention was helpful, I keep forgetting the linux mentality of a centralised logging directory. At least in the log it does reference expanding the framebuffer to 5760x1080 (the intended 3 screen spread) toward the end. I followed this for setting the desktop size as one of my previous attempts, but it feels like it didn't do anything meaningful. Having read over the logs though, I've picked out some names for interfaces that I can reference in the Option sections in the Device heading. It shows them up as DP1-1-1, DP1-1-2, and DP1-2.

I'm going to try testing out altering the Device section as:

Code: Select all

Section "Device"
        Identifier      "Configured Video Device"
...
        Option          "DP1-1-1" "Left Monitor"
        Option          "DP1-1-2" "Middle Monitor"
        Option          "DP1-2" "Right Monitor"
EndSection
I believe I didn't configure this properly before, and it's as good a place as any to continue.

Addendum:

No luck, sadly. No error messages or anything indicating that it made a change at all. Interestingly when looking over the logs it states that there's a monitor connected to DP1, but not DP1-1-1, DP1-1-2, or DP1-2.

jp734
Level 4
Level 4
Posts: 261
Joined: Wed Apr 27, 2011 12:18 pm

Re: Enable maximizing window across multiple displays

Post by jp734 » Fri Jun 21, 2019 8:47 am

I was looking at my "/var/log/xorg.0.log" file and saw this:
[ 16.603] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[ 16.638] (==) No Layout section. Using the first Screen section.
[ 16.638] (==) No screen section available. Using defaults.
[ 16.638] (**) |-->Screen "Default Screen Section" (0)
[ 16.638] (**) | |-->Monitor "<default monitor>"
[ 16.641] (==) No monitor specified for screen "Default Screen Section".
Using a default monitor configuration.
So obviously, it tries to look for config files. If your system is the same thing,I would suggest creating separate config files for each item (device, monitor, screen and server layout) even if it's detecting connected monitors. Save all files under /usr/share/X11/xorg.conf.d folder
Intel Xeon X5470; [Multi-Boot] Puppy Linux 64Bit - Xenial 7.5; Win7; Radeon HD5850

Post Reply

Return to “Cinnamon”