(SOLVED) - Black screen after login

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon
Post Reply
The_Riskbreaker
Level 1
Level 1
Posts: 16
Joined: Mon Jun 18, 2012 11:43 am

(SOLVED) - Black screen after login

Post by The_Riskbreaker » Mon Jun 18, 2012 12:07 pm

Hello. Thanks for reading.
I switched my laptop over from Natty Ubuntu yesterday to Maya-13 w/ Cinnmaon in 64bit. Everything went fine. I was then able to copy over my backed up files, and I ran the commands to get my sources list back and reinstall all my old programs listed in that text file you can make. So far so good. Aside from a package issue that I snuffed with Synaptic, all was good. I shut down the machine and did some things. A few hours later I fired it up to do some writing. After logging in I get a black screen and a cursor. Nothing else happens. At first I though it was just loading so I left it there for a few minutes. Nothing changed. I hit the power button, then restarted and it still gave me that screen after logging in. I left it there for over ten minutes to no avail. HOWEVER, if I change the session option from the Xclient one to, gnome 2 for example, I get the gui and windows as normal. I really want my default Cinnamon back though.

I have this question also brewing on Ubuntu forums, but you guys may be able to answer this better. My graphics card is an intel integrated one (number slips my mind, but i doubt it matter as I was using the OS previously, even surfing, doing YouTube, and playing a round of Klotski) I have 4 gigs of ram and a 2.2ghz dual core proc.

I realize that Mint is based off of Ubuntu. But could me trying to install all my stuff from Natty have caused the window manager to do this? A conflict perhaps?

Another forum post I found said to do this... [sudo dpkg-reconfigure-mdm] I thought MDM was just the login though. Don't I need to run the command to reconfigure X?

Sorryt for the length, and many thanks for the help. Assuming it works like people are claiming I fully plan to become a donor soon.
Last edited by The_Riskbreaker on Wed Jun 20, 2012 12:21 pm, edited 1 time in total.

Seventh Reign
Level 1
Level 1
Posts: 22
Joined: Tue Jun 17, 2008 8:25 pm
Location: Southwestern Pennsylvania

Re: Black screen after login

Post by Seventh Reign » Mon Jun 18, 2012 1:50 pm

It may be possible to repair your current system, but given your apparent knowledge of how Linux works, I believe your best and most likely only option is a full system re-install. After you have re-installed, do not, under any circumstances, copy over your old sources list. This list is from an older version of a different system. It is obsolete and incompatible with Mint 13. IF you had any 3rd party PPA's installed, you will have to find the newer versions of them and install those manually.

H.A.N.D. :-)

sagirfahmid3
Level 6
Level 6
Posts: 1041
Joined: Sun Sep 04, 2011 12:39 pm

Re: Black screen after login

Post by sagirfahmid3 » Mon Jun 18, 2012 1:55 pm

Sooo...let me get this straight...
You used Ubuntu Natty (11.04) Narwhal's sources list...on Mint 13 (12.04)--a FULL TWO versions above Natty's version, AND you expect it to work?
Sorry to disappoint you, but that's not how things work in the OS world. That's like saying you want to run Windows 2000 programs on Windows 7 (it will work, just not well).
You basically DOWNgraded your UPgraded system and now you are asking for help with Cinnamon (which probably has gotten borked from what you did).

The_Riskbreaker
Level 1
Level 1
Posts: 16
Joined: Mon Jun 18, 2012 11:43 am

Re: Black screen after login

Post by The_Riskbreaker » Mon Jun 18, 2012 2:05 pm

If it's a knowledge issue i'm still gonna try and avoid the reinstall. I have a friend who lives nearby who is studying for his second cert from the Linux Institute., I'll call him if I need to. If it's the sources list I can fix that. I actually believe it's a driver issue, not a software/program one, which kind of explains why I can boot fine into any "session type" other than the Xclient. I'm gonna try and run some reconfiguring commands tonight.

Also, I realized it was wrong after it was too late do stuff. I figured Ubuntu apps would work in Mint. I don't think that's the issue. And I have a lot of programs that run in Windows 2000 and 7. I understand the analogy, but it's not right.

I always consider reinstalls the last option. If it truly is an irreversable mistake i'll accept it. But if it's a driver issue like I theorize, reinstalling would be awfully harsh.

The_Riskbreaker
Level 1
Level 1
Posts: 16
Joined: Mon Jun 18, 2012 11:43 am

Re: Black screen after login

Post by The_Riskbreaker » Wed Jun 20, 2012 9:19 am

Given that my wireless card now doesn't want to work, and that i keep getting messages about serious errors, i thought I might as well reinstall and then slowly update things from there. But I still worry that the problem of logging in and having no window manager (WM) load will come back. Am I right in saying that a black screen with a cursor only is a result of the WM not loading? I know that since i'm using an Intel Integrated 960/965 I might have to change xorg.conf from "vesa" to "intel" to fix minor issues, but i know that didn't fix the black screen.

When I did I the initial install it worked fine while installing updates and some light surfing. It wasn't until i restarted that the OS started that the black screen issue started. So is it possible that a program install/update caused my WM issue? Because if that's the case I should be able to take care of the issue this time. Is there anything else that can cause this? Perhaps a 64 bit issue since i'm running that type?

Thanks for the thoughts.

sagirfahmid3
Level 6
Level 6
Posts: 1041
Joined: Sun Sep 04, 2011 12:39 pm

Re: Black screen after login

Post by sagirfahmid3 » Wed Jun 20, 2012 12:04 pm

YOU...CAN...NOT...USE UBUNTU NATTY'S REPOSITORIES ON MINT 13, THAT'S THE BOTTOM LINE.
If you fail to understand this, well good luck with whatever the heck you're doing because all it's going to do is wreck your system and waste your time and forum users' time.

Good day

The_Riskbreaker
Level 1
Level 1
Posts: 16
Joined: Mon Jun 18, 2012 11:43 am

(SOLVED) - Black screen after login

Post by The_Riskbreaker » Wed Jun 20, 2012 12:21 pm

I appreciate the tone. I'm not using Natty's repo's anymore. It appears the graphical issue is the result of a "vesa" versus "intel". The wireless issue may have been caused by my repo use but i took notes regarding what apps i was suing and I will reinstall them all manually as there weren't a lot. I'm doing all the updating by hand to ensure no issues arise.

Thanks for the attempted assist. Calling the issue solved.

Post Reply

Return to “Cinnamon”