Brightness Control

Please post suggestions for improvement of Cinnamon on:
https://github.com/linuxmint/Cinnamon
Forum rules
Before you post read how to get help. Topics in this forum are automatically closed 6 months after creation.
Locked
ahimmerman

Brightness Control

Post by ahimmerman »

Hello,

I'm running Linux Mint 13 stock with Cinnamon on a Lenovo ThinkPad W520 4276-39U laptop with an NVIDIA Quadro M1000 GF108GL (NVIDIA driver version 295.40). The Fn+Home and Fn+End (LED brightness increase and decrease, respectively), works when in consoles; however, in Cinnamon, they don't. When those keys are clicked, the brightness slider pops up and indicates changes, though brightness doesn't change. Also, the software brightness control, under Cinnamon Settings: Brightness and Lock, also has no effect.

Not sure if it's relevant, though, while trying to work through the issue, I switched the kernel from acpi_backlight=vendor (implicit default) to acpi_backlight=thinkpad_acpi. When operating under that driver, Fn+Home and Fn+End poped the brightness slider up, yet no change was indicated (and no change occurred). Also, under that driver, unhandled HKEY events were sent to syslog. Since then, I've restored the default configuration.

Any assistance would be appreciated.

Andrew
Last edited by LockBot on Wed Dec 28, 2022 7:16 am, edited 1 time in total.
Reason: Topic automatically closed 6 months after creation. New replies are no longer allowed.
okko7

Re: Brightness Control

Post by okko7 »

Try the following: 

Code: Select all

sudo nvidia-xconfig
(if there is no xorg.conf file yet)

Then

Code: Select all

sudo gedit /etc/X11/xorg.conf
Under "Section "Screen", before "EndSection" add:

Code: Select all

Option  "RegistryDwords" "EnableBrightnessControl=1"
So that section would look something like this (yours might not be exactly the same) -

Code: Select all

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
    Option      "RegistryDwords" "EnableBrightnessControl=1"
EndSection
Then reboot.
AmneetBedi

Re: Brightness Control

Post by AmneetBedi »

Facing the same problem on Acer Aspire 5749 running Linux Mint 13 cinnamon. Tried modifying xorg.conf file as suggested above, but the issue still persists.
lunatico

Re: Brightness Control

Post by lunatico »

Running Linux Mint 13 Cinnamon 32-bit on a Thinkpad W520. I was also having this problem and the suggestion from okko7 did fix it for me.

Thanks!
Lebrontron

Re: Brightness Control

Post by Lebrontron »

I did this on my Lenovo z570 with a onboard intel graphics card. After restarting i got a prompt that X server has stopped working. Then on the command line i renamed the xorg.conf file i created to xorg.conf.failsafe and i could reboot the system into cinnamon. What's the right way please suggest.
baliiii

Re: Brightness Control

Post by baliiii »

@okko7
Thanks mate.
jvb

Re: Brightness Control

Post by jvb »

@okko7 works for me too.

I had recently (19th August 2012) installed the latest graphics driver from NVIDIA (file:///home/jvb/downloads/installed/NVIDIA-Linux-x86_64-304.37.run) and lost the use of the brightness keys too, probably due to overwriting xconf.org in the NVIDIA driver installatiion.

x64 Linux Mint Debian Edition
Xethron

Re: Brightness Control

Post by Xethron »

@okko7 Thanks! This works great! Bookmarked!
muzule

Re: Brightness Control

Post by muzule »

works for me too mate! and I had to dig deep!
I've a W510 with Mint 17.
Thank you so much!
obscenic

Re: Brightness Control

Post by obscenic »

This also worked for me (Lenovo T510) on Mint 17 too. Thank you!
Locked

Return to “Cinnamon”