Screen Tear - Panel Auto Hide

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon
Post Reply
mrwes_40
Level 1
Level 1
Posts: 7
Joined: Fri Sep 28, 2012 12:57 pm

Screen Tear - Panel Auto Hide

Post by mrwes_40 » Fri Sep 28, 2012 1:00 pm

Hey all,

I'm looking for a possible solution to excessive screen tear when running Cinnamon 1.6.1 and the when the panel is set to auto hide. Here's my video card information:

lspci | grep VGA
00:01.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Device 9647


Thanks,
Bill

lurkatron
Level 3
Level 3
Posts: 127
Joined: Tue Nov 01, 2011 2:18 pm

Re: Screen Tear - Panel Auto Hide

Post by lurkatron » Fri Sep 28, 2012 2:38 pm

im not sure if this is relevant but i had a lot of video tearing with my nvidia gtx670 card. no idea if it can help but it solved all my problems:
sudo gedit /etc/environment
add at bottom:
CLUTTER_PAINT=disable-clipped-redraws:disable-culling
CLUTTER_VBLANK=True

reboot

User avatar
Thongar
Level 1
Level 1
Posts: 4
Joined: Mon Sep 24, 2012 12:24 am
Location: Ontario, Canada

Re: Screen Tear - Panel Auto Hide

Post by Thongar » Fri Sep 28, 2012 5:53 pm

Re: Screen Tear - Panel Auto Hide
by lurkatron on Fri Sep 28, 2012 2:38 pm

im not sure if this is relevant but i had a lot of video tearing with my nvidia gtx670 card. no idea if it can help but it solved all my problems:
sudo gedit /etc/environment
add at bottom:
CLUTTER_PAINT=disable-clipped-redraws:disable-culling
CLUTTER_VBLANK=True

reboot
Thanks lurkatron! :D its been driving me nuts in LMDE been tracking sid for a few months now and on my main box. But most recently updating to Cinnamon 1.6 my flash video's began having crazy tearing with flash video's and those two lines added to my /etc/environment fixed that.

lurkatron
Level 3
Level 3
Posts: 127
Joined: Tue Nov 01, 2011 2:18 pm

Re: Screen Tear - Panel Auto Hide

Post by lurkatron » Fri Sep 28, 2012 7:20 pm

thongar, those 2 lines are basicaly stolen from the compiz settings thing, cos it worked in compiz, cinnamon doesent have a gui for it (yet) - hopefully it will in time :)

User avatar
Thongar
Level 1
Level 1
Posts: 4
Joined: Mon Sep 24, 2012 12:24 am
Location: Ontario, Canada

Re: Screen Tear - Panel Auto Hide

Post by Thongar » Fri Sep 28, 2012 8:23 pm

lurkatron wrote:thongar, those 2 lines are basicaly stolen from the compiz settings thing, cos it worked in compiz, cinnamon doesent have a gui for it (yet) - hopefully it will in time :)

Lol yeah a gui option would be nice since I'm sure most don't wanna go around looking for what config file to edit lol. I don't mind been doing that for way to long but thanks again :)

mrwes_40
Level 1
Level 1
Posts: 7
Joined: Fri Sep 28, 2012 12:57 pm

Re: Screen Tear - Panel Auto Hide

Post by mrwes_40 » Sat Sep 29, 2012 6:10 am

lurkatron wrote:im not sure if this is relevant but i had a lot of video tearing with my nvidia gtx670 card. no idea if it can help but it solved all my problems:
sudo gedit /etc/environment
add at bottom:
CLUTTER_PAINT=disable-clipped-redraws:disable-culling
CLUTTER_VBLANK=True

reboot
Thanks for the input. That setting worked for a few seconds and then my screen started flickering and tearing with the panel set to auto hide.

Bill

AUserInEssex
Level 3
Level 3
Posts: 127
Joined: Thu May 01, 2014 8:21 pm

Re: Screen Tear - Panel Auto Hide

Post by AUserInEssex » Sun Nov 02, 2014 1:42 am

That hack didn't work for me either, I am afraid (though the problem does indeed seem to be caused by auto-hide).

AUserInEssex
Level 3
Level 3
Posts: 127
Joined: Thu May 01, 2014 8:21 pm

Re: Screen Tear - Panel Auto Hide

Post by AUserInEssex » Sat Dec 27, 2014 9:06 am

I take the liberty of resurrecting this thread in order to post a solution (although one that I presume will work only on systems with Intel graphics).

Code: Select all

sudo apt-get remove xserver-xorg-video-intel && sudo apt-get install xserver-xorg-video-intel
Then reboot.

This worked for me - no more tearing/flickering.

Paper Bag
Level 1
Level 1
Posts: 17
Joined: Fri Dec 31, 2010 1:20 pm

Re: Screen Tear - Panel Auto Hide

Post by Paper Bag » Sat Feb 14, 2015 1:52 pm

AUserInEssex wrote:I take the liberty of resurrecting this thread in order to post a solution (although one that I presume will work only on systems with Intel graphics).

Code: Select all

sudo apt-get remove xserver-xorg-video-intel && sudo apt-get install xserver-xorg-video-intel
Then reboot.

This worked for me - no more tearing/flickering.
I think you just had old / different drivers, thus the tearing was somehow solved as a side effect. I don't think this will solve it for most people though.

Post #2 solution worked for me (no more tearing on mplayer (VAAPI), VLC (VAAPI), HTML5 (Chrome) or Flash (PepperFlash/Chrome).

Post Reply

Return to “Cinnamon”