System Settings Cannot Display Image Correctly [SOLVED]

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon
Post Reply
jqx1990
Level 1
Level 1
Posts: 7
Joined: Wed Oct 03, 2012 2:21 pm

System Settings Cannot Display Image Correctly [SOLVED]

Post by jqx1990 » Wed Oct 03, 2012 2:28 pm

As you see here, the icon shows the "stop sign"/"no image sign". This issue has bothered me for a long time. Is there a possible way to fix this without re-installing the OS? The OS is maya-cinnamon.

Thank you! :D
Attachments
123.png
123.png (91.16 KiB) Viewed 867 times
Last edited by jqx1990 on Sun Oct 14, 2012 6:24 pm, edited 1 time in total.

remoulder
Level 17
Level 17
Posts: 7638
Joined: Fri May 09, 2008 1:14 pm
Contact:

Re: System Settings Cannot Display Image Correctly

Post by remoulder » Wed Oct 03, 2012 8:10 pm

I'm sure if anyone can work out what you are talking about they may be able to help. Have you tried changing themes?
[Edit] your original post and add [SOLVED] once your question is resolved.

“The people are my God” stressing the factor determining man’s destiny lies within man not in anything outside man, and thereby defining man as the dominator and remoulder of the world.

abnvolk
Level 4
Level 4
Posts: 491
Joined: Thu May 10, 2012 11:05 am

Re: System Settings Cannot Display Image Correctly

Post by abnvolk » Thu Oct 04, 2012 6:04 am

The Humanity icon theme has those 3 icons.

jqx1990
Level 1
Level 1
Posts: 7
Joined: Wed Oct 03, 2012 2:21 pm

Re: System Settings Cannot Display Image Correctly

Post by jqx1990 » Thu Oct 04, 2012 2:55 pm

remoulder wrote:I'm sure if anyone can work out what you are talking about they may be able to help. Have you tried changing themes?
I have tried to change Cinnamon theme which didn't work. As for GNOME themes, I will try. Thank you!

jqx1990
Level 1
Level 1
Posts: 7
Joined: Wed Oct 03, 2012 2:21 pm

Re: System Settings Cannot Display Image Correctly

Post by jqx1990 » Thu Oct 04, 2012 2:58 pm

abnvolk wrote:The Humanity icon theme has those 3 icons.
Thank you. I will try to move those three icons to Mint theme.

lurkatron
Level 3
Level 3
Posts: 127
Joined: Tue Nov 01, 2011 2:18 pm

Re: System Settings Cannot Display Image Correctly

Post by lurkatron » Thu Oct 04, 2012 3:21 pm

same thing here. dont care

jqx1990
Level 1
Level 1
Posts: 7
Joined: Wed Oct 03, 2012 2:21 pm

Re: System Settings Cannot Display Image Correctly

Post by jqx1990 » Thu Oct 04, 2012 10:31 pm

Hello everyone,

I did some searching about where exactly those missing icon is. I got some places, like /usr/share/icons. But they are not here. Can anyone point out the file location?

Thank all you!

User avatar
Sopwith_Camel
Level 1
Level 1
Posts: 10
Joined: Tue Jan 04, 2011 6:15 pm
Location: UK

Re: System Settings Cannot Display Image Correctly

Post by Sopwith_Camel » Sun Oct 14, 2012 3:55 pm

Hi,

You just need to add a few icons to /usr/share/icons/[current icon theme]/categories/24 - see this page for downloadable icon files and instructions. (Alternatively, add some .svg icons of your choice into that folder, and rename them accordingly.)

Tried the download-and-install just now; worked fine. :)
Last edited by Sopwith_Camel on Sun Oct 14, 2012 6:54 pm, edited 1 time in total.

jqx1990
Level 1
Level 1
Posts: 7
Joined: Wed Oct 03, 2012 2:21 pm

Re: System Settings Cannot Display Image Correctly

Post by jqx1990 » Sun Oct 14, 2012 6:24 pm

Sopwith_Camel wrote:Hi,

You just need to add a few icons to /usr/share/icons/[current icon theme]/categories/24 - see this page for downloadable icon files and instructions. (Alternatively, add some .svg icons of your choice into that folder, and rename them accordingly.)

Tried the download just now; worked fine. :)
Thank you for the help! It worked after some modifications to the help.
The instruction page gives a file of svg files. I first put them into /usr/share/icons/[current icon theme]/categories/24. It did not work. I guess because all files in this folder are supposed to be png. So instead I put them into /usr/share/icons/[current icon theme]/scalable. It worked right away!!

Thank you again for the help!

User avatar
Sopwith_Camel
Level 1
Level 1
Posts: 10
Joined: Tue Jan 04, 2011 6:15 pm
Location: UK

Re: System Settings Cannot Display Image Correctly [SOLVED]

Post by Sopwith_Camel » Sun Oct 14, 2012 6:52 pm

Brilliant! Sorry it didn't work first time, but glad you got it sorted. :D

jqx1990
Level 1
Level 1
Posts: 7
Joined: Wed Oct 03, 2012 2:21 pm

Re: System Settings Cannot Display Image Correctly [SOLVED]

Post by jqx1990 » Sun Oct 14, 2012 6:58 pm

Sopwith_Camel wrote:Brilliant! Sorry it didn't work first time, but glad you got it sorted. :D
Thanks!

caribriz
Level 5
Level 5
Posts: 938
Joined: Mon Nov 28, 2011 7:43 am

Re: System Settings Cannot Display Image Correctly [SOLVED]

Post by caribriz » Sun Oct 14, 2012 7:39 pm

Thank you Sopwith_Camel and jqx1990 :D

I'm using Faenza-Cupertino icons and I placed the new icons in /home/my-username/.icons/Faenza-Cupertino/places/scalable
(and just for good measure :wink: ) into /home/d/.icons/Faenza-Cupertino/actions/scalable.

Also changed the preferences-system-directory.svg Ubuntu icon to a Linux Mint icon instead.
I didn't have a .svg icon so used a .png and renamed it to preferences-system-directory.png.
It worked as well.

Thanks for the fix -
caribriz
Desktop: C2D E6400 / Asus P5LD2SE / 2GB ram / Asus GeForce 210 / 320GB (WinXP) & 1TB (Mint - various)
Laptop: Asus A53E-SX1455V - i5 2450M / 4GB ram / Intel HD 3000 / 500GB (Win7/Mint 18.3 Cinnamon)

jqx1990
Level 1
Level 1
Posts: 7
Joined: Wed Oct 03, 2012 2:21 pm

Re: System Settings Cannot Display Image Correctly [SOLVED]

Post by jqx1990 » Mon Oct 15, 2012 3:19 am

Hi caribriz,

Thank you for sharing the new way.

jqx1990

Post Reply

Return to “Cinnamon”